IPv6 ne cessera jamais de m'étonner

Le
Stephane Bortzmeyer
Soit une machine Debian lenny où IPv6 fonctionnait bien (via Free,
avec la Freebox qui émet des RA et la machine qui se configure
dessus).

Je change la carte Ethernet, une 3c905 est remplacée par une Realtek
8168. C'est tout.

Depuis, IPv6 déconne. La certe met plusieurs minutes à configurer son
adresse globale (je vois bien les RA avec tcpdump mais on dirait que
la carte ne les voit pas tout de suite).

Une fois l'adresse globale (et les routes) configurées, la carte
marche une heure ou deux puis la route par défaut disparait et avec
elle mes espoirs de faire de l'IPv6.

En IPv4, tout marche bien comme avant. Sur le même
réseau local, avec la même Freebox, une machine Ubuntu et une machine
NetBSD n'ont pas de problèmes avec IPv6.

Lorsque IPv6 stoppe, ifdown eth1 && ifup eth1 et on recommence à zéro
(plusieurs minutes avant d'avoir une adresse IPv6).

La nouvelle carte :

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

dmesg affiche :

[ 9.748547] eth0: RTL8168c/8111c at 0xf8956000, 00:1e:8c:76:29:b6, XID 3c2000c0 IRQ 220
[ 10.134356] udev: renamed network interface eth0 to eth1
[ 15.718933] r8169: eth1: link up
[ 15.718933] r8169: eth1: link up
[ 27.132877] eth1: no IPv6 routers present


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain Sauvage
Le #18958731
Goldy, dimanche 22 mars 2009, 23:01:05 CET

Stephane Bortzmeyer a écrit :
[…]
> Je change la carte Ethernet, une 3c905 est remplacée par une Realt ek
> 8168. C'est tout.
>
> Depuis, IPv6 déconne. La certe met plusieurs minutes à config urer son
> adresse globale (je vois bien les RA avec tcpdump mais on dirait que
> la carte ne les voit pas tout de suite).
[…]
Bonjour,



’soir,

Ce pilote réseau est buggué, j'ai également eu des probl èmes mais avec
le multicast (le trafique multicast entrant est bloqué en ipv4, voir un
ancien thread sur avahi dans ce groupe).

Je pense qu'il vaut mieux éviter d'utiliser ce pilote réseau po ur l'instant.



Vu que IPv6 utilise beaucoup le multicast, notamment pour la
configuration, les deux problèmes n’en font peut-être bien
qu’un…

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Goldy
Le #18958721
Stephane Bortzmeyer a écrit :
Soit une machine Debian lenny où IPv6 fonctionnait bien (via Free,
avec la Freebox qui émet des RA et la machine qui se configure
dessus).

Je change la carte Ethernet, une 3c905 est remplacée par une Realtek
8168. C'est tout.

Depuis, IPv6 déconne. La certe met plusieurs minutes à configurer son
adresse globale (je vois bien les RA avec tcpdump mais on dirait que
la carte ne les voit pas tout de suite).

Une fois l'adresse globale (et les routes) configurées, la carte
marche une heure ou deux puis la route par défaut disparait et avec
elle mes espoirs de faire de l'IPv6.

En IPv4, tout marche bien comme avant. Sur le même
réseau local, avec la même Freebox, une machine Ubuntu et une machine
NetBSD n'ont pas de problèmes avec IPv6.

Lorsque IPv6 stoppe, ifdown eth1 && ifup eth1 et on recommence à zéro
(plusieurs minutes avant d'avoir une adresse IPv6).

La nouvelle carte :

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

dmesg affiche :

[ 9.748547] eth0: RTL8168c/8111c at 0xf8956000, 00:1e:8c:76:29:b6, XID 3c2000c0 IRQ 220
[ 10.134356] udev: renamed network interface eth0 to eth1
[ 15.718933] r8169: eth1: link up
[ 15.718933] r8169: eth1: link up
[ 27.132877] eth1: no IPv6 routers present






Bonjour,

Ce pilote réseau est buggué, j'ai également eu des problèmes mais avec
le multicast (le trafique multicast entrant est bloqué en ipv4, voir un
ancien thread sur avahi dans ce groupe).

Je pense qu'il vaut mieux éviter d'utiliser ce pilote réseau pour l'instant.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Stephane Bortzmeyer
Le #18965701
On Sun, Mar 22, 2009 at 11:01:05PM +0100,
Goldy a message of 54 lines which said:

Ce pilote réseau est buggué, j'ai également eu des problèmes mais avec
le multicast (le trafique multicast entrant est bloqué en ipv4, voir un
ancien thread sur avahi dans ce groupe).

Je pense qu'il vaut mieux éviter d'utiliser ce pilote réseau pour l'instant.



Et lequel utiliser alors ? Celui qui distribue Realtek sur son site
(et qui compilait en etch) ne marche plus en lenny :

% make
...
CC [M] /local/src/Realtek-RTL8168C/src/r8168_n.o
/local/src/Realtek-RTL8168C/src/r8168_n.c: In function 'rtl8168_init_board':
/local/src/Realtek-RTL8168C/src/r8168_n.c:2270: error: implicit declaration of function 'SET_MODULE_OWNER'
/local/src/Realtek-RTL8168C/src/r8168_n.c: In function 'rtl8168_init_one':
/local/src/Realtek-RTL8168C/src/r8168_n.c:2570: error: 'struct net_device' has no member named 'poll'
/local/src/Realtek-RTL8168C/src/r8168_n.c:2571: error: 'struct net_device' has no member named 'weight'
...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Alain Nicolas
Le #18965841
--_6d896745-9484-40df-952e-6d07defbf27c_
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable


Bonjour,

Je sais que cela fait cent fois que la question a été posée, mais e n désespoir de cause, je m'en remets à vous.

Impossible de se désinscrire de cette (sorry) "foutue" liste de diffusion , j'ai tout essayé : le unsubscribe en majuscules, minuscules, acco mpagné ou non d'un texte et cela fait des mois que je continue à recevo ir des dizaines, que dis-je ces centaines de messages, probablement for ts instructifs, mais voilà, je n'en ai pas (plus) besoin !

Alors de grâce si quelqu'un ici peut quelque chose pour moi faites-le, délivrez-moi de cette nom de D... de put... liste ! Dieu (s'il existe) vo us le rendra au centuple !



Mille merci d'avance !

Alain



_________________________________________________________________
Téléphonez gratuitement à tous vos proches avec Windows Live Messenge r  !  Téléchargez-le maintenant ! 
http://www.windowslive.fr/messenger/1.asp
--_6d896745-9484-40df-952e-6d07defbf27c_
Content-Type: text/html; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<html>
<head>
<style>
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
font-size: 10pt;
font-family:Verdana
}
</style>
</head>
<body class='hmmessage'>
Bonjour,<BR>
Je sais que cela fait cent fois que la question a été posée, mais e n désespoir de cause, je m'en remets à vous.<BR>
Impossible de se désinscrire de cette (sorry) "foutue" liste de diffusion , j'ai tout essayé : le unsubscribe en majuscules, minuscules, acco mpagné ou non d'un texte et cela fait des mois que je continue à recevo ir des dizaines, que dis-je ces centaines de messages, probablement for ts instructifs, mais voilà, je n'en ai pas (plus) besoin !<BR>
Alors de grâce si quelqu'un ici peut quelque chose pour moi faites-le, délivrez-moi de cette nom de D... de put... liste ! Dieu (s'il existe)&nb sp;vous le&nbsp;rendra au centuple !<BR>
&nbsp;<BR>
Mille merci d'avance !<BR>
Alain<BR>
&nbsp; </html>
--_6d896745-9484-40df-952e-6d07defbf27c_--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Stephane Bortzmeyer
Le #18966101
On Sun, Mar 22, 2009 at 11:01:05PM +0100,
Goldy a message of 54 lines which said:

Ce pilote réseau est buggué, j'ai également eu des problèmes mais avec
le multicast (le trafique multicast entrant est bloqué en ipv4, voir un
ancien thread sur avahi dans ce groupe).



OK, j'ai finalement réussi à compiler le pilote Relatek et ça semble
marcher, IPv4 et IPv6, donc, c'était bien ça. Merci beaucoup.

J'ai documenté en :

http://www.bortzmeyer.org/install-debian-realtek-RTL8168.html

...

Donc, la solution, trouvée sur
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.24/+bug/141343/comments/21
a été de télécharger un patch du pilote
(http://launchpadlibrarian.net/14011806/r8168-8.005.00.hardy.diff.txt),
de l'appliquer avec cd src; patch -p1 <
../r8168-8.005.00.hardy.diff.txt et de recompiler le pilote. (Le
"patch" est pour la version 005 du pilote RealTtek, version que j'avais
gardée des manipulations précédentes, pas la toute dernière qui est la
011 mais je suppose que l'adaptation n'est pas trop difficile.)

Après cela, tout semble marcher. dmesg affiche :

[ 9.028941] eth0: Identified chip type is 'RTL8168C/8111C'.
[ 9.028941] eth0: RTL8168B/8111B at 0xf897e000, 00:1e:8c:76:29:b6, IRQ 18

et IPv4 et IPv6 marchent.



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Adrien
Le #18966091
Salut,

Un mail à avec comme suje t « unsubscribe » ne marche pas ?
Ton client mail a sûrement un bouton « se désinscrir e de la liste » (message, puis liste de diffusion dans claws-m ail)

Sinon la prochaine fois tu peux aussi passer par gmane pour avoir la liste comme newsgroup ; C’est très pratique :)

adrien

En cette soirée du lundi 23 mars 2009,
Alain Nicolas
Impossible de se désinscrire de cette (sorry) "foutue" liste de diff usion, j'ai tout essayé : le unsubscribe en majuscules, minuscules, ac compagné ou non d'un texte et cela fait des mois que je continue à   recevoir des dizaines, que dis-je ces centaines de messages, probableme nt forts instructifs, mais voilà, je n'en ai pas (plus) besoin !




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Nicolas PHAM
Le #18966081
On Mon, 23 Mar 2009 22:36:43 +0100, Alain Nicolas
Bonjour,

Je sais que cela fait cent fois que la question a été posée, mais en
désespoir de cause, je m'en remets à vous.

Impossible de se désinscrire de cette (sorry) "foutue" liste de


diffusion,
j'ai tout essayé : le unsubscribe en majuscules, minuscules, accompagné
ou non d'un texte et cela fait des mois que je continue à recevoir des
dizaines, que dis-je ces centaines de messages, probablement forts
instructifs, mais voilà, je n'en ai pas (plus) besoin !

Alors de grâce si quelqu'un ici peut quelque chose pour moi faites-le,
délivrez-moi de cette nom de D... de put... liste ! Dieu (s'il existe)
vous le rendra au centuple !



Mille merci d'avance !

Alain



Salut,
pour ma part j'écris un mail en texte seul à
(faut pas oublier le 'request')
avec unsubscribe en objet et unsubscribe dans le corps du mail. Ca marche
à tout les coups !
@+

--
Nicolas PHAM

eMail : nicolas[at]phamily.fr
Jabber : nicop[at]jabber.fr
Site : http://nico.phamily.fr

Propulsé par Debian GNU/Linux - Vers l'infini et au-delà !
Membre de l'April - http://www.april.org - Promouvoir et défendre le
logiciel libre
--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Frédéric Massot
Le #18967631
Stephane Bortzmeyer a écrit :
On Sun, Mar 22, 2009 at 11:01:05PM +0100,
Goldy a message of 54 lines which said:

Ce pilote réseau est buggué, j'ai également eu des problèmes mais avec
le multicast (le trafique multicast entrant est bloqué en ipv4, voir un
ancien thread sur avahi dans ce groupe).



OK, j'ai finalement réussi à compiler le pilote Relatek et ça semble
marcher, IPv4 et IPv6, donc, c'était bien ça. Merci beaucoup.

J'ai documenté en :

http://www.bortzmeyer.org/install-debian-realtek-RTL8168.html



Bonjour,

L'un d'entre vous a t-il remonté le bug du pilote r8168 dans le bugzilla
de Linux : http://bugzilla.kernel.org ?

--
============================================= | FRÉDÉRIC MASSOT |
| http://www.juliana-multimedia.com |
| mailto: |
==========================Þbian=GNU/Linux==
--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Goldy
Le #18969891
Stephane Bortzmeyer a écrit :
On Sun, Mar 22, 2009 at 11:01:05PM +0100,
Goldy a message of 54 lines which said:

Ce pilote réseau est buggué, j'ai également eu des problèmes mais avec
le multicast (le trafique multicast entrant est bloqué en ipv4, voir un
ancien thread sur avahi dans ce groupe).

Je pense qu'il vaut mieux éviter d'utiliser ce pilote réseau pour l'instant.



Et lequel utiliser alors ? Celui qui distribue Realtek sur son site
(et qui compilait en etch) ne marche plus en lenny :

% make
...
CC [M] /local/src/Realtek-RTL8168C/src/r8168_n.o
/local/src/Realtek-RTL8168C/src/r8168_n.c: In function 'rtl8168_init_board':
/local/src/Realtek-RTL8168C/src/r8168_n.c:2270: error: implicit declaration of function 'SET_MODULE_OWNER'
/local/src/Realtek-RTL8168C/src/r8168_n.c: In function 'rtl8168_init_one':
/local/src/Realtek-RTL8168C/src/r8168_n.c:2570: error: 'struct net_device' has no member named 'poll'
/local/src/Realtek-RTL8168C/src/r8168_n.c:2571: error: 'struct net_device' has no member named 'weight'
...




Pour ma part, j'ai changé d'interface réseau. Je suis allé acheter une
carte PCI, c'est pas pour ce que ça coute...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Goldy
Le #18969881
Frédéric Massot a écrit :
Stephane Bortzmeyer a écrit :
On Sun, Mar 22, 2009 at 11:01:05PM +0100,
Goldy
Ce pilote réseau est buggué, j'ai également eu des problèmes mais avec
le multicast (le trafique multicast entrant est bloqué en ipv4, voir un
ancien thread sur avahi dans ce groupe).



OK, j'ai finalement réussi à compiler le pilote Relatek et ça semble
marcher, IPv4 et IPv6, donc, c'était bien ça. Merci beaucoup.

J'ai documenté en :

http://www.bortzmeyer.org/install-debian-realtek-RTL8168.html



Bonjour,

L'un d'entre vous a t-il remonté le bug du pilote r8168 dans le bugzilla
de Linux : http://bugzilla.kernel.org ?




J'ai voulu le faire, mais j'ai pas les compétences pour.

De plus, il me semble que ça a déjà été fait.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme