=?ISO-8859-1?Q?[WD11][d=E9butant]_Indice_d'une_table_m=E9moire_??=

Le
Loko
Bonjour

C'est tout bête mais j'ai pas trouvé : comment savoir l'indice courant
dans ma table mémoire, lorsque je la parcours par programmation ?

(Je parle pas de tableselect puisque je suis dans l'initialisation de
ma fenetre et l'utilisateur n'a donc pas encore sélectionné de ligne,
d'ailleurs la table est non sélectionnable).

J'ai essayé tout simple le nom de ma table, mais ca me retourne à
chaque fois 1, meme apres chaque TableAjoute.

Exemple de code :
Code :


TANTQUE PAS HEnDehors()
TableAjoute(ma_table, )
Info(ma_table)
HLitSuivant()
FIN

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal F
Le #14567941
Loko a émis l'idée suivante :
Bonjour

C'est tout bête mais j'ai pas trouvé : comment savoir l'indice courant
dans ma table mémoire, lorsque je la parcours par programmation ?

(Je parle pas de tableselect puisque je suis dans l'initialisation de
ma fenetre et l'utilisateur n'a donc pas encore sélectionné de ligne,
d'ailleurs la table est non sélectionnable).

J'ai essayé tout simple le nom de ma table, mais ca me retourne à
chaque fois 1, meme apres chaque TableAjoute.

Exemple de code :
Code :

...
TANTQUE PAS HEnDehors()
TableAjoute(ma_table, ...)
Info(ma_table)
HLitSuivant(...)
FIN

Merci



pourquoi vouloir connaitre l'indice courant puisque tableajoute ajoute en fin de table?

--
Pascal

Ne garder que le prénom pour me joindre
Roumegou Eric
Le #14567931
Loko avait écrit le 13/12/2007 :
Bonjour

C'est tout bête mais j'ai pas trouvé : comment savoir l'indice courant
dans ma table mémoire, lorsque je la parcours par programmation ?

(Je parle pas de tableselect puisque je suis dans l'initialisation de
ma fenetre et l'utilisateur n'a donc pas encore sélectionné de ligne,
d'ailleurs la table est non sélectionnable).

J'ai essayé tout simple le nom de ma table, mais ca me retourne à
chaque fois 1, meme apres chaque TableAjoute.

Exemple de code :
Code :

...
TANTQUE PAS HEnDehors()
TableAjoute(ma_table, ...)
Info(ma_table)
HLitSuivant(...)
FIN

Merci



normalement, ça ça peut le faire.

pI est un entier
TableAjoute(ma_table, ...)
pI=tableoccurrence(matable)


sinon

POUR TOUTE LIGNE de Matable

pi=Matable
info(pI)

FIN

--
Eric Roumégou
Webmaster des Wtablettes
http://cerbermail.com/?qE7t4Qvilo
(cliquez sur le lien ci-dessus pour m'écrire)
Publicité
Poster une réponse
Anonyme