j'ai des chiffres a comparer sur 2 col. differentes sur excel?

Le
titou01230
bonjour, je voudrais comparer tous les chiffres d'une coonne par rapport a
une autre colonne avec excel. Y a t'il une manip. qui le fait automatiquement?
merci pour vos réponses.
sincèrement.
thierry.
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Mgr T. Banni
Le #19641291
bonjour titou
un truc à la MichDenis....ça vaut donc ce que ça vaut :-)
le nom de ta feuille est à adapter, bien évidemment
HTH
Mgr T.B.

Sub Test()

Dim ColB As Range, ColC As Range

Dim A As Long, DerLig As Long

Application.ScreenUpdating = False

With Worksheets("Feuil1") ' Nom Feuille à déterminer

DerLig = .Range("B:C").Find(What:="*", _

LookIn:=xlFormulas, _

SearchOrder:=xlByRows, _

SearchDirection:=xlPrevious).Row

Set ColB = .Range("b1:b" & DerLig)

Set ColC = .Range("C1.C" & DerLig)

End With

For A = 1 To DerLig

If ColB(A) = ColC(A) Then

ColB(A).Cut ColB(A).Offset(1, -1)

ColC(A).ClearContents

End If

Next

Set ColB = Nothing: Set ColC = Nothing

End Sub




"titou01230" de news:
bonjour, je voudrais comparer tous les chiffres d'une coonne par rapport a
une autre colonne avec excel. Y a t'il une manip. qui le fait
automatiquement?
merci pour vos réponses.
sincèrement.
thierry.


Daniel.C
Le #19641471
Bonjour.
Si tu as XL2007, sélectionne les deux colonnes, clique sur Mise en
forme conditionnelle, Règles de mise en surbrillance des cellules, et
sur valeurs en double. Avec les versions antérieures, sélectionne la
seconde colonne (B dans l'exemple) et choisis Mise en forme
conditionnelle en utilisant la formule :
=NB.SI($A:$A;B1)>0
format au choix.
Cordialement.
Daniel

bonjour, je voudrais comparer tous les chiffres d'une coonne par rapport a
une autre colonne avec excel. Y a t'il une manip. qui le fait
automatiquement? merci pour vos réponses.
sincèrement.
thierry.


Daniel.C
Le #19641461
Tout dépend bien sûr de ce que tu entends par "comparer"; peux-tu
donner un exemple ?
Daniel

Bonjour.
Si tu as XL2007, sélectionne les deux colonnes, clique sur Mise en forme
conditionnelle, Règles de mise en surbrillance des cellules, et sur valeurs
en double. Avec les versions antérieures, sélectionne la seconde colonne (B
dans l'exemple) et choisis Mise en forme conditionnelle en utilisant la
formule :
=NB.SI($A:$A;B1)>0
format au choix.
Cordialement.
Daniel

bonjour, je voudrais comparer tous les chiffres d'une coonne par rapport a
une autre colonne avec excel. Y a t'il une manip. qui le fait
automatiquement? merci pour vos réponses.
sincèrement.
thierry.




xlcomparator
Le #19711781
titou01230 a écrit le 26/06/2009 à 11h23 :
bonjour, je voudrais comparer tous les chiffres d'une coonne par rapport a
une autre colonne avec excel. Y a t'il une manip. qui le fait automatiquement?
merci pour vos réponses.
sincèrement.
thierry.


Bonjour,
une solution ne nécessitant pas de passer par la programmation d'une macro, XlComparator ici :
http://www.xlcomparator.net/
A+
Marc
Publicité
Poster une réponse
Anonyme