j'ai fais une bêtise...

Le
François Patte
Bonjour,

A la suite d'une manœuvre douteuse, j'ai désinstallé (avec apt-get) des
paquets sur une debian 7.

Quand j'ai voulu les réinstaller, tjrs avec apt-get, ça c'est bien passé
au début, jusqu'à ce que je demande de réinstaller mjpegtools, transcode
et là ça a coincé

Depuis, quoique je demande, j'ai des messages du type suivant (par
exemple installer alien):

The following packages have unmet dependencies:
alien : Depends: debhelper (>= 7) but it is not going to be installed
libapt-pkg-perl : Depends: perl-base (>= 5.18.1-2) but 5.14.2-21 is to
be installed
Depends: perlapi-5.18.1
liblavfile-2.1-0 : Depends: libmjpegutils-2.1-0 but it is not going to
be installed
liblavplay-2.1-0 : Depends: liblavjpeg-2.1-0 but it is not going to be
installed
Depends: libmjpegutils-2.1-0 but it is not going to
be installed
libperl5.18 : Depends: perl-base (= 5.18.1-4) but 5.14.2-21 is to be
installed
mjpegtools : Depends: liblavjpeg-2.1-0 but it is not going to be installed
Depends: libmjpegutils-2.1-0 but it is not going to be
installed
Depends: libmpeg2encpp-2.1-0 but it is not going to be
installed
Depends: libmplex2-2.1-0 but it is not going to be installed
perl : Depends: perl-base (= 5.18.1-4) but 5.14.2-21 is to be installed
Depends: perl-modules (>= 5.18.1-4) but 5.14.2-21 is to be installed
transcode : Depends: libmjpegutils-2.1-0 but it is not going to be
installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
specify a solution).


Bon, je suis obeissant et je fait apt-get -f install et j'obtiens qu'il
va m'installer de nouveaux paquets, en retirer d'autres, en mettre à
jour d'autres., j'accepte et:

Retrieving bug reports Done
Parsing Found/Fixed information Done
Reading changelogs Done
(Reading database 195928 files and directories currently installed.)
Unpacking libmjpegutils-2.1-0 (from
/libmjpegutils-2.1-0_1%3a2.1.0+debian-2_amd64.deb)
dpkg: error processing
/var/cache/apt/archives/libmjpegutils-2.1-0_1%3a2.1.0+debian-2_amd64.deb
(--unpack):
trying to overwrite
'/usr/lib/x86_64-linux-gnu/libmjpegutils-2.1.so.0.0.0', which is also in
package libmjpegutils-2.0-0 1:2.1.0+debian-1
Unpacking liblavjpeg-2.1-0 (from
/liblavjpeg-2.1-0_1%3a2.1.0+debian-2_amd64.deb)
dpkg: error processing
/var/cache/apt/archives/liblavjpeg-2.1-0_1%3a2.1.0+debian-2_amd64.deb
(--unpack):
trying to overwrite
'/usr/lib/x86_64-linux-gnu/liblavjpeg-2.1.so.0.0.0', which is also in
package liblavjpeg-2.0-0 1:2.1.0+debian-1
Errors were encountered while processing:
/var/cache/apt/archives/libmjpegutils-2.1-0_1%3a2.1.0+debian-2_amd64.deb
/var/cache/apt/archives/liblavjpeg-2.1-0_1%3a2.1.0+debian-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Comment sortir de là?

Merci pour toute aide.
--
François Patte
Université Paris Descartes
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jacques_guezenec
Le #25742342
Le 25/10/2013 13:26, François Patte a écrit :
Bonjour,

A la suite d'une manœuvre douteuse, j'ai désinstallé (avec apt-get) des
paquets sur une debian 7.


Comment sortir de là?

Merci pour toute aide.



Pour aujourd'hui, je n'ai pas de solution, mais pour demain, faites des
sauvegardes mensuelles de votre (vos) partition avec Clonezilla ou
Pmagic. Il suffit alors d'une restauration : ça prend 15 mn. Puis une
mise à jour si nécessaire.
yamo'
Le #25742572
Salut,

François Patte a tapoté, le 25/10/2013 13:26:
A la suite d'une man½uvre douteuse, j'ai désinstallé (avec apt-get) des
paquets sur une debian 7.



Aucune idée.
Peut-être que les lignes correspondantes de
/var/log/dpkg.log peuvent aider à répondre un spécialiste de debian?


C'est uniquement des paquets de stable qui sont installés?

--
Stéphane BOFH excuse #266:

All of the packets are empty.
Emmanuel Florac
Le #25742742
Le Fri, 25 Oct 2013 13:26:36 +0200, François Patte a écrit:




Comment sortir de là?





Sous Debian depuis la 5 il est recommandé d'utiliser aptitude et pas apt-
get. Comment par essayer "aptitude install -f".

--
Quis, quid, ubi, quibus auxiliis, cur, quomodo, quando
Nicolas George
Le #25742822
Emmanuel Florac , dans le message
Sous Debian depuis la 5 il est recommandé d'utiliser aptitude et pas apt-
get.



Si je me souviens bien, cette recommandation a été inversée ensuite.
Pascal Hambourg
Le #25742812
Nicolas George a écrit :
Emmanuel Florac , dans le message
Sous Debian depuis la 5 il est recommandé d'utiliser aptitude et pas apt-
get.



Si je me souviens bien, cette recommandation a été inversée ensuite.



Oui. Et de toute façon elle ne vaut que pour résoudre les changements de
dépendances lors d'un dist-upgrade/full-upgrade.
François Patte
Le #25742962
Le 26/10/2013 13:17, Pascal Hambourg a écrit :
Nicolas George a écrit :
Emmanuel Florac , dans le message
Sous Debian depuis la 5 il est recommandé d'utiliser aptitude et pas apt-
get.



Si je me souviens bien, cette recommandation a été inversée ensuite.



Oui. Et de toute façon elle ne vaut que pour résoudre les changements de
dépendances lors d'un dist-upgrade/full-upgrade.




J'ai trouvé une solution (en faisant le gros dos, croisant les doigts,
caressant une patte de lapin...): j'ai sauvagement assassiné les paquets
qui créaient un pb et... ça remarche!


--
François Patte
Université Paris Descartes
Publicité
Poster une réponse
Anonyme