J'ai fais quoi de pas bien avec mon boot.ini ?

Le
JièL
Salutatousse

Selon les conseils de Michel_D (cf
http://groups.google.fr/group/microsoft.public.fr.windowsxp/browse_thread/thread/68c10e437c331e40#)
j'ai modifié mon Boot.ini de celle façon

[boot loader]
timeout0
default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Windows XP moribond"
/fastdetect /NoExecute=OptIn
multi(0)disk(0)rdisk(2)partition(1)WINDOWS="Windows XP tout neuf" /fastdetect

et ça fonctionnait !!! (encore merci à lui)

mais, j'ai du débranché le dd n°2 pour en brancher un autre pour récupérer
les données présente sur ce dernier, et maintenant que j'ai tout remis
"komyfo" mon démarrage sur le nouvel XP ne veut plus rien savoir
y'a une histoire de HAL manquant quand je veux booter sur le DD2 alors
qu'il n'est évidement pas manquant.

Dans le gestionnaire de disque du vieil XP j'ai
Disque 0,
C:, Part Princip, NTFS, Sain (System)
D:, Part Princip, NTFS, Sain
(je sais pas pourquoi mais le D: est aussi une partition principale)

Disque 1,
E:, Lecteur logique, FAT32, Sain (Fichier d'échange)

Disque 2,
F:, Part Princip, NTFS, Sain (Actif)
H:, Lecteur logique, NTFS, Sain

J'ai fais quoi de pas bien svp ?

A noter qu'en appuyant sur une touche lors du boot, le bios me propose de
démarrer sur le DD de mon choix, et quand je choisie le 2, ça fonctionne,
donc ce n'est pas un pb de Windows, mais certainement un soucis dans le
boot.ini (ou dans les partoches), mais je n'arrive pas à voir lequel.

Merci

--
JièL / Jean-Louis GOUBERT
La FAQ Outlook a déménagé : http://faq.outlook.fr/

Boycott des questions venant de CDO
http://faq.outlook.fr/viewpage.php?page_id=2
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 4
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Michel__D
Le #16600741
Bonjour,

"JièL"
Salutatousse

Selon les conseils de Michel_D (cf
http://groups.google.fr/group/microsoft.public.fr.windowsxp/browse_thread/thread/68c10e437c331e40#)
j'ai modifié mon Boot.ini de celle façon

[boot loader]
timeout0
default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Windows XP moribond"
/fastdetect /NoExecute=OptIn
multi(0)disk(0)rdisk(2)partition(1)WINDOWS="Windows XP tout neuf" /fastdetect

et ça fonctionnait !!! (encore merci à lui)

mais, j'ai du débranché le dd n°2 pour en brancher un autre pour récupérer
les données présente sur ce dernier, et maintenant que j'ai tout remis
"komyfo" mon démarrage sur le nouvel XP ne veut plus rien savoir
y'a une histoire de HAL manquant quand je veux booter sur le DD2 alors
qu'il n'est évidement pas manquant.

Dans le gestionnaire de disque du vieil XP j'ai
Disque 0,
C:, Part Princip, NTFS, Sain (System)
D:, Part Princip, NTFS, Sain
(je sais pas pourquoi mais le D: est aussi une partition principale)

Disque 1,
E:, Lecteur logique, FAT32, Sain (Fichier d'échange)

Disque 2,
F:, Part Princip, NTFS, Sain (Actif)
H:, Lecteur logique, NTFS, Sain

J'ai fais quoi de pas bien svp ?

A noter qu'en appuyant sur une touche lors du boot, le bios me propose de
démarrer sur le DD de mon choix, et quand je choisie le 2, ça fonctionne,
donc ce n'est pas un pb de Windows, mais certainement un soucis dans le
boot.ini (ou dans les partoches), mais je n'arrive pas à voir lequel.



Moi je ferais en sorte que le bios démarre sur le disque qui contient l'XP
tout neuf, en plus cela tombe bien cette config fonctionne, aprés je
récupèrerais les données de l'XP moribond que j'effacerais et ensuite je
clonerais l'XP tout neuf sur l'ex XP moribond pour avoir un OS de secours.
Ayrton [ASC]
Le #16600731
Bonjour *JièL* :-p
Dans ton message de Tu nous envoyais cette missive :-(*)

Salutatousse



Salut Jièl,

Selon les conseils de Michel_D (cf
http://groups.google.fr/group/microsoft.public.fr.windowsxp/browse_thread/thread/68c10e437c331e40#)
j'ai modifié mon Boot.ini de celle façon

[boot loader]
timeout0
default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Windows XP moribond"
/fastdetect /NoExecute=OptIn
multi(0)disk(0)rdisk(2)partition(1)WINDOWS="Windows XP tout neuf"
/fastdetect



[....]

A tout hasard, jette un oeil ici :
http://www.world-informatique.com/pasapas/recupxp/recupxp6.html


Merci



Avec Plaisir ;-)

--
Christophe
http://viadresse.com?25031980
--------------------------------------------------------------
Pour le dépannage:
http://pcland.easyforum.fr/index.htm
Perso:
http://christophe.mignerat.free.fr
Geo
Le #16603332
Bonjour   Ji¨L qui nous a ©crit :


Disque 2,
F:, Part Princip, NTFS, Sain (Actif)
H:, Lecteur logique, NTFS, Sain



La lettre de F n'a pas chang© entre le moment o¹ §a marchait et
maintenant ?

A noter qu'en appuyant sur une touche lors du boot, le bios me propose de d©marrer sur
le DD de mon choix, et quand je choisie le 2, §a fonctionne, donc ce n'est pas un pb de
Windows,



Quelle lettre affect©e   la partition Windows ?

--
A+
Geo
Le #16603322
Bonjour

en plus cela tombe bien cette config fonctionne,



Mmoui,
on peut interpr©ter :-)

--
A+
JièL
Le #16603562
Bonjoir(c) Geo

Le 22/08/2008 22:19 vous avez ©crit ceci :
en plus cela tombe bien cette config fonctionne,



Mmoui,
on peut interpr©ter :-)



;-) t'en rates pas une Geo ;-)

--
Ji¨L / Jean-Louis GOUBERT
La FAQ Outlook a d©m©nag© : http://faq.outlook.fr/

Boycott des questions venant de CDO
http://faq.outlook.fr/viewpage.php?page_id=2
JièL
Le #16603552
Bonjoir(c) Geo

Le 22/08/2008 22:16 vous avez ©crit ceci :
Disque 2,
F:, Part Princip, NTFS, Sain (Actif)
H:, Lecteur logique, NTFS, Sain



La lettre de F n'a pas chang© entre le moment o¹ §a marchait et
maintenant ?



Euh... non, je ne crois pas

A noter qu'en appuyant sur une touche lors du boot, le bios me propose
de d©marrer sur le DD de mon choix, et quand je choisie le 2, §a
fonctionne, donc ce n'est pas un pb de Windows,



Quelle lettre affect©e   la partition Windows ?



C: dans les deux cas
Pour la petite histoire, quand j'ai install© le 1er Windows je n'avais pas
de 2¨me DD.
Quand j'ai install© le 2¨me, pour ©viter tout pb, j'ai d©branch© le 1er DD
et install©   partir du CD comme si c'©tait le seul DD ,donc C:
automatiquement

--
Ji¨L / Jean-Louis GOUBERT
La FAQ Outlook a d©m©nag© : http://faq.outlook.fr/

Boycott des questions venant de CDO
http://faq.outlook.fr/viewpage.php?page_id=2
JièL
Le #16603672
Bonjoir(c) Ayrton [ASC]

Hey, salut Ayrton... ça faisait un moment... ;-)

Le 22/08/2008 15:42 vous avez écrit ceci :
A tout hasard, jette un oeil ici :
http://www.world-informatique.com/pasapas/recupxp/recupxp6.html



Je testerai, merci

--
JièL / Jean-Louis GOUBERT
La FAQ Outlook a déménagé : http://faq.outlook.fr/

Boycott des questions venant de CDO
http://faq.outlook.fr/viewpage.php?page_id=2
JièL
Le #16603662
Bonjoir(c) Michel__D

Le 22/08/2008 15:39 vous avez écrit ceci :
Moi je ferais en sorte que le bios démarre sur le disque qui contient l'XP
tout neuf, en plus cela tombe bien cette config fonctionne, aprés je
récupèrerais les données de l'XP moribond que j'effacerais et ensuite je
clonerais l'XP tout neuf sur l'ex XP moribond pour avoir un OS de secours.



C'est un conseil judicieux ;-), mais... parce qu'il y a toujours un jolie
mois de mai ;-), j'ai encore BEAUCOUP besoin du Windows moribond à cause
de la foultitude de programmes et des moults réglages et paramétrages
qu'il contient... Je n'ai plus les CD d'install de certain prog et ça me
manquerais vraiment de ne pas pouvoir démarrer sur ce Windows là.

Je me demande quand même ce que j'ai pu changer, parce que avant de
débrancher le DD ça fonctionnait... Bizarre autant qu'étrange

--
JièL / Jean-Louis GOUBERT
La FAQ Outlook a déménagé : http://faq.outlook.fr/

Boycott des questions venant de CDO
http://faq.outlook.fr/viewpage.php?page_id=2
JF
Le #16604991
*Bonjour JièL * !

Salutatousse



Selon les conseils de Michel_D (cf
http://groups.google.fr/group/microsoft.public.fr.windowsxp/browse_thread/thread/68c10e437c331e40#)
j'ai modifié mon Boot.ini de celle façon



[boot loader]
timeout0
default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Windows XP moribond" /fastdetect
/NoExecute=OptIn
multi(0)disk(0)rdisk(2)partition(1)WINDOWS="Windows XP tout neuf"
/fastdetect



et ça fonctionnait !!! (encore merci à lui)



mais, j'ai du débranché le dd n°2 pour en brancher un autre.....



Solution 1 :
BOOTCFG /REBUILD depuis la Console de Récupération
http://support.microsoft.com/kb/314477/fr

Solution 2 :
BOOT.INI à mettre sur la racine de chaque disque :

[boot loader]
timeout3
default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS

[operating systems]
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="disque 0 partition 1"
multi(0)disk(0)rdisk(0)partition(2)WINDOWS="disque 0 partition 2"
multi(0)disk(0)rdisk(0)partition(3)WINDOWS="disque 0 partition 3"
multi(0)disk(0)rdisk(0)partition(4)WINDOWS="disque 0 partition 4"
multi(0)disk(0)rdisk(1)partition(1)WINDOWS="disque 1 partition 1"
multi(0)disk(0)rdisk(1)partition(2)WINDOWS="disque 1 partition 2"
multi(0)disk(0)rdisk(1)partition(3)WINDOWS="disque 1 partition 3"
multi(0)disk(0)rdisk(1)partition(4)WINDOWS="disque 1 partition 4"
multi(0)disk(0)rdisk(2)partition(1)WINDOWS="disque 2 partition 1"
multi(0)disk(0)rdisk(2)partition(2)WINDOWS="disque 2 partition 2"
multi(0)disk(0)rdisk(2)partition(3)WINDOWS="disque 2 partition 3"
multi(0)disk(0)rdisk(2)partition(4)WINDOWS="disque 2 partition 4"
multi(0)disk(0)rdisk(3)partition(1)WINDOWS="disque 3 partition 1"
multi(0)disk(0)rdisk(3)partition(2)WINDOWS="disque 3 partition 2"
multi(0)disk(0)rdisk(3)partition(3)WINDOWS="disque 3 partition 3"
multi(0)disk(0)rdisk(3)partition(4)WINDOWS="disque 3 partition 4"



Ajouter à chaque ligne : /fastdetect /NoExecute=OptIn
Modifier la première ligne en fonction des résultats.
Idem pour les autres.

Conventions d'affectation de noms et
utilisation des chemins BOOT.INI et ARC
http://support.microsoft.com/kb/102873/fr

Résumé :
rdisk() est l'ordinal du disque de la carte, généralement de 0 à 3
rdisk() est presque toujours à 0 avec la syntaxe multi()
partition() est le n° de la partition, notée de 1 à n

Sources :
http://www.bellamyjc.org/fr/windowsnt.html#bootini
http://www.bellamyjc.org/fr/windowsnt.html#disquetteNT

--
Salutations, Jean-François
FAQ XP de Panthère Noire (index) : www.d2i.ch/pn/az
Un problème à montrer ? http://fspsa.free.fr/copiecran.htm
Outil : http://fspsa.free.fr/Presse-Papier_vers_Regedit.htm
Geo
Le #16605322
Bonjour

Quelle lettre affectée à la partition Windows ?



C: dans les deux cas
Pour la petite histoire, quand j'ai installé le 1er Windows je n'avais pas de 2ème DD.
Quand j'ai installé le 2ème, pour éviter tout pb, j'ai débranché le 1er DD et installé
à partir du CD comme si c'était le seul DD ,donc C: automatiquement



Ok pour l'install, mais quand tu redémarres, pas certain qu'il le
prenne comme C:
En tous cas s'il démarre sur le nouveau en C:, ton ancien Windows
aurait bien une autre lettre.
S'il la conserve lors du boot suivant, amha ça poserait quelques
problèmes.

Dans des trucs comme ça, il vaut mieux avoir des tiroirs et échanger
les disques.

--
A+
Publicité
Poster une réponse
Anonyme