J'ai plus d'id

Le
Centaur
Bonjour à tous !

Soit une table simple :

Nom Horodatage_début Horodatage_fin

Il y a 1800 lignes, mais seulement 50 noms. La table n'est pas triée du
tout.

Normalement, il n'y a pas de "trous" en terme d'horodatage : exemple de
lignes normale (après tri)

Paul 01/01/07 15:42:00 15/01/07 16:45:00
Paul 15/01/07 16h45h00 28/01/07 10:52:00

Etc

Il peut même arriver qu'un horodatage de début démarre avant la fin de
l'horodatage précédent, exemple :

Jean 01/01/07 15:42:00 15/01/07 16:45:00
Jean 15/01/07 15h03h00 28/01/07 10:52:00

Jean à donc démarré 1 heure et 42 minutes "avant d'avoir fini" sa ligne
précédente. Cherchez pas, c'est NORMAL/

Les cas recherchés sont ceux ou un laps de temps n'aurait pas été
enregistré, exemple :

Marc 01/01/07 15:42:00 15/01/07 16:45:00
Marc 18/01/07 18h02h00 28/01/07 10:52:00

Dans cet exemple, j'ai un trou entre le 15 et le 18/01, soit 3 jours, 1
heure et 17 minutes de trou exactement

Question : comment repérer pour chacune des 50 personnes individuellement
si elle fait ou non l'objet d'un tel trou ?

Seule soluce trouvée jusqu'a maintenant : filtre auto sur le nom, copier
coller des données d'un individu dans une autre feuille, tri par
horodatage de début et calcul du delta entre debut(n) et fin(n-1)

Multiplié par 50 gus, ca va rapidement mal finir

Donc si une bonne ame à une meilleure idée

Merci d'avance à tous !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5276411
Bonsoir.
Après tri sur les trois premières colonnes :
=SI(ET(A1¢;B2+C2>D1+E1);"trou";"") en F2, à recopier vers le bas.
Cordialement.
Daniel
"Centaur" 47b46c73$0$27594$
Bonjour à tous !

Soit une table simple :

Nom Horodatage_début Horodatage_fin

Il y a 1800 lignes, mais seulement 50 noms. La table n'est pas triée du
tout.

Normalement, il n'y a pas de "trous" en terme d'horodatage : exemple de
lignes normale (après tri)

Paul 01/01/07 15:42:00 15/01/07 16:45:00
Paul 15/01/07 16h45h00 28/01/07 10:52:00

Etc

Il peut même arriver qu'un horodatage de début démarre avant la fin de
l'horodatage précédent, exemple :

Jean 01/01/07 15:42:00 15/01/07 16:45:00
Jean 15/01/07 15h03h00 28/01/07 10:52:00

Jean à donc démarré 1 heure et 42 minutes "avant d'avoir fini" sa ligne
précédente. Cherchez pas, c'est NORMAL/

Les cas recherchés sont ceux ou un laps de temps n'aurait pas été
enregistré, exemple :

Marc 01/01/07 15:42:00 15/01/07 16:45:00
Marc 18/01/07 18h02h00 28/01/07 10:52:00

Dans cet exemple, j'ai un trou entre le 15 et le 18/01, soit 3 jours, 1
heure et 17 minutes de trou exactement

Question : comment repérer pour chacune des 50 personnes individuellement
si elle fait ou non l'objet d'un tel trou ?

Seule soluce trouvée jusqu'a maintenant : filtre auto sur le nom, copier
coller des données d'un individu dans une autre feuille, tri par
horodatage de début et calcul du delta entre debut(n) et fin(n-1)

Multiplié par 50 gus, ca va rapidement mal finir...

Donc si une bonne ame à une meilleure idée...

Merci d'avance à tous !


Centaur
Le #5276131
Le Thu, 14 Feb 2008 19:03:44 +0100, Daniel.C a écrit:

Bonsoir.
Après tri sur les trois premières colonnes :
=SI(ET(A1¢;B2+C2>D1+E1);"trou";"") en F2, à recopier vers le bas.
Cordialement.
Daniel



Merci Daniel, mais il y a un truc que je ne comprends pas dans votre
formule :

Je n'ai que 3 colonnes Nom en A, Début en B et Fin en C

Je vais essayer ceci sur sur votre idée

=SI(ET(A1¢;B2-C1>0);"Trou;"")

PS, J'ai essayé, ca marche !

Merci pour l'idée et bonne journée

Publicité
Poster une réponse
Anonyme