Java

Le
Gloops
Bonjour,

Sur fr.comp.infosystemes.www.navigateurs, nous avons depuis trois jours
un fil "Java de merde", avec quelqu'un qui se fait jeter
systématiquement lorsqu'il s'agit d'exécuter Java sous Windows,
plusieurs versions de Windows essayées.

Je viens de lui faire remarquer qu'il ne serait pas possible de lui
répondre sans qu'il précise les versions de JRE installées.

Par ailleurs je note que la situation de Java n'est pas au top de la
clarté en ce moment, avec Oracle, qui si je ne m'abuse a racheté Java=

depuis quelque temps, qui propose une version 7, et Sun qui ne se
désintéresse pas de la question en proposant une version 8.

Les outils de contrôle peinent à y retrouver leur latin : Firefox
n'accepte que la version 7, tandis que Hippo File UpdateChecker signale
à l'utilisateur qu'il est temps d'installer la 8. Les deux refusent
d'ailleurs de co-exister sur la même machine.

Seuls les utilisateurs d'Avast (et les gens qui fouillent dans les docs) =

sont informés que c'est bien joli de passer de l'une à l'autre, mais =

qu'il faut aussi désinstaller la 6.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Maboule
Le #26096932
"Gloops" lj3v3i$6t5$
Bonjour,

Sur fr.comp.infosystemes.www.navigateurs, nous avons depuis trois jours
un fil "Java de merde", avec quelqu'un qui se fait jeter
systématiquement lorsqu'il s'agit d'exécuter Java sous Windows,
plusieurs versions de Windows essayées.

Je viens de lui faire remarquer qu'il ne serait pas possible de lui
répondre sans qu'il précise les versions de JRE installées.

Par ailleurs je note que la situation de Java n'est pas au top de la
clarté en ce moment, avec Oracle, qui si je ne m'abuse a racheté Java
depuis quelque temps, qui propose une version 7, et Sun qui ne se
désintéresse pas de la question en proposant une version 8.

Les outils de contrôle peinent à y retrouver leur latin : Firefox
n'accepte que la version 7, tandis que Hippo File UpdateChecker signale
à l'utilisateur qu'il est temps d'installer la 8. Les deux refusent
d'ailleurs de co-exister sur la même machine.

Seuls les utilisateurs d'Avast (et les gens qui fouillent dans les docs)
sont informés que c'est bien joli de passer de l'une à l'autre, mais
qu'il faut aussi désinstaller la 6.
________________________________________________

- Et actuellement Mozilla Firefox désactive systématiqueùent Java.
- Mais IE8 ne réagit pas !
- Faudrait savoir...
Gloops
Le #26097062
Maboule a écrit, le 21/04/2014 22:54 :
- Et actuellement Mozilla Firefox désactive systématiqueùent Java .
- Mais IE8 ne réagit pas !
- Faudrait savoir...




Pour ma part Firefox (28.0) me demande si je veux désactiver Java ou pa s :
http://cjoint.com/?DDwanKk0ir6

En revanche, il n'accepte que Java 7.
Au-dessus de la liste des plug-ins, cliquer sur "Vérifier si les plugin s
sont à jour", en face de Java cliquer sur Mettre à jour, puis laisser
Firefox s'occuper de tout, télécharger, installer, redémarrer.


C'est vrai que l'installation après avoir téléchargé autrement, p ar
exemple depuis chez FileHippo, aboutit à un échec.

Celui de FileHippo fonctionne très bien pour IE en revanche.
A ne pas installer quand on a un train à prendre.
Gloops
Le #26097072
Gloops a écrit, le 22/04/2014 00:21 :
Celui de FileHippo fonctionne très bien pour IE en revanche.
A ne pas installer quand on a un train à prendre.



En fonction de la cohérence de ce que j'ai dit, j'ai un doute quant à
avoir téléchargé la 7u55 depuis FileHippo.

Je ne retrouve pas la trace, mais peu importe l'important est de la
trouver quelque part.
Sur IE ce qui est installé s'appelle Java(tm)Plug-In SSV Helper, de
Oracle America, Inc., version 7.0.550.14
Laurent Jumet
Le #26097142
Hello Maboule !

"Maboule"
- Et actuellement Mozilla Firefox désactive systématiqueùent Java.
- Mais IE8 ne réagit pas !
- Faudrait savoir...



La version orthodoxe c'est 7u55
Depuis un certain temps déjà, l'install par défaut ne donne accès à JAVA que pour
les applications signées; signées par qui?
Au début, c'était signées par leur auteur; maintenant c'est signées par un
"notaire". La raison est que JAVA est très puissant et donne accès à tout; alors pour
éviter les applets viraux, tout est désactivé par défaut.
En pratique, si JAVA est installé, il faut aller dans sa config et mettre le
curseur "Sécurité" en position moyenne/basse; alors les applets affichent une boîte de
dialogue avant chaque exécution. Donc il n'y a pas de danger d'exécution automatique,
à chaque fois on est prompté, c'est ce que je fais et je conseille, autrement JAVA ne
sert tout simplement à rien vu qu'il est bloqué pour presque tout.

Pour télécharger JAVA, c'est uniquement à partir d'ici: java.com/fr/

--
Laurent Jumet - Point de Chat, Liège, BELGIUM
KeyID: 0xCFAF704C
[Restore address to laurent.jumet for e-mail reply.]
Maboule
Le #26099412
"Laurent Jumet" news:

Hello Maboule !

"Maboule"
- Et actuellement Mozilla Firefox désactive systématiqueùent Java.
- Mais IE8 ne réagit pas !
- Faudrait savoir...



La version orthodoxe c'est 7u55
Depuis un certain temps déjà, l'install par défaut ne donne accès à
JAVA que pour
les applications signées; signées par qui?
Au début, c'était signées par leur auteur; maintenant c'est signées par
un
"notaire". La raison est que JAVA est très puissant et donne accès à tout;
alors pour
éviter les applets viraux, tout est désactivé par défaut.
En pratique, si JAVA est installé, il faut aller dans sa config et
mettre le
curseur "Sécurité" en position moyenne/basse; alors les applets affichent
une boîte de
dialogue avant chaque exécution. Donc il n'y a pas de danger d'exécution
automatique,
à chaque fois on est prompté, c'est ce que je fais et je conseille,
autrement JAVA ne
sert tout simplement à rien vu qu'il est bloqué pour presque tout.

Pour télécharger JAVA, c'est uniquement à partir d'ici: java.com/fr/

--
Laurent Jumet - Point de Chat, Liège, BELGIUM
KeyID: 0xCFAF704C
[Restore address to laurent.jumet for e-mail reply.]


_______________________________________________

Merci Laurent.

Un message de Avast nous informe enfin qu'il s'agit d'une erreur chez Avast
et qu'ils vont corriger cela.
Gloops
Le #26100092
Maboule a écrit, le 23/04/2014 14:51 :
Merci Laurent.

Un message de Avast nous informe enfin qu'il s'agit d'une erreur chez A vast
et qu'ils vont corriger cela.






Mais vous avez quelle version d'Avast ?
Maboule
Le #26100292
"Gloops" ljahl5$i9f$
Maboule a écrit, le 23/04/2014 14:51 :
Merci Laurent.

Un message de Avast nous informe enfin qu'il s'agit d'une erreur chez
Avast
et qu'ils vont corriger cela.






Mais vous avez quelle version d'Avast ?

Avast Internet Security, dans sa version la plus récente.
C'est une version payante.
Maboule
Le #26100322
"Gloops" ljahl5$i9f$
Maboule a écrit, le 23/04/2014 14:51 :
Merci Laurent.

Un message de Avast nous informe enfin qu'il s'agit d'une erreur chez
Avast
et qu'ils vont corriger cela.






Mais vous avez quelle version d'Avast ?

Voici le message de Avast :
Message qui apparait lors de la vérification des plugins.

"Un problème concernant la détection des versions les plus récentes du
plugin Java et l'indiquant à tort comme étant vulnérable nous a été
rapporté. Dans l'attente d'un correctif de notre part, vous pouvez visiter
le site de Java pour télécharger la dernière version."
Gloops
Le #26100392
Maboule a écrit, le 24/04/2014 14:32 :
"Gloops" ljahl5$i9f$
Maboule a écrit, le 23/04/2014 14:51 :
Merci Laurent.

Un message de Avast nous informe enfin qu'il s'agit d'une erreur chez
Avast
et qu'ils vont corriger cela.






Mais vous avez quelle version d'Avast ?

Avast Internet Security, dans sa version la plus récente.
C'est une version payante.




Ah ... J'ai fait l'essai pendant deux semaines ce mois-ci, jamais eu ce
souci.

Mais pour être franc je n'ai cherché à utiliser Java qu'hier, c'est là
que j'ai découvert la boîte de dialogue de configuration dans le pann eau
du même nom.

Ah, c'est le pare-feu qui bloque, pas l'antivirus ?

Ah lui c'est avec MySql qu'il a un peu traîné des pieds. Bon ça c'e st
une question de flemme : j'aurais dû le paramétrer. Mais là, ce n'e st
plus Java.
Maboule
Le #26101062
"Maboule" ljb2e8$8fh$
"Gloops" ljahl5$i9f$
Maboule a écrit, le 23/04/2014 14:51 :
Merci Laurent.

Un message de Avast nous informe enfin qu'il s'agit d'une erreur chez
Avast
et qu'ils vont corriger cela.


Mais vous avez quelle version d'Avast ?

Voici le message de Avast :
Message qui apparait lors de la vérification des plugins.

"Un problème concernant la détection des versions les plus récentes du
plugin Java et l'indiquant à tort comme étant vulnérable nous a été
rapporté. Dans l'attente d'un correctif de notre part, vous pouvez visiter
le site de Java pour télécharger la dernière version."




Oups !
Pardonnez-moi, mes mirettes ont déraillé, c'est Firefox qui nous donne ce
message.
Publicité
Poster une réponse
Anonyme