Je veux comparer des dates

Le
joseph84
Bonjour tout le monde

je me suis penche aujourd hui sur un cas particulier de comapraison et
je suis bute sur la comparaison entre des dates

voila ma formule : =SI(CV2<>0,MAX(DD2,DL2,DT2,EB2,EJ2,ER2,EZ2),0)

je voudrais faire une macro qui prend en charge la formule si haut

vous trouverais ci joint le lien de mon exemple

http://cjoint.com/?ADDv4meoJdi

merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #23320941
Bonjour,

Tu cherches quelque chose comme :

'--------------------------------------
Sub test()
Dim Rg As Range
With Worksheets("Feuil1") 'Nom à adapter
With .Range("CV1")
.FormulaArray = "=IF(CV1<>0,MAX(DD1,DL1,DT1,EB1,EJ1,ER1,EZ1),0)"
End With
DerLig = .Cells.Find(What:="*", _
LookIn:=xlFormulas, _
SearchOrder:=xlByRows, _
SearchDirection:=xlPrevious).Row
.Range("CV1:CV" & DerLig).FillDown
End With
End Sub
'--------------------------------------


MichD
--------------------------------------------
"joseph84" a écrit dans le message de groupe de discussion :


Bonjour tout le monde

je me suis penche aujourd hui sur un cas particulier de comapraison et
je suis bute sur la comparaison entre des dates

voila ma formule : =SI(CV2<>0,MAX(DD2,DL2,DT2,EB2,EJ2,ER2,EZ2),0)

je voudrais faire une macro qui prend en charge la formule si haut

vous trouverais ci joint le lien de mon exemple

http://cjoint.com/?ADDv4meoJdi

merci
MichD
Le #23321571
Juste une petite correction qui m'a échappé,

J'aurais du écrire : .Formula au lieu de .FormulaArray


MichD
--------------------------------------------
Publicité
Poster une réponse
Anonyme