Joie de l'autod

Le
Emmanuel Florac
Après m'être longtemps pris la tête pour comprendre pourquoi le gdm d'un
serveur (Debian squeeze) arrêtait de fonctionner, j'ai fini par
m'apercevoir que c'est parce qu'il n'y a pas d'écran connecté EDID ne
trouve pas d'écran, donc X se gaufre ( "no screens found" ), et gdm avec.
J'ai essayé de bricoler un xorg.conf mais rien à faire. Quelqu'un a une
idée? Même un serveur X en VGA me va, il faut que gdm tourne pour assurer
le XDMCP, c'est tout

(entre parenthèses, prenons un moment pour maudire les adeptes du
plugnpray qui a contaminé xorg jusqu'à la 42e génération).

--
My assertion that we can do better with computer languages is a
persistent belief and fond hope, but you'll note I don't actually claim
to be either rational or right. Except when it's convenient.
Larry Wall
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
YBM
Le #24753392
Emmanuel Florac a écrit :
Après m'être longtemps pris la tête pour comprendre pourquoi le gdm d'un
serveur (Debian squeeze) arrêtait de fonctionner, j'ai fini par
m'apercevoir que c'est parce qu'il n'y a pas d'écran connecté... EDID ne
trouve pas d'écran, donc X se gaufre ( "no screens found" ), et gdm avec.
J'ai essayé de bricoler un xorg.conf mais rien à faire. Quelqu'un a une
idée? Même un serveur X en VGA me va, il faut que gdm tourne pour assurer
le XDMCP, c'est tout...

(entre parenthèses, prenons un moment pour maudire les adeptes du
plugnpray qui a contaminé xorg jusqu'à la 42e génération).




Ce ne serait pas plus simple de dire à gdm de ne pas gérer
d'affichage local ?
Emmanuel Florac
Le #24754292
Le Tue, 04 Sep 2012 02:57:24 +0200, YBM a écrit:


Ce ne serait pas plus simple de dire à gdm de ne pas gérer d'affichage
local ?



C'est une solution. Idéalement, je pense que forcer affichage basique qui
passe sur tout écran âgé de moins de 20 ans (genre 1024x768) ferait
l'affaire, mais au pire pas d'affichage local serait mieux qu'un plantage
en bonne et dûe forme. Comment configure t-on gdm pour ça?

(entre parenthèses, je viens de remarquer que X dans Wheezy ne répond
plus à ctrl+Alt+backspace. C'est la décadence, la fin des haricots, la
mort du petit cheval, chuis dégoûté. Comment on redémarre X11 d'un seul
geste maintenant ?).

--
I have not failed. I've just found 10,000 ways that won't work.
Thomas A. Edison
Sergio
Le #24754412
Le Tue, 04 Sep 2012 11:28:37 +0000, Emmanuel Florac a écrit :

(entre parenthèses, je viens de remarquer que X dans Wheezy ne répond
plus à ctrl+Alt+backspace. C'est la décadence, la fin des haricots, la
mort du petit cheval, chuis dégoûté. Comment on redémarre X11 d'un seul
geste maintenant ?).




Y'a un truc à régler quelque part...

Chez moi (LinuxMint 13/MATE) dans les réglages clavier / Agencement /
Options, il y a un item "Séquence de touche pour tuer le serveur X".

essaye aussi "Ctrl-Alt-Impr-K".
Emmanuel Florac
Le #24754532
Le Tue, 04 Sep 2012 12:28:56 +0000, Sergio a écrit:


Chez moi (LinuxMint 13/MATE) dans les réglages clavier / Agencement /
Options, il y a un item "Séquence de touche pour tuer le serveur X".



Oui, je sais c'est dans xkb maintenant...

essaye aussi "Ctrl-Alt-Impr-K".



Délicat: ça tue le programme en avant-plan. Si le serveur X est planté,
il peut y avoir une image de serveur X à l'écran alors qu'il a planté
(arrive souvent avec certaines cartes graphiques ou drivers) et dans ce
cas, on peut tuer un autre programme.

--
I love deadlines, I love the whooshing noise they make as they go by.
Douglas Adams
Benoit Izac
Le #24755022
Bonjour,

le 04/09/2012 à 13:28, Emmanuel Florac a écrit dans le message

(entre parenthèses, je viens de remarquer que X dans Wheezy ne répond
plus à ctrl+Alt+backspace. C'est la décadence, la fin des haricots, la
mort du petit cheval, chuis dégoûté. Comment on redémarre X11 d'un
seul geste maintenant ?).



Ce n'est pas une nouveauté, ça doit faire plus d'un an que c'est le
comportement par défaut de xorg mais ça se soigne :

% cat /etc/X11/xorg.conf.d/10-keymap.conf
Section "InputClass"
Identifier "french keyboard"
MatchIsKeyboard "yes"
Option "XkbRules" "xorg"
Option "XkbLayout" "fr"
Option "XkbVariant" "oss"
Option "XkbOptions" "terminate:ctrl_alt_bksp,compose:menu"
EndSection

--
Benoit Izac
Lucas Levrel
Le #24755682
Le 4 septembre 2012, Emmanuel Florac a écrit :

(entre parenthèses, je viens de remarquer que X dans Wheezy ne répond
plus à ctrl+Alt+backspace. C'est la décadence, la fin des haricots, la
mort du petit cheval, chuis dégoûté. Comment on redémarre X11 d'un seul
geste maintenant ?).



Essaye deux fois de suite. Il y a une option pour désactiver ce
comportement le cas échéant (ZapWarning de mémoire).

--
LL
Emmanuel Florac
Le #24756162
Le Tue, 04 Sep 2012 22:38:41 +0200, Lucas Levrel a écrit:


Essaye deux fois de suite. Il y a une option pour désactiver ce
comportement le cas échéant (ZapWarning de mémoire).




Non, c'est un paramètre xkb maintenant (ZapMachin ne fonctionne plus avec
un xorg au dessus de 1.4 de mémoire). Par contre je ne comprends pas
pourquoi ils ne l'ont pas laissé actif par défaut. Pour imiter Ubuntu?

--
There are only two kinds of languages: the ones people complain about
and the ones nobody uses.
Bjarne Stroustrup
Lucas Levrel
Le #24757982
Le 5 septembre 2012, Emmanuel Florac a écrit :

Non, c'est un paramètre xkb maintenant (ZapMachin ne fonctionne plus avec
un xorg au dessus de 1.4 de mémoire).



Jamais compris la numérotation des versions d'X. J'ai

X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0

et C-A-BSP marche depuis que j'ai mis ZapWarning à off dans xorg.conf.

Pour ton problème : qu'as-tu mis dans ton xorg.conf "minimal" ? On a ici
des machines qui, je crois, ont un DM fonctionnel même en bootant sans
écran.

--
LL
Emmanuel Florac
Le #24758872
Le Wed, 05 Sep 2012 17:33:39 +0200, Lucas Levrel a écrit:


Pour ton problème : qu'as-tu mis dans ton xorg.conf "minimal" ? On a ici
des machines qui, je crois, ont un DM fonctionnel même en bootant sans
écran.




Je pense que c'est lié au driver: apparemment avec les intel intégrés et
les radeon, c'est la misère. Pour le xorg minimal, j'ai fait un X -detect
puis j'ai ajouté les modlines pour un moniteur virtuel basique; ensuite
j'ai ajouté quelques lignes suggérées sur le net pour désactiver le DDC
mais que dalle... J'ai la forte impression que le xorg.conf est
absolument ignoré.

--
Sutor ne ultra Crepidam.
Lucas Levrel
Le #24760342
Le 5 septembre 2012, Emmanuel Florac a écrit :

Je pense que c'est lié au driver: apparemment avec les intel intégrés et
les radeon, c'est la misère. Pour le xorg minimal, j'ai fait un X -detect
puis j'ai ajouté les modlines pour un moniteur virtuel basique; ensuite
j'ai ajouté quelques lignes suggérées sur le net pour désactiver le DDC
mais que dalle... J'ai la forte impression que le xorg.conf est
absolument ignoré.



S'il est pris en compte tu devrais avoir
(==) Using config file: "/etc/X11/xorg.conf"
au début du log, puis des lignes
(**) Option ...
correspondant à son contenu.

Sinon, as-tu essayé l'option -config à l'appel d'Xorg ?

Sur une machine plus récente, il n'y a pas de xorg.conf mais un répertoire
xorg.conf.d, et le log contient
(==) Using config directory: "/etc/X11/xorg.conf.d"

--
LL
Publicité
Poster une réponse
Anonyme