jours ouvrables

Le
surplus Hors ligne
Bonjour,
comment calculer les jours ouvrables dans une semaine en incluant le samedi
nbjoursouvrés donne resultat 5 j et moi ça doit donner 6 donc 12 si 2 semaines et 18 si 3 semaines
merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #24526621
Bonjour,

Si tu es français :

Pour ne pas compter les dimanches. Dans la formule, Fériés représente une plage nommée
qui contient la liste des journées fériées. Si une journée fériée dans cette liste tombe
parmi les jours
travaillés (sauf les dimanches), elle est enlevée du total.

La cellule A1 : Date de départ
la cellule A2 : Date de fin de la période.

=SOMMEPROD((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));2)<7)*(NB.SI(fériés;LIGNE(INDIRECT(A1&":"&A2)))=0))

Si tu ne veux pas tenir compte des jours fériés, ceci est satisfaisant :
=SOMMEPROD((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));2)<7)*1)

Si tu es nord-américain,
=SOMMEPROD((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));1)<>1)*(NB.SI(fériés;LIGNE(INDIRECT(A1&":"&A2)))=0))

OU
=SOMMEPROD((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));1)<>1)*1)
surplus Hors ligne
Le #24527561
Le vendredi 01 Juin 2012 à 01:57 par MichD :
Bonjour,

Si tu es français :

Pour ne pas compter les dimanches. Dans la formule, Fériés
représente une plage nommée
qui contient la liste des journées fériées. Si une
journée fériée dans cette liste tombe
parmi les jours
travaillés (sauf les dimanches), elle est enlevée du total.

La cellule A1 : Date de départ
la cellule A2 : Date de fin de la période.

=SOMMEPROD((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));2)<7)*(NB.SI(fériés;LIGNE(INDIRECT(A1&":"&A2)))=0))

Si tu ne veux pas tenir compte des jours fériés, ceci est
satisfaisant :
=SOMMEPROD((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));2)<7)*1)

Si tu es nord-américain,
=SOMMEPROD((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));1)<>1)*(NB.SI(fériés;LIGNE(INDIRECT(A1&":"&A2)))=0))

OU
=SOMMEPROD((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));1)<>1)*1)


bonjour
avec ta methode 1 cela me donne 84 comme resultats
la 2 me conviendrait mais faudrait decompter les fériés
car j avais deja une formule avec plage de depart et plage de rentrée et plage de fériés
avec ta formule Ca donne 1 jour de trop
selon ces bases
http://www.gestiondelapaie.com/decompte_conges/decompte_conges.php
merci
MichD
Le #24527711
Désolé, je n'ai pas le temps à tester ce que tu présentes.

Fais-moi un exemple dans un fichier Excel de ce qui ne fonctionne pas
et publie-le en utilisant l'adresse cjoint.com. Tu dois nous retourner
l'adresse obtenue ici.
surplus Hors ligne
Le #24528441
Le vendredi 01 Juin 2012 à 01:22 par surplus :
Bonjour,
comment calculer les jours ouvrables dans une semaine en incluant le samedi
nbjoursouvrés donne resultat 5 j et moi ça doit donner 6 donc 12
si 2 semaines et 18 si 3 semaines
merci


bonjour
j'ai fait le fichier
http://cjoint.com/?BFbtzVKBAdF
j ai marqué la somme a trouver par rapport au site
http://www.gestiondelapaie.com/decompte_conges/decompte_conges.php
il y a des plages conditions a transcrire sur juin ou juillet mais je pourrais le voir apres et des jours fériés plages départ congés et rentré congé 2 plages pour chacun
j espère être clair
a bientôt
surplus Hors ligne
Le #24533621
Le vendredi 01 Juin 2012 à 01:22 par surplus :
Bonjour,
comment calculer les jours ouvrables dans une semaine en incluant le samedi
nbjoursouvrés donne resultat 5 j et moi ça doit donner 6 donc 12
si 2 semaines et 18 si 3 semaines
merci


bonsoir
MichD pas de nouvelles c'est en cours ou abandonné?
je tourne en rond mais toujours rien de mon coté
merci
a bientôt
surplus Hors ligne
Le #24535911
Le vendredi 01 Juin 2012 à 01:22 par surplus :
Bonjour,
comment calculer les jours ouvrables dans une semaine en incluant le samedi
nbjoursouvrés donne resultat 5 j et moi ça doit donner 6 donc 12
si 2 semaines et 18 si 3 semaines
merci


bonjour
merci de ton aide j ai trouvé la solution
a bientot
Publicité
Poster une réponse
Anonyme