KDE4 dans sid

Le
Patrice OLIVER
Bonjour,

Je suis en Debian SID.
J'ai tenté d'installer KDE4, mais j'ai obtenu les messages suivants :

apt-get -t experimental install kde4
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
kde4: Dépend: extragear-plasma (>= 4:4.0.0) mais ne sera pas install=
é
Dépend: kde4-minimal (>= 1) mais ne sera pas installé
Dépend: kdeadmin (>= 4:4.0.0) mais 4:3.5.9-1 devra être insta=
llé
Dépend: kdeartwork (>= 4:4.0.0) mais ne sera pas installé
Dépend: kdeedu (>= 4:4.0.0) mais 4:3.5.9-1 devra être install=
é
Dépend: kdegames (>= 4:4.0.0) mais ne sera pas installé
Dépend: kdegraphics (>= 4:4.0.0) mais 4:3.5.9-1 devra être in=
stallé
Dépend: kdemultimedia (>= 4:4.0.0) mais 4:3.5.9-1 devra être =
installé
Dépend: kdenetwork (>= 4:4.0.0) mais ne sera pas installé
Dépend: kdeutils (>= 4:4.0.0) mais 4:3.5.9-1 devra être insta=
llé
E: Paquets défectueux

Bizarre, cela a fonctionné du premier coup sur une kubuntu.

Quelqu'un aurait une piste ?

Merci.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Patrice OLIVER
Le #9678121
Le 6 mai 2008 09:46, Christophe Mouilleron
On Tue, May 06, 2008 at 09:27:22AM +0200, Patrice OLIVER wrote:
> Bonjour,
>
> Je suis en Debian SID.
> J'ai tenté d'installer KDE4, mais j'ai obtenu les messages suivants :
>
> apt-get -t experimental install kde4

> Bizarre, cela a fonctionné du premier coup sur une kubuntu.
>
> Quelqu'un aurait une piste ?
>
> Merci.
Bonjour,

Le mot «experimental» est une piste. Kde 4 N'est PAS dans la unstabl e de
debian pour le moment. Le paquet que tu as pris venait d'un dépôt
expérimental. Or, les paquets venant des dépôts expérimentaux
n'offrent aucunes garanties. Il vaut mieux les éviter à moins de bie n
savoir ce qu'on fait.

Bonne journée.
Christophe.




Ok avec toi, mais toutes les procédures que j'ai trouvé sur le net
indiquent que qu'ils faut récupérer les paquets dans les dépôts
expérimentaux. Pour Kubuntu, cela s'installe "tout seul".

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Anthony
Le #9678101
Pour info

http://pkg-kde.alioth.debian.org/experimental.html


Patrice OLIVER a écrit :
Le 6 mai 2008 09:46, Christophe Mouilleron

On Tue, May 06, 2008 at 09:27:22AM +0200, Patrice OLIVER wrote:
> Bonjour,
>
> Je suis en Debian SID.
> J'ai tenté d'installer KDE4, mais j'ai obtenu les messages suivants :
>
> apt-get -t experimental install kde4


Bizarre, cela a fonctionné du premier coup sur une kubuntu.



>
> Quelqu'un aurait une piste ?
>
> Merci.
Bonjour,

Le mot «experimental» est une piste. Kde 4 N'est PAS dans la unstable de
debian pour le moment. Le paquet que tu as pris venait d'un dépôt
expérimental. Or, les paquets venant des dépôts expérimentaux
n'offrent aucunes garanties. Il vaut mieux les éviter à moins de bien
savoir ce qu'on fait.

Bonne journée.
Christophe.





Ok avec toi, mais toutes les procédures que j'ai trouvé sur le net
indiquent que qu'ils faut récupérer les paquets dans les dépôts
expérimentaux. Pour Kubuntu, cela s'installe "tout seul".





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Anthony
Le #9678111
bonjour,

quel est ton sources.list...?
il doit bien contenir "experimental" :

deb http://ftp.de.debian.org/debian/ experimental main non-free contrib
deb-src http://ftp.de.debian.org/debian/ experimental main non-free contrib


Test :
apt-get -t experimental install kde4 extragear-plasma kde4-minimal
kdeadmin kdeartwork kdeedu kdegames kdegraphics kdemultimedia kdenetwork
kdeutils




Patrice OLIVER a écrit :
Bonjour,

Je suis en Debian SID.
J'ai tenté d'installer KDE4, mais j'ai obtenu les messages suivants :

apt-get -t experimental install kde4
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
kde4: Dépend: extragear-plasma (>= 4:4.0.0) mais ne sera pas installé
Dépend: kde4-minimal (>= 1) mais ne sera pas installé
Dépend: kdeadmin (>= 4:4.0.0) mais 4:3.5.9-1 devra être installé
Dépend: kdeartwork (>= 4:4.0.0) mais ne sera pas installé
Dépend: kdeedu (>= 4:4.0.0) mais 4:3.5.9-1 devra être installé
Dépend: kdegames (>= 4:4.0.0) mais ne sera pas installé
Dépend: kdegraphics (>= 4:4.0.0) mais 4:3.5.9-1 devra être installé
Dépend: kdemultimedia (>= 4:4.0.0) mais 4:3.5.9-1 devra être installé
Dépend: kdenetwork (>= 4:4.0.0) mais ne sera pas installé
Dépend: kdeutils (>= 4:4.0.0) mais 4:3.5.9-1 devra être installé
E: Paquets défectueux

Bizarre, cela a fonctionné du premier coup sur une kubuntu.

Quelqu'un aurait une piste ?

Merci.





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Patrice OLIVER
Le #9677641
Le 6 mai 2008 14:56, Anthony

OK

Donc utilise

aptitude -t experimental install kde4

aptitude va gérer les dépendances...

bon kde4

anthony




Ben justement non, c'est justement l'objet de mon message initial
;)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Nicolas
Le #9677471
On 6 mai, 10:50, "Patrice OLIVER"
Le 6 mai 2008 09:46, Christophe Mouilleron



> On Tue, May 06, 2008 at 09:27:22AM +0200, Patrice OLIVER wrote:
>  > Bonjour,

>  > Je suis en Debian SID.
>  > J'ai tenté d'installer KDE4, mais j'ai obtenu les messages suivan ts :

>  >  apt-get -t experimental install kde4


Ok avec toi, mais toutes les procédures que j'ai trouvé sur le net
indiquent que qu'ils faut récupérer les paquets dans les dépôts
expérimentaux. Pour Kubuntu, cela s'installe "tout seul".



J'ai fait le grand saut vers kde4 en experimental il y a un moment, et
à moins de tomber sur un moment d'update des packages (*), il suffit
soit de virer kde 3 avant l'upgrade, soit d'installer chaque package 1
à 1 : en gros tu installes chaque package que ça site dans la liste
des dépendances non satisfaites à coups de "aptitude -t experimental
install"...
Ceci dit ya surement un meilleur moyen que cette dernière solution,
j'ai jamais bien cherché pour ces histoires de pinning avec apt...

Bon courage :)

(*) personnellement avec une autre machine je suis tombé juste au
mauvais moment : quand certains packages étaient passés en svn de la
4.1, alors que d'autres étaient encore en 4.0... le bordel quoi ^^`

--
Nicolas

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme