Kernel > 2.6.26 Freeza à la sortie d'un suspend to ram

Le
Thierry Leurent
Bonsoir,

Afin de maire fonctionner ma carte Wifi avec ath5k, j'ai décidé de pass=
ée à une
version supérieur de mon kernel, un 2.6.26-1 de chez debian.
J'ai donc essayé :
- Le debian sid 2.6.29-1
- le sidux 2.6.29
- kubuntu 2.6.29

et enfin le kubuntu 2.6.30-rc3

Avec tous ces kernel, j'ai constaté 2 choses, l'amélioration du driver =
ath5k
et un freeze quand je veux sortir d'un suspend to ram.

Quelqu'un a-t-il déjà rencontré ce probème ?

Merci

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
thveillon.debian
Le #19241371
Thierry Leurent a écrit :
Bonsoir,

Afin de maire fonctionner ma carte Wifi avec ath5k, j'ai décidé de passée à une
version supérieur de mon kernel, un 2.6.26-1 de chez debian.
J'ai donc essayé :
- Le debian sid 2.6.29-1
- le sidux 2.6.29
- kubuntu 2.6.29

et enfin le kubuntu 2.6.30-rc3

Avec tous ces kernel, j'ai constaté 2 choses, l'amélioration du driver ath5k
et un freeze quand je veux sortir d'un suspend to ram.

Quelqu'un a-t-il déjà rencontré ce probème ?

Merci




Salut,

avec ath5k + NetworkManager j'ai des gèles complets du système
régulièrement (des séquences déconnexion/re-connexion toutes les
secondes puis freeze complet), quelque soit le noyau (2.6.[26,27,28]).
Avec ath5k + wicd ça marche au poil.

Tu peux toujours essayer.

Tom

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
François Cerbelle
Le #19244811
Thierry Leurent a écrit :
Avec tous ces kernel, j'ai constaté 2 choses, l'amélioration du driver ath5k
et un freeze quand je veux sortir d'un suspend to ram.
Quelqu'un a-t-il déjà rencontré ce probème ?



Perso, sur mon Aspire one A110, j'ai une carte
03:00.0 Ethernet controller: Atheros Communications Inc. AR242x
802.11abg Wireless PCI Express Adapter (rev 01)

Sachant que la carte n'est correctement gérée que par MadWifi ou un
noyau 2.6.29, j'ai pris le .config du noyau Debian SID et les sources
d'un noyau pure "vanille". J'ai patché 5 lignes d'un fichier pour avoir
aussi la gestion de la LED (ajoutée proprement en tant que classe dans
/sys/class/leds et utilisable comme heartbeat si on veut, par exemple),
j'ai désactivé le matériel qui ne pourra jamais etre connecté au
portable (port parallele, port serie RS232, cartes son, cartes videos,
...), configuré en dur ce qui ne pourra pas en etre retiré (carte ath,
carte reseau, carte video, lecteur de cartes SD, carte son...) et aussi
le systeme de fichier ext2 (pour m'eviter la nécessité d'un initrd).
J'ai recompilé et le noyau est parfaitement stable en toute occasion.

Je tiens le .config à disposition de qui le voudrait. Quant au patch
"LED ath" :
----------------------------------------------------------------
diff -uNr linux-source-2.6.29/drivers/net/wireless/ath5k/base.c
linux-source-2.6.29aspire1/drivers/net/wireless/ath5k/base.c
--- linux-source-2.6.29/drivers/net/wireless/ath5k/base.c
2009-03-23 23:12:14.000000000 +0000
+++ linux-source-2.6.29aspire1/drivers/net/wireless/ath5k/base.c
2009-03-31 10:37:35.000000000 +0000
@@ -2619,6 +2619,13 @@
sc->led_pin = 1;
sc->led_on = 1; /* active high */
}
+ /* Pin 3 on Foxconn chips used in Acer Aspire One (0x105b:e008) */
+ if (pdev->subsystem_vendor == PCI_VENDOR_ID_FOXCONN) {
+ __set_bit(ATH_STAT_LEDSOFT, sc->status);
+ sc->led_pin = 3;
+ sc->led_on = 0; /* active low */

+ }
+
if (!test_bit(ATH_STAT_LEDSOFT, sc->status))
goto out;

diff -uNr linux-source-2.6.29/include/linux/pci_ids.h
linux-source-2.6.29aspire1/include/linux/pci_ids.h
--- linux-source-2.6.29/include/linux/pci_ids.h 2009-03-24
13:51:20.000000000 +0000
+++ linux-source-2.6.29aspire1/include/linux/pci_ids.h 2009-03-31
10:38:27.000000000 +0000
@@ -834,6 +834,8 @@
#define PCI_DEVICE_ID_PROMISE_20276 0x5275
#define PCI_DEVICE_ID_PROMISE_20277 0x7275

+#define PCI_VENDOR_ID_FOXCONN 0x105b
+
#define PCI_VENDOR_ID_UMC 0x1060
#define PCI_DEVICE_ID_UMC_UM8673F 0x0101
#define PCI_DEVICE_ID_UMC_UM8886BF 0x673a
----------------------------------------------------------------

J'ai aussi patché coretemp pour avoir le capteur de temperature du
processeur, mais ca ne parche pas chez moi.

Le seul vrai problème est au niveau du pilote video intel qui a tendance
à faire geler certains hacks de xscreensaver GL à certains moments
precis à cause d'un vblank quelquechose. Mais ce n'est pas bloquant, un
kill du hack ou l'attente du hack suivant (rotation des hacks toutes les
minutes) dégèle l'affichage/clavier.

Voila, j'espere t'avoir aidé quant à ta carte ath5k. Si tu veux mon
.config, demande en privé.

Fanfan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Frédéric Boiteux
Le #19268021
Le Fri, 1 May 2009 23:47:02 +0200,
Thierry Leurent
Bonsoir,

Afin de maire fonctionner ma carte Wifi avec ath5k, j'ai décidé de
passée à une version supérieur de mon kernel, un 2.6.26-1 de chez
debian. J'ai donc essayé :
- Le debian sid 2.6.29-1
- le sidux 2.6.29
- kubuntu 2.6.29

et enfin le kubuntu 2.6.30-rc3

Avec tous ces kernel, j'ai constaté 2 choses, l'amélioration du
driver ath5k et un freeze quand je veux sortir d'un suspend to ram.

Quelqu'un a-t-il déjà rencontré ce probème ?



Bonjour,

J'ai un Asus 1002HE, qui a une carte Atheros gérée par le module ath9k
(et non ath5k). J'y ai installé Lenny à l'époque et le 2.6.2 8 (le
2.6.26 n'avait pas encore le module ath9k), et tout marchait très bien,
y compris les s2ram et s2disk. Depuis, j'ai tenté les versions 2.6.29,
et avec les 4 premières passées dans Sid, j'ai des crashs
[aléatoires] en sortie de s2ram, de la corruption au niveau de
l'affichage, bref cela ne marche pas :-( Malheureusement, on ne trouve
plus le paquet du 2.6.28 chez Debian ...

Fred.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
David Prévot
Le #19269281
Frédéric Boiteux a écrit :

Bonjour,



Bonjour,

[...] Malheureusement, on ne trouve
plus le paquet du 2.6.28 chez Debian ...



Il y est sur le snapshot tout de même
http://snapshot.debian.net/

Amicalement

David

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Frédéric Boiteux
Le #19269261
Le Tue, 05 May 2009 09:32:09 -0400,
David Prévot
Frédéric Boiteux a écrit :

> Bonjour,

Bonjour,

> [...] Malheureusement, on ne trouve
> plus le paquet du 2.6.28 chez Debian ...

Il y est sur le snapshot tout de même
http://snapshot.debian.net/



Peut-être, mais je ne le trouves pas :-( Comment se rédige le cha mp
« package name pattern » ? Je n'ai pas trouvé d'ex plication, et les
patterns à la shell, sed, perl ne marchent pas...

Fred.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
David Prévot
Le #19271231
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Frédéric Boiteux a écrit :
Le Tue, 05 May 2009 09:32:09 -0400,
David Prévot
Frédéric Boiteux a écrit :

Bonjour,


Bonjour,

[...] Malheureusement, on ne trouve
plus le paquet du 2.6.28 chez Debian ...


Il y est sur le snapshot tout de même
http://snapshot.debian.net/



Peut-être, mais je ne le trouves pas :-(



J'ai aussi des difficultés à utiliser snapshot, mais j'avais vérifié
qu'il était accessible, par exemple avec le classement par date [1]. Si
quelqu'un connaît une méthode plus élégante, je serais son bon lecteur.

[1]http://snapshot.debian.net/archive/2009/03/28/debian/pool/main/l/linux-2.6/

Amicalement

David

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkoAZwAACgkQ18/WetbTC/rlSQCgip1wUBxw6XI6/Ev9GgcICUP5
UlIAmgMcvlo0TCOCoBBh/MpA1ncc9mVQ
=g2Ls
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme