Lancement lent...

Le
Denis Beauregard
Bonjour,


J'ai écrit mon premier programme en java et j'ai déjà des
petits problèmes.

Chez moi, cela fonctionne bien. Il y a un délai au départ, mais c'est
toujours le cas en java.

Puis, j'ai recopié l'applet sur mon site à cette adresse, en incluant
tout.

http://www.francogene.com/java/

Au 1er essai, le navigateur (Seamonkey 2.3.3) a gelé. Puis, j'ai
fermé (ou tué) le navigateur, puis relancé, et cela fonctionne bien.

Avec FF 6.0.2, j'ai vu le logo java puis plus rien. Pas de plantage
mais j'ai rechargé pour que cela fonctionne. Avec IE8, départ du 1er
coup avec aussi le logo java (qui était absent avec Seamonkey).

Sur un autre PC, IE9 semble ne pas avoir Java pré-installé et affiche
le message disant qu'il ne sait pas quoi faire avec l'applet.

Est-ce que java est toujours aussi lent, donc à éviter comme ornement
inutile mais joli ? J'ai déjà vu des sites lents avec mon ancien
ordi (j'avais Windows 98). J'ai maintenant une machine moderne et
c'est une applet un peu complexe (6 classes, près de 28k) avec du
graphisme, etc. Rien de sophistiqué mais il me semble avoir vu des
trucs beaucoup plus compliqués sur mon vieux PC sans que cela prenne
longtemps avant de voir le résultat.


Denis

--
Denis Beauregard - généalogiste émérite (FQSG)
Les Français d'Amérique du Nord - www.francogene.com/genealogie--quebec/
French in North America before 1722 - www.francogene.com/quebec--genealogy/
Sur cédérom à 1780 - On CD-ROM to 1780
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
yamo'
Le #23765361
Salut,

Denis Beauregard a tapoté, le 16/09/2011 01:29:
http://www.francogene.com/java/

Au 1er essai, le navigateur (Seamonkey 2.3.3) a gelé. Puis, j'ai
fermé (ou tué) le navigateur, puis relancé, et cela fonctionne bien.



Chez moi, ça fonctionne très bien Seamonkey 2.3.3 XUbuntu 11.04 JRE :
openjdk-6-jre

--
Stéphane


On peut être plus fin qu'un autre, mais non pas plus fin que tous les
autres.
-+- François de La Rochefoucauld (1613-1680), Maximes 394 -+-
Mayeul
Le #23765351
On 16/09/2011 01:29, Denis Beauregard wrote:
Bonjour,


J'ai écrit mon premier programme en java et j'ai déjà des
petits problèmes.

Chez moi, cela fonctionne bien. Il y a un délai au départ, mais c'est
toujours le cas en java.

Puis, j'ai recopié l'applet sur mon site à cette adresse, en incluant
tout.

http://www.francogene.com/java/

Au 1er essai, le navigateur (Seamonkey 2.3.3) a gelé. Puis, j'ai
fermé (ou tué) le navigateur, puis relancé, et cela fonctionne bien.

Avec FF 6.0.2, j'ai vu le logo java puis plus rien. Pas de plantage
mais j'ai rechargé pour que cela fonctionne. Avec IE8, départ du 1er
coup avec aussi le logo java (qui était absent avec Seamonkey).

Sur un autre PC, IE9 semble ne pas avoir Java pré-installé et affiche
le message disant qu'il ne sait pas quoi faire avec l'applet.

Est-ce que java est toujours aussi lent, donc à éviter comme ornement
inutile mais joli ? J'ai déjà vu des sites lents avec mon ancien
ordi (j'avais Windows 98). J'ai maintenant une machine moderne et
c'est une applet un peu complexe (6 classes, près de 28k) avec du
graphisme, etc. Rien de sophistiqué mais il me semble avoir vu des
trucs beaucoup plus compliqués sur mon vieux PC sans que cela prenne
longtemps avant de voir le résultat.




Chez moi, avec Firefox 6.0.2 et Chrome à jour, ce n'est pas lent du tout.
Le téléchargement lui-même est un peu lent, oui, et la barre prend
quelques secondes à se remplir. Mais l'applet se charge immédiatement et
a l'air de fonctionner convenablement.

Mon plugin Java est la version 1.6.0_24

De manière générale, sauf pour des choses totalement triviales, Java est
assez lourd et lent au démarrage, oui. En tant qu'applet, il y a
tellement de limitations de sécurité et il est si rarement installé, que
je préfère le considérer comme un ornement inutile.
Mais pas à ce point-là.

Il doit y avoir un problème avec votre installation de Java. Pas avec
votre applet.

--
Mayeul
Christian Laborde
Le #23765541
Le 16. 09. 11 01:29, Denis Beauregard a écrit :
Bonjour,


J'ai écrit mon premier programme en java et j'ai déjà des
petits problèmes.

Chez moi, cela fonctionne bien. Il y a un délai au départ, mais c'est
toujours le cas en java.

Puis, j'ai recopié l'applet sur mon site à cette adresse, en incluant
tout.

http://www.francogene.com/java/

Au 1er essai, le navigateur (Seamonkey 2.3.3) a gelé. Puis, j'ai
fermé (ou tué) le navigateur, puis relancé, et cela fonctionne bien.

Avec FF 6.0.2, j'ai vu le logo java puis plus rien. Pas de plantage
mais j'ai rechargé pour que cela fonctionne. Avec IE8, départ du 1er
coup avec aussi le logo java (qui était absent avec Seamonkey).

Sur un autre PC, IE9 semble ne pas avoir Java pré-installé et affiche
le message disant qu'il ne sait pas quoi faire avec l'applet.

Est-ce que java est toujours aussi lent, donc à éviter comme ornement
inutile mais joli ? J'ai déjà vu des sites lents avec mon ancien
ordi (j'avais Windows 98). J'ai maintenant une machine moderne et
c'est une applet un peu complexe (6 classes, près de 28k) avec du
graphisme, etc. Rien de sophistiqué mais il me semble avoir vu des
trucs beaucoup plus compliqués sur mon vieux PC sans que cela prenne
longtemps avant de voir le résultat.


Denis



Pas de problème pour moi. Téléchargement très rapide et
démarrage presque instantané. Pas le temps de voir le logo Java.
Ma config :
CPU Core I5 750 sur carte mère Asus P7H55
Linux OpenSUSE 11.4
Firefox 6.0.2
JDK 6 de Sun

--
Christian Laborde
La Révolution citoyenne, c'est sur : http://c.lab.over-blog.com/
Les citoyens qui voient Net : http://www.netoyens.info
True E-mail : remove -no-spam-
Sentier des Vinches
CH 1091 Grandvaux
Suisse
Denis Beauregard
Le #23766681
Le Thu, 15 Sep 2011 19:29:12 -0400, Denis Beauregard
fr.comp.lang.java:

Bonjour,


J'ai écrit mon premier programme en java et j'ai déjà des
petits problèmes.

Chez moi, cela fonctionne bien. Il y a un délai au départ, mais c'est
toujours le cas en java.

Puis, j'ai recopié l'applet sur mon site à cette adresse, en incluant
tout.

http://www.francogene.com/java/

Au 1er essai, le navigateur (Seamonkey 2.3.3) a gelé. Puis, j'ai
fermé (ou tué) le navigateur, puis relancé, et cela fonctionne bien.



Nouvel essai ce matin, à froid.

Si je reprends une applet déjà utilisée, c'est rapide. Si j'en regarde
une nouvelle, l'écran reste blanc. Si je regarde un autre onglet avec
une image (comme Google Maps), l'autre onglet reste affiché vis-à-vis
l'applet. Pourtant, le site Java me dit que mon Java est bien installé
et que j'ai la dernière version.

J'ai la version 6.0.270.0 ou JRE 6 release 27. Je voudrais réduire à
24 pour voir si c'est le problème (vu que c'est la version de
quelqu'un chez qui cela fonctionne), mais je ne vois pas comment
obtenir les anciennes versions sur le site officiel : seulement 6-27
ou 7.

Par ailleurs, après un nouvel essai, rien n'est encore apparu sur SM
après avoir répété l'affichage. Je ne vois rien qui pourrait bloquer
dans la configuration. Je n'ai que ces plug-ins :

Acrobat 10
Java Deployment Toolkit 6.0.270.7
Java Platform
Flsh 10
Silverlight 4
Windows Live Photo Gallery 14

about:config a cette seule variable

dom.ipc.plugins.java.enabled;false

Je l'ai mis à true et cela ne change rien, mais j'ai pu voir le logo
Java tourner de façon aléatoire.

Sur FF 6, j'ai eu à peu près les mêmes problèmes, avec en plus ce
diagnostic !

charger : classe Famille4.class introuvable.
java.lang.ClassNotFoundException: Famille4.class
at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Exception : java.lang.ClassNotFoundException: Famille4.class



Pourtant, cette classe est bien présente sur le serveur et le fichier
a la même grandeur que sur mon PC.

Merci pour vos commentaires.


Denis

--
Denis Beauregard - généalogiste émérite (FQSG)
Les Français d'Amérique du Nord - www.francogene.com/genealogie--quebec/
French in North America before 1722 - www.francogene.com/quebec--genealogy/
Sur cédérom à 1780 - On CD-ROM to 1780
Bertrand Usse
Le #23767211
Denis Beauregard wrote:
Le Thu, 15 Sep 2011 19:29:12 -0400, Denis Beauregard
fr.comp.lang.java:

Bonjour,

J'ai écrit mon premier programme en java et j'ai déjà des
petits problèmes.

[...]

http://www.francogene.com/java/

Au 1er essai, le navigateur (Seamonkey 2.3.3) a gelé. Puis, j'ai
fermé (ou tué) le navigateur, puis relancé, et cela fonctionne bien.



Nouvel essai ce matin, à froid.

[...] (soucis toujours)



L'applet a bien fonctionné du premier coup avec SeaMonkey 2.3.3 sur
Windows XP Pro 32 SP3 et Java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)

Le temps de chargement a surtout été conditionné par le premier
lancement de la machine virtuelle parce que j'ai ensuite essayé avec
Firefox 6.0.2 (toujours sur la même machine) et là ça a été instantané !

En espérant que ce retour puisse t'aider.

Configuration matérielle de la machine de test :
AMD Atlon XP 2600+ à 1.92Ghz avec 1Go de RAM et NVIDIA GeForce 2 GTS

l'animation des rectangles et des trais les reliant est très fluide

Tu as sûrement un problème avec l'installation de Java ou bien un
programme tiers qui ralenti Java et/ou les navigateurs utilisés.

En espérant que ce retour te sois utile ...
Denis Beauregard
Le #23767221
Le Fri, 16 Sep 2011 18:53:12 +0200, Bertrand Usse

Denis Beauregard wrote:

http://www.francogene.com/java/

Au 1er essai, le navigateur (Seamonkey 2.3.3) a gelé. Puis, j'ai
fermé (ou tué) le navigateur, puis relancé, et cela fonctionne bien.



Nouvel essai ce matin, à froid.

[...] (soucis toujours)



L'applet a bien fonctionné du premier coup avec SeaMonkey 2.3.3 sur
Windows XP Pro 32 SP3 et Java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)




J'ai l'impression que mon problème vient du serveur et non du
navigateur.

J'ai 3 façons d'essayer mon code : directement file://, via mon site
et via easyphp, donc en local mais avec du http:. En local, cela ne
donne pas de problème. C'est instantanée. Sur le site, cela donne
l'impression que le serveur ne répond pas (il y a 4 classes à lire).
Par ailleurs, le ftp fonctionne mal. Donc, problème potentiel avec
ma connexion au réseau, ce qui ennuie quand on veut tester. Mais
je vais contourner ce problème avec EasyPHP puisque les conditions
devraient être similaires.

Ceci dit, j'ai eu des messages d'erreurs qui semblent confirmer que
le serveur (ou le réseau) répond mal. L'un d'eux mentionnait l'absence
de la classe principale alors qu'elle était sur le réseau. J'ai aussi
téléchargé plusieurs fois certaines classes.

Merci de votre essai.


Denis

--
Denis Beauregard - généalogiste émérite (FQSG)
Les Français d'Amérique du Nord - www.francogene.com/genealogie--quebec/
French in North America before 1722 - www.francogene.com/quebec--genealogy/
Sur cédérom à 1780 - On CD-ROM to 1780
Wykaaa
Le #23767641
Denis Beauregard a écrit :
Bonjour,


J'ai écrit mon premier programme en java et j'ai déjà des
petits problèmes.

Chez moi, cela fonctionne bien. Il y a un délai au départ, mais c'est
toujours le cas en java.

Puis, j'ai recopié l'applet sur mon site à cette adresse, en incluant
tout.

http://www.francogene.com/java/

Au 1er essai, le navigateur (Seamonkey 2.3.3) a gelé. Puis, j'ai
fermé (ou tué) le navigateur, puis relancé, et cela fonctionne bien.

Avec FF 6.0.2, j'ai vu le logo java puis plus rien. Pas de plantage
mais j'ai rechargé pour que cela fonctionne. Avec IE8, départ du 1er
coup avec aussi le logo java (qui était absent avec Seamonkey).

Sur un autre PC, IE9 semble ne pas avoir Java pré-installé et affiche
le message disant qu'il ne sait pas quoi faire avec l'applet.

Est-ce que java est toujours aussi lent, donc à éviter comme ornement
inutile mais joli ? J'ai déjà vu des sites lents avec mon ancien
ordi (j'avais Windows 98). J'ai maintenant une machine moderne et
c'est une applet un peu complexe (6 classes, près de 28k) avec du
graphisme, etc. Rien de sophistiqué mais il me semble avoir vu des
trucs beaucoup plus compliqués sur mon vieux PC sans que cela prenne
longtemps avant de voir le résultat.


Denis



Cet applet ne fonctionne avec aucun de mes navigateur sous Mac OS 10.5.8
(Mac Pro early 2008 bi-quad 2*3.2 GHz, 10 Go de RAM). Sous Chrome j'ai
ceci :
Module Java 1.6.0_26
Utilisation de la version JRE 1.5.0_30-b03-389-9M3425 Java HotSpot(TM)
Client VM

java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at
sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:247)
at
sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Plugin2ClassLoader.java:250)
at
sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:180)
at
sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:161)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at
sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:675)
at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:3046)
at
sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1498)
at java.lang.Thread.run(Thread.java:655)
Exception : java.lang.UnsupportedClassVersionError: Bad version number
in .class file

Mes préférences Java sont réglées comme suit pour l'ordre de recherche
des versions :
J2SE 5.0 32 bits 1.5.0_30-b03
Java SE6 64 bits 1.6.0_26-b03-384
J2SE 5.0 64 bits 1.5.0_30-b03

Sur mon iMac dernier cri (juin 2011) sous Mac OS 10.6.8 (2.8 GHz, 8 Go
de RAM) ça fonctionne sous Firefox 6.0.2 et sous Safari 5.1 avec Java
SE6 64 bits 1.6.0_26-b03-384

Voilà, voilà.
Denis Beauregard
Le #23767881
Le Fri, 16 Sep 2011 21:28:57 +0200, Wykaaa dans fr.comp.lang.java:

Denis Beauregard a écrit :

J'ai écrit mon premier programme en java et j'ai déjà des
petits problèmes.

Chez moi, cela fonctionne bien. Il y a un délai au départ, mais c'est
toujours le cas en java.



Cet applet ne fonctionne avec aucun de mes navigateur sous Mac OS 10.5.8
(Mac Pro early 2008 bi-quad 2*3.2 GHz, 10 Go de RAM). Sous Chrome j'ai
ceci :



J'ai pourtant utilisé comme source d'inspiration un des exemples du
JDK 6-26 et sur les 4 classes, j'en ai modifié une seule.


Module Java 1.6.0_26
Utilisation de la version JRE 1.5.0_30-b03-389-9M3425 Java HotSpot(TM)
Client VM

java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at
sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:247)
at
sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Plugin2ClassLoader.java:250)
at
sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:180)
at
sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:161)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at
sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:675)
at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:3046)
at
sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1498)
at java.lang.Thread.run(Thread.java:655)
Exception : java.lang.UnsupportedClassVersionError: Bad version number
in .class file

Mes préférences Java sont réglées comme suit pour l'ordre de recherche
des versions :
J2SE 5.0 32 bits 1.5.0_30-b03
Java SE6 64 bits 1.6.0_26-b03-384
J2SE 5.0 64 bits 1.5.0_30-b03



J'avais la 64 bits et je l'ai enlevée, sinon il n'y avait rien du tout
en local (via file://).


Sur mon iMac dernier cri (juin 2011) sous Mac OS 10.6.8 (2.8 GHz, 8 Go
de RAM) ça fonctionne sous Firefox 6.0.2 et sous Safari 5.1 avec Java
SE6 64 bits 1.6.0_26-b03-384

Voilà, voilà.



Merci

En passant, j'ai aussi placé l'exemple original provenant du SDK 6
pour Windows, à cette URL :

http://www.francogene.com/java/example3.html

S'il y a les mêmes problèmes, alors le bug est dans le SDK lui-même.


Denis

--
Denis Beauregard - généalogiste émérite (FQSG)
Les Français d'Amérique du Nord - www.francogene.com/genealogie--quebec/
French in North America before 1722 - www.francogene.com/quebec--genealogy/
Sur cédérom à 1780 - On CD-ROM to 1780
Wykaaa
Le #23768011
Denis Beauregard a écrit :
Le Fri, 16 Sep 2011 21:28:57 +0200, Wykaaa dans fr.comp.lang.java:

Denis Beauregard a écrit :
J'ai écrit mon premier programme en java et j'ai déjà des
petits problèmes.

Chez moi, cela fonctionne bien. Il y a un délai au départ, mais c'est
toujours le cas en java.



Cet applet ne fonctionne avec aucun de mes navigateur sous Mac OS 10.5.8
(Mac Pro early 2008 bi-quad 2*3.2 GHz, 10 Go de RAM). Sous Chrome j'ai
ceci :



J'ai pourtant utilisé comme source d'inspiration un des exemples du
JDK 6-26 et sur les 4 classes, j'en ai modifié une seule.


Module Java 1.6.0_26
Utilisation de la version JRE 1.5.0_30-b03-389-9M3425 Java HotSpot(TM)
Client VM

java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at
sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:247)
at
sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Plugin2ClassLoader.java:250)
at
sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:180)
at
sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:161)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at
sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:675)
at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:3046)
at
sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1498)
at java.lang.Thread.run(Thread.java:655)
Exception : java.lang.UnsupportedClassVersionError: Bad version number
in .class file

Mes préférences Java sont réglées comme suit pour l'ordre de recherche
des versions :
J2SE 5.0 32 bits 1.5.0_30-b03
Java SE6 64 bits 1.6.0_26-b03-384
J2SE 5.0 64 bits 1.5.0_30-b03



J'avais la 64 bits et je l'ai enlevée, sinon il n'y avait rien du tout
en local (via file://).

Sur mon iMac dernier cri (juin 2011) sous Mac OS 10.6.8 (2.8 GHz, 8 Go
de RAM) ça fonctionne sous Firefox 6.0.2 et sous Safari 5.1 avec Java
SE6 64 bits 1.6.0_26-b03-384

Voilà, voilà.



Merci

En passant, j'ai aussi placé l'exemple original provenant du SDK 6
pour Windows, à cette URL :

http://www.francogene.com/java/example3.html

S'il y a les mêmes problèmes, alors le bug est dans le SDK lui-même.



Là je n'ai carrément plus rien avec Chrome et toujours une erreur
d'exécution avec les autres navigateurs sous Mac OS 10.5.8.
Christian Laborde
Le #23768731
Le 16. 09. 11 22:58, Denis Beauregard a écrit :
Le Fri, 16 Sep 2011 21:28:57 +0200, Wykaaa dans fr.comp.lang.java:

Denis Beauregard a écrit :

J'ai écrit mon premier programme en java et j'ai déjà des
petits problèmes.

Chez moi, cela fonctionne bien. Il y a un délai au départ, mais c'est
toujours le cas en java.



Cet applet ne fonctionne avec aucun de mes navigateur sous Mac OS 10.5.8
(Mac Pro early 2008 bi-quad 2*3.2 GHz, 10 Go de RAM). Sous Chrome j'ai
ceci :



J'ai pourtant utilisé comme source d'inspiration un des exemples du
JDK 6-26 et sur les 4 classes, j'en ai modifié une seule.


Module Java 1.6.0_26
Utilisation de la version JRE 1.5.0_30-b03-389-9M3425 Java HotSpot(TM)
Client VM

java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at
sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:247)
at
sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Plugin2ClassLoader.java:250)
at
sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:180)
at
sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:161)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at
sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:675)
at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:3046)
at
sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1498)
at java.lang.Thread.run(Thread.java:655)
Exception : java.lang.UnsupportedClassVersionError: Bad version number
in .class file

Mes préférences Java sont réglées comme suit pour l'ordre de recherche
des versions :
J2SE 5.0 32 bits 1.5.0_30-b03
Java SE6 64 bits 1.6.0_26-b03-384
J2SE 5.0 64 bits 1.5.0_30-b03



J'avais la 64 bits et je l'ai enlevée, sinon il n'y avait rien du tout
en local (via file://).


Sur mon iMac dernier cri (juin 2011) sous Mac OS 10.6.8 (2.8 GHz, 8 Go
de RAM) ça fonctionne sous Firefox 6.0.2 et sous Safari 5.1 avec Java
SE6 64 bits 1.6.0_26-b03-384

Voilà, voilà.



Merci

En passant, j'ai aussi placé l'exemple original provenant du SDK 6
pour Windows, à cette URL :

http://www.francogene.com/java/example3.html

S'il y a les mêmes problèmes, alors le bug est dans le SDK lui-même.


Denis



Cela ne fonctionne pas pour moi.
A+


--
Christian Laborde
La Révolution citoyenne, c'est sur : http://c.lab.over-blog.com/
Les citoyens qui voient Net : http://www.netoyens.info
True E-mail : remove -no-spam-
Sentier des Vinches
CH 1091 Grandvaux
Suisse
Publicité
Poster une réponse
Anonyme