Lancer une macro avec "Entrée"

Le
Guy72
Bonjour,
Un mot est trouvé en A24, je souhaiterais voir apparaître la définition dans
une fenêtre tel que MsgBox ou UserForm ou ..(le plus facile).
Pour l'instant je le fais avec la formule ci-dessous, mais je préfairereais
une fenêtre.
'=SI($A$24=$AZ$18;RECHERCHE($AZ$18;Mots;Définitions);"").
Merci de votre aide.
--
Cordialement
Guy
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Guy72
Le #17779841
Bonjour,
Excusez, le titre ne correspond pas à la demande, pas réveillé.
--
Cordialement
Guy
"Guy72"
Bonjour,
Un mot est trouvé en A24, je souhaiterais voir apparaître la définition
dans une fenêtre tel que MsgBox ou UserForm ou ........(le plus facile).
Pour l'instant je le fais avec la formule ci-dessous, mais je
préfairereais une fenêtre.
'=SI($A$24=$AZ$18;RECHERCHE($AZ$18;Mots;Définitions);"").
Merci de votre aide.
--
Cordialement
Guy




Papyjac
Le #17788331
Bonjour Guy

Si je comprends bien, tu veux écrire une formule qui affiche une fenêtre =>
Pour cela, tu peux écrire une fonction personnalisée, par exemple

=SI($A$24=$AZ$18;MESSAGE(RECHERCHE($AZ$18;Mots;Définitions));"").

et dans le project du classeur, en VBA

SUB Message(Texte as string)
Msgbox Texte
end sub

A vérifier

--
Papyjac


"Guy72" a écrit :

Bonjour,
Excusez, le titre ne correspond pas à la demande, pas réveillé.
--
Cordialement
Guy
"Guy72"
> Bonjour,
> Un mot est trouvé en A24, je souhaiterais voir apparaître la définition
> dans une fenêtre tel que MsgBox ou UserForm ou ........(le plus facile).
> Pour l'instant je le fais avec la formule ci-dessous, mais je
> préfairereais une fenêtre.
> '=SI($A$24=$AZ$18;RECHERCHE($AZ$18;Mots;Définitions);"").
> Merci de votre aide.
> --
> Cordialement
> Guy
>
>





Guy72
Le #17788711
Bonjour Papyjac
ça na fonctionne pas, j'ai un message "Fonction non valide" et ça mets en
surbrillance le mot "MESSAGE" dans la formule.
--
Cordialement
Guy

"Papyjac" news:
Bonjour Guy

Si je comprends bien, tu veux écrire une formule qui affiche une fenêtre
=>
Pour cela, tu peux écrire une fonction personnalisée, par exemple

=SI($A$24=$AZ$18;MESSAGE(RECHERCHE($AZ$18;Mots;Définitions));"").

et dans le project du classeur, en VBA

SUB Message(Texte as string)
Msgbox Texte
end sub

A vérifier

--
Papyjac


"Guy72" a écrit :

Bonjour,
Excusez, le titre ne correspond pas à la demande, pas réveillé.
--
Cordialement
Guy
"Guy72"
> Bonjour,
> Un mot est trouvé en A24, je souhaiterais voir apparaître la définition
> dans une fenêtre tel que MsgBox ou UserForm ou ........(le plus
> facile).
> Pour l'instant je le fais avec la formule ci-dessous, mais je
> préfairereais une fenêtre.
> '=SI($A$24=$AZ$18;RECHERCHE($AZ$18;Mots;Définitions);"").
> Merci de votre aide.
> --
> Cordialement
> Guy
>
>







Publicité
Poster une réponse
Anonyme