Lancer squid automatiquement au démarrage

Le
El Hévire
Bonjour,
j'ai paramétré squid et il fonctionne correctement ; mon souci est que
je voudrais le lancer automatiquement au démarrage d'Ubuntu ;
comment procéder ?

merci d'avance

config : maverick x86 ; Squid 2.8 stable9
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Aéris
Le #23142991
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Le 20/02/2011 07:16, El Hévire a écrit :
Bonjour,
j'ai paramétré squid et il fonctionne correctement ; mon souci est que
je voudrais le lancer automatiquement au démarrage d'Ubuntu ;
comment procéder ?



Normalement il l'est par défaut
Sinon tenter un update-rc.d squid defaults
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJNYRDQAAoJEK8zQvxDY4P9FmcIAIneGXYP2Gxg5vBYFyixDBjk
/PWwDzN0xBlGFtY7k6b5iQagQqtLutKz9ebvMoQwSH9+q2R0rLNUZVORY3HHZTy9
l+H97hcZwKxMNIS1SRtuFwz9rrZUi2p901Q/WVid+j7AhG8/w6AW8mUeMMM6+MsD
POd+4Ss5p+zt6DHri3nZCX+WDcyXKB1SUPlvK7F2x2O7WGImOcchJHeQmkZ6gpSu
zWc0DVv7m6ZlXSLZedYA/uxhF0X6WV06JiUZi9yLUvCgrH0awXm6Lrs+Mg1cjVEO
Nq7NI6w5Q69mbk9wwt3Fk7NmAC+fUEgKN08EVRRV8KQrUYBAnHiQRWSsIALQsgI =dN+v
-----END PGP SIGNATURE-----
El Hévire
Le #23143041
Le 20/02/2011 16:02, Aéris a écrit :
update-rc.d squid defaults


merci de ta réponse ;

==> update-rc.d: /etc/init.d/squid: file does not exist

j'ai bien vu un site qui traite de cette méthode, mais je ne sais trop
que faire avec rc.d
Fabien LE LEZ
Le #23143301
On Sun, 20 Feb 2011 16:06:10 +0300, El Hévire
==> update-rc.d: /etc/init.d/squid: file does not exist



Quelle version de Ubuntu utilises-tu exactement ?

Apparemment /etc/init.d/squid est présent dans "Lucid" mais pas dans
"Maverick".
http://packages.ubuntu.com/lucid/amd64/squid/filelist
http://packages.ubuntu.com/maverick/amd64/squid/filelist
El Hévire
Le #23143391
Le 20/02/2011 17:44, Fabien LE LEZ a écrit :
On Sun, 20 Feb 2011 16:06:10 +0300, El Hévire
==> update-rc.d: /etc/init.d/squid: file does not exist



Quelle version de Ubuntu utilises-tu exactement ?

Apparemment /etc/init.d/squid est présent dans "Lucid" mais pas dans
"Maverick".
http://packages.ubuntu.com/lucid/amd64/squid/filelist
http://packages.ubuntu.com/maverick/amd64/squid/filelist



maverick 32

ce que j'ai fait, sans succès :

dans /etc/rc.local : sudo squid
exit 0
ai attribué les droits x à tout le monde (bizarrement sous gnome, ils
n'apparaissent pas, mais ls -l me les indique bien)
dans un lanceur depuis le menu systeme, gksudo squid en m'arrangeant
pour qu'il ne demande pas le passe root

aucune de ces méthodes de fonctionne ; par contre, en ligne de commande
sudo squid lance le process (inutile de faire service squid start, ça
marche quand même)

tout ce que j'ai gagné, c'est réussir à ce que sudo ne me demande plus
le mot de passe pour lancer squid ; un peu court

voilà, je suis coincé ; merci à ceux qui peuvent m'aider
Aéris
Le #23143501
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Le 20/02/2011 15:44, Fabien LE LEZ a écrit :
Quelle version de Ubuntu utilises-tu exactement ?

Apparemment /etc/init.d/squid est présent dans "Lucid" mais pas dans
"Maverick".
http://packages.ubuntu.com/lucid/amd64/squid/filelist
http://packages.ubuntu.com/maverick/amd64/squid/filelist




Ça ne sera pas le 1er paquet où Ubuntu se gauffre lamentablement dessus?

Sans rire, y'a quelqu'un qui fait de la QA chez Canonical? Oserais-je
que je demanderais si quelqu'un teste les paquets avant de le releaser?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJNYTbOAAoJEK8zQvxDY4P9pMMIALEEptQ1sPmZtCyujBT0V1tQ
4YpDS28YOCsF3pSXsQbMi/G7Wf1FZT2Zz/gILhc2DoUPPF88Mn1hsMDGCpTvqf80
0h8IdJ8CpDqf5a3Q5VeBxRH5iuSUtRlizxYE831TLLKjAAy6KWzkZCjQ62E1pATh
+cYZUlRXGMVxjSkCZdzaLNb8NVYhX/LpThEIJm595xgjW2xY6sMkKAHVJ3xYK3tX
7LB4K4eN5JVSXk6IkB/WXRJZldandUsbdp2hTsQA/Q18IoEb7v6omyTCTPNx7/n7
tSTBTUxQIOOW4ispJC+WklmBdMtBLpudj53P4IZDO4ZD2l2uXT3aiH0reT7iKLo =wMCz
-----END PGP SIGNATURE-----
Fabien LE LEZ
Le #23143571
On Sun, 20 Feb 2011 16:44:18 +0100, Aéris
Ça ne sera pas le 1er paquet où Ubuntu se gauffre lamentablement dessus?



D'après le commentaire #20 sur
https://bugs.launchpad.net/ubuntu/maverick/+source/squid/+bug/573853 ,
j'ai l'impression que c'est voulu, mais je ne sais pas pourquoi.

"btw, in maverick the linked '/etc/init.d/squid' won't be created
anymore -> No upstart hint."
El Hévire
Le #23143631
Le 20/02/2011 18:55, Fabien LE LEZ a écrit :
On Sun, 20 Feb 2011 16:44:18 +0100, Aéris
Ça ne sera pas le 1er paquet où Ubuntu se gauffre lamentablement dessus?



D'après le commentaire #20 sur
https://bugs.launchpad.net/ubuntu/maverick/+source/squid/+bug/573853 ,
j'ai l'impression que c'est voulu, mais je ne sais pas pourquoi.

"btw, in maverick the linked '/etc/init.d/squid' won't be created
anymore -> No upstart hint."




et donc ?
voyez vous une solution à mon souci ?
downgrader vers 10.04 ? mais là, je perds mon touchpad de portable, géré
seulement depuis 10.10...

et j'ai besoin de squid en tant que proxy cache vu que je n'ai accès
qu'au rtc, hélas
Aéris
Le #23143691
El Hévire wrote:

downgrader vers 10.04 ? mais là, je perds mon touchpad de portable, géré
seulement depuis 10.10...



Installe uniquement squid en 10.04
Ça doit être possible avec apt
El Hévire
Le #23143741
Le 20/02/2011 19:20, Aéris a écrit :
El Hévire wrote:

downgrader vers 10.04 ? mais là, je perds mon touchpad de portable, géré
seulement depuis 10.10...



Installe uniquement squid en 10.04
Ça doit être possible avec apt



je sais pas ; j'ai viré squid, sur les dépôts maverick, y'a une version
3.1 ; je vais voir ; merci en tout cas
Benoit Izac
Le #23143831
Bonjour,

le 20/02/2011 à 16:44, Aéris a écrit dans le message

Quelle version de Ubuntu utilises-tu exactement ?

Apparemment /etc/init.d/squid est présent dans "Lucid" mais pas dans
"Maverick".
http://packages.ubuntu.com/lucid/amd64/squid/filelist
http://packages.ubuntu.com/maverick/amd64/squid/filelist




Ça ne sera pas le 1er paquet où Ubuntu se gauffre lamentablement dessus?

Sans rire, y'a quelqu'un qui fait de la QA chez Canonical? Oserais-je
que je demanderais si quelqu'un teste les paquets avant de le releaser?



Faut quand même pas exagérer, on peut bien dire ce que l'on veut
(parfois leur choix sont discutables), mais ce ne sont pas des débiles
profonds chez Ubuntu.

Maverick a introduit upstart (que je n'utilise pas) et au vu de la
liste des fichiers dans le paquet upstart
( documentation ne manque pas.

Le script de démarrage est /etc/init/squid.conf.

Il faut vivre avec son temps ou changer de distribution.
--
Benoit Izac
Publicité
Poster une réponse
Anonyme