Largeur de cellules de tableau

Le
Gloops
Bonjour tout le monde,

J'ai un souci pour afficher un tableau de trois colonnes dans Internet
Explorer (8.0.6001.18702).

La première colonne a une largeur fixe. La troisième colonne se charg=
e
avec un texte invitant à autoriser les scripts, puis un script charge
une liste déroulante avec les noms des langues proposées, ce qui dimi=
nue
la largeur utile de la colonne. La colonne du milieu doit prendre toute
la largeur disponible, je l'ai donc réglée avec style="width:100%".=


Dans Firefox tout ceci fonctionne très bien, mais je viens de me rendre=

compte (et personne n'a fait remonter le problème, mais on n'en a pas
peut-être pas pensé moins) que sous Internet Explorer la troisième =

colonne échoue à présent à diminuer sa largeur, ce qui fait qu'il=
ne
reste que la portion congruë au titre, dans la colonne du milieu.

J'ai essayé, pour la troisième colonne, en plus de style="width:75p=
x",
de mettre width="75px", mais ça n'a rien donné de plus. C'est d'aut=
ant
plus moche que je fais mon développement sous Visual Studio, et donc ç=
a
n'aurait pas dû attendre la compilation pour que ce soit évident que =
je
faisais une bêtise (si toutefois je peux m'autoriser une certaine
naïveté). Or là, après la mise en ligne, je ne vois toujours pas.=
La
colonne garde la largeur qu'elle a à son premier affichage, et ne la
rafraîchit pas après modification du contenu.

Une suggestion, peut-être ?

Exemple :
http://www.zailes.org/ClavierNum/Claviernum.aspx

Dans la liste en haut à droite, si les scripts sont autorisés l'intit=
ulé
"With a script you can display in English" est bien remplacé par le nom=

de la langue, "English", mais la colonne garde la même largeur. ça me=
t
donc le titre sur plusieurs lignes, esthétiquement il y a à redire.

Sous Firefox, aucun problème.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Hans Le Roy
Le #20601261
Bonjour,

Je ne comprends strictement rien... je ne vois pas de différence entre IE et
FF3 dans l'affichage du tableau sur
http://www.zailes.org/ClavierNum/Claviernum.aspx.

Amitiés

Hans

"Gloops" news:
Bonjour tout le monde,

J'ai un souci pour afficher un tableau de trois colonnes dans Internet
Explorer (8.0.6001.18702).

La première colonne a une largeur fixe. La troisième colonne se charge
avec un texte invitant à autoriser les scripts, puis un script charge une
liste déroulante avec les noms des langues proposées, ce qui diminue la
largeur utile de la colonne. La colonne du milieu doit prendre toute la
largeur disponible, je l'ai donc réglée avec style="width:100%".

Dans Firefox tout ceci fonctionne très bien, mais je viens de me rendre
compte (et personne n'a fait remonter le problème, mais on n'en a pas
peut-être pas pensé moins) que sous Internet Explorer la troisième colonne
échoue à présent à diminuer sa largeur, ce qui fait qu'il ne reste que la
portion congruë au titre, dans la colonne du milieu.

J'ai essayé, pour la troisième colonne, en plus de style="width:75px", de
mettre width="75px", mais ça n'a rien donné de plus. C'est d'autant plus
moche que je fais mon développement sous Visual Studio, et donc ça
n'aurait pas dû attendre la compilation pour que ce soit évident que je
faisais une bêtise (si toutefois je peux m'autoriser une certaine
naïveté). Or là, après la mise en ligne, je ne vois toujours pas. La
colonne garde la largeur qu'elle a à son premier affichage, et ne la
rafraîchit pas après modification du contenu.

Une suggestion, peut-être ?

Exemple :
http://www.zailes.org/ClavierNum/Claviernum.aspx

Dans la liste en haut à droite, si les scripts sont autorisés l'intitulé
"With a script you can display in English" est bien remplacé par le nom de
la langue, "English", mais la colonne garde la même largeur. ça met donc
le titre sur plusieurs lignes, esthétiquement il y a à redire.

Sous Firefox, aucun problème.


Gloops
Le #20603721
Hans Le Roy a écrit, le 21/11/2009 16:07 :
Bonjour,

Je ne comprends strictement rien... je ne vois pas de différence entr e
IE et FF3 dans l'affichage du tableau sur
http://www.zailes.org/ClavierNum/Claviernum.aspx.




Ah, ça veut dire que c'est ma config de IE qui est en cause, alors.
A la limite j'aime autant, ça prête moins à conséquence.

Pour la forme ça serait bien que je remette ça d'aplomb.

Il y a la réinstallation du produit, carrément.
Si quelqu'un a une solution plus légère, euh ... il l'aurait déjà dit,
peut-être ?
Gloops
Le #20689471
Hans Le Roy a écrit, le 21/11/2009 16:07 :
Bonjour,

Je ne comprends strictement rien... je ne vois pas de différence entr e
IE et FF3 dans l'affichage du tableau sur
http://www.zailes.org/ClavierNum/Claviernum.aspx.



Salut,

Depuis cette discussion, j'ai eu deux fois une erreur 404 sur cette page.
La deuxième fois, je me rends compte qu'en fait le point, à la fin, a
été intégré à l'URL, et qu'effectivement le serveur ne connaî t pas
l'extension "aspx.", alors qu'il reconnaît l'extension "aspx"
(et je mettrais bien un point pour finir la phrase, mais je me demande
si je serais clair pour tout le monde en demandant de distinguer un
point devant le guillemet d'un point après le guillemet).

Ceci dépend vraisemblablement du logiciel de news utilisé, par exempl e
Thunderbird, à la lecture, crée automatiquement un lien en arrêtant
l'URL juste avant le point, ce qui est approprié, et en cliquant dessus
on affiche bien la page et non une erreur 404.

Dans tous les cas le lien que j'ai placé dans le premier message du fil
n'est pas suivi d'un point (j'ai plus ou moins pris l'habitude d'éviter
un point ou une virgule après une URL à cause de ce problème) et
logiquement il ne devrait pas déclencher d'erreur 404.
Publicité
Poster une réponse
Anonyme