Latence autofs+sshfs

Le
Fabien LUCE
--BEGIN PGP SIGNED MESSAGE--
Hash: SHA1

Bonjour à tous,


est ce que quelqu un sait comment diminuer le temps de montage
automatique d'un dossier distant avec autofs?
En fait quand je rentre dans un dossier monté par autofs via sshfs, je n'ai pas tout de suite le
montage de fait, il faut que je resorte et rerentre 1 ou 2 fois.
C'est une sorte de temps de latence qui même si on le sait est un peu
déroutante pour un utilisateur qui ne le saurait pas.

Auriez vous une idée du problème?

Merci


- --
Fabien LUCE
Jabber ID: ftg@lutix.org
Identi.ca: http://identi.ca/ftg
Web: www.lutix.org
--BEGIN PGP SIGNATURE--
Version: GnuPG v1.4.10 (GNU/Linux)

iQEcBAEBAgAGBQJQUtB8AAoJELBIZX4diADYLLoH/RY/Xj//stRlVAvj6aJ0usv4
yOQpxiuCsyhpOfd6LyH4+TEMnQmsA3vcXJLWcqCZlMgRP7Erfcpl+cfqF9vSJTcD
M4S/fM3jXXTyfS5AaNM9CWoGf1r2tu3wCf7Bhbw2ywn1haUDxOsSDLmkVvrWyTNo
iRRgzvGLWKroFaw6RbTY6nS4VtSryXYY3oVt4jxgkMufTfJnhiCdCddYRA5CyvYs
589tjf8gjN1PxTA6KW6mRmxjg1kgCYdgK85nlwQEwi2Jm1LMlIX8WSHjs2WP3tRD
PGYnPjwYhMAX2WsHy4G9Xe2KrCpE3/6xYJyOl/86KFhL+8SxZLnhXijMx7fYj6k=
=L3WA
--END PGP SIGNATURE--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20120914063644.GB3894@serveur.lutix.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fabien LUCE
Le #24782822
Hola,

merci pour ta reponse, je pensais plutot à ca:
http://serverfault.com/questions/198772/unable-to-access-files-through-autofs-on-first-attempt-only-afterwards
exactement le même pronbleme.
Et c'est plutot genant pour par exemple des logiciels de musique qui
comptent sur ces repertoires montés.

Fabien



On Fri, Sep 14, 2012 at 09:30:19AM +0200, Boiteux Frederic wrote:
Bonjour,

La latence vient surtout de sshfs : lors du montage, il y a une connexion SSH qui s'effectue, avec échange de clés/décodage, cela prend du temps, d'où la latence observée...

Fred.


-----Message d'origine-----
De : Fabien LUCE [mailto:]
Envoyé : vendredi 14 septembre 2012 08:37
À : Liste Debian
Objet : Latence autofs+sshfs

Bonjour à tous,


est ce que quelqu un sait comment diminuer le temps de montage automatique d'un dossier distant avec autofs?
En fait quand je rentre dans un dossier monté par autofs via sshfs, je n'ai pas tout de suite le montage de fait, il faut que je resorte et rerentre 1 ou 2 fois.
C'est une sorte de temps de latence qui même si on le sait est un peu déroutante pour un utilisateur qui ne le saurait pas.

Auriez vous une idée du problème?

Merci


--
Fabien LUCE
Jabber ID:
Identi.ca: http://identi.ca/ftg
Web: www.lutix.org

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/




--
Fabien LUCE
Jabber ID:
Identi.ca: http://identi.ca/ftg
Web: www.lutix.org

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bzzz
Le #24783022
On Fri, 14 Sep 2012 18:08:37 +0200
Fabien LUCE
http://serverfault.com/questions/198772/unable-to-access-files-through-au tofs-on-first-attempt-only-afterwards
exactement le même pronbleme.



Aucun PB ici, client=squeeze+bpo & server=sid
Ligne de Cde de test:
sshfs :/VD/vwx/en /home/user1/VD -C -o cache_timeout=2

ls ~/VD répond instantanément.

--
* Le Zoophile est entré sur le chan.
* pti_hamster92 a quitté le chan.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Fabien LUCE
Le #24784392
En fait effectivement si je monte avec sshfs je n'ai pas de soucis.
Le pb vient de la combinaison autofs+sshfs. On a l 'impression que
autofs mets du temps à se rendre compte qu'on est rentré dans le
répertoire...
C'est exactement la situation du lien que j'ai posté: la première fois
rien ne se passe, la seconde autofs s'est enfin rendu compte qu'on
rentrait dans ce répertoire.


On Fri, Sep 14, 2012 at 06:35:29PM +0200, Bzzz wrote:
On Fri, 14 Sep 2012 18:08:37 +0200
Fabien LUCE
> http://serverfault.com/questions/198772/unable-to-access-files-through-autofs-on-first-attempt-only-afterwards
> exactement le même pronbleme.

Aucun PB ici, client=squeeze+bpo & server=sid
Ligne de Cde de test:
sshfs :/VD/vwx/en /home/user1/VD -C -o cache_timeout=2

ls ~/VD répond instantanément.

--
* Le Zoophile est entré sur le chan.
* pti_hamster92 a quitté le chan.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/




--
Fabien LUCE
Jabber ID:
Identi.ca: http://identi.ca/ftg
Web: www.lutix.org

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Boiteux Frederic
Le #24790792
Bonjour,

J'utilise une combinaison autofs+sshfs, et je n'observe pas ce comportement : lors du premier accès, la commande bloque le temps du montage SSH (ce n'est pas immédiat, mais dure environ 2 secondes)

Tu pourrais activer le debug d'autofs pour voir (option --debug dans la troisième colonne de ton /etc/auto.master correspondant à ton montage SSHFS).



Cdlt,
Fred.


-----Message d'origine-----
De : Fabien LUCE [mailto:]
Envoyé : samedi 15 septembre 2012 09:43
À : Bzzz
Cc :
Objet : Re: Latence autofs+sshfs

En fait effectivement si je monte avec sshfs je n'ai pas de soucis.
Le pb vient de la combinaison autofs+sshfs. On a l 'impression que autofs mets du temps à se rendre compte qu'on est rentré dans le répertoire...
C'est exactement la situation du lien que j'ai posté: la première fois rien ne se passe, la seconde autofs s'est enfin rendu compte qu'on rentrait dans ce répertoire.


On Fri, Sep 14, 2012 at 06:35:29PM +0200, Bzzz wrote:
On Fri, 14 Sep 2012 18:08:37 +0200
Fabien LUCE
> http://serverfault.com/questions/198772/unable-to-access-files-throu
> gh-autofs-on-first-attempt-only-afterwards
> exactement le même pronbleme.

Aucun PB ici, client=squeeze+bpo & server=sid Ligne de Cde de test:
sshfs :/VD/vwx/en /home/user1/VD -C -o cache_timeout=2

ls ~/VD répond instantanément.

--
* Le Zoophile est entré sur le chan.
* pti_hamster92 a quitté le chan.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive:
http://lists.debian.org/




--
Fabien LUCE
Jabber ID:
Identi.ca: http://identi.ca/ftg
Web: www.lutix.org

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Fabien LUCE
Le #24791302
Bonjour Fred,

merci pour ta réponse.
Pourrais tu me dire quelles sont tes versions de Debian, autofs et sshfs
stp?

Merci

On Mon, Sep 17, 2012 at 01:03:58PM +0200, Boiteux Frederic wrote:
Bonjour,

J'utilise une combinaison autofs+sshfs, et je n'observe pas ce comportement : lors du premier accès, la commande bloque le temps du montage SSH (ce n'est pas immédiat, mais dure environ 2 secondes)

Tu pourrais activer le debug d'autofs pour voir (option --debug dans la troisième colonne de ton /etc/auto.master correspondant à ton montage SSHFS).



Cdlt,
Fred.


-----Message d'origine-----
De : Fabien LUCE [mailto:]
Envoyé : samedi 15 septembre 2012 09:43
À : Bzzz
Cc :
Objet : Re: Latence autofs+sshfs

En fait effectivement si je monte avec sshfs je n'ai pas de soucis.
Le pb vient de la combinaison autofs+sshfs. On a l 'impression que autofs mets du temps à se rendre compte qu'on est rentré dans le répertoire...
C'est exactement la situation du lien que j'ai posté: la première fois rien ne se passe, la seconde autofs s'est enfin rendu compte qu'on rentrait dans ce répertoire.


On Fri, Sep 14, 2012 at 06:35:29PM +0200, Bzzz wrote:
> On Fri, 14 Sep 2012 18:08:37 +0200
> Fabien LUCE >
> > http://serverfault.com/questions/198772/unable-to-access-files-throu
> > gh-autofs-on-first-attempt-only-afterwards
> > exactement le même pronbleme.
>
> Aucun PB ici, client=squeeze+bpo & server=sid Ligne de Cde de test:
> sshfs :/VD/vwx/en /home/user1/VD -C -o cache_timeout=2
>
> ls ~/VD répond instantanément.
>
> --
> * Le Zoophile est entré sur le chan.
> * pti_hamster92 a quitté le chan.
>
> --
> Lisez la FAQ de la liste avant de poser une question :
> http://wiki.debian.org/fr/FrenchLists
>
> Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
> vers
> En cas de soucis, contactez EN ANGLAIS
> Archive:
> http://lists.debian.org/
>

--
Fabien LUCE
Jabber ID:
Identi.ca: http://identi.ca/ftg
Web: www.lutix.org

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/




--
Fabien LUCE
Jabber ID:
Identi.ca: http://identi.ca/ftg
Web: www.lutix.org

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Boiteux Frederic
Le #24794752
Bonjour Fabien,

J'utilise autofs+sshfs sur une Debian Squeeze.

autofs5: version 5.0.4-3.2
sshfs: version 2.2-1

Cdlt,
Fred.


-----Message d'origine-----
De : Fabien LUCE [mailto:]
Envoyé : lundi 17 septembre 2012 17:01
À : Boiteux Frederic
Cc :
Objet : Re: Re: Latence autofs+sshfs

Bonjour Fred,

merci pour ta réponse.
Pourrais tu me dire quelles sont tes versions de Debian, autofs et sshfs stp?

Merci

On Mon, Sep 17, 2012 at 01:03:58PM +0200, Boiteux Frederic wrote:
Bonjour,

J'utilise une combinaison autofs+sshfs, et je n'observe pas ce
comportement : lors du premier accès, la commande bloque le temps du
montage SSH (ce n'est pas immédiat, mais dure environ 2 secondes)

Tu pourrais activer le debug d'autofs pour voir (option --debug dans la troisième colonne de ton /etc/auto.master correspondant à ton montage SSHFS).



Cdlt,
Fred.


-----Message d'origine-----
De : Fabien LUCE [mailto:] Envoyé : samedi 15 septembre
2012 09:43 À : Bzzz Cc :
Objet : Re: Latence autofs+sshfs

En fait effectivement si je monte avec sshfs je n'ai pas de soucis.
Le pb vient de la combinaison autofs+sshfs. On a l 'impression que autofs mets du temps à se rendre compte qu'on est rentré dans le répertoire...
C'est exactement la situation du lien que j'ai posté: la première fois rien ne se passe, la seconde autofs s'est enfin rendu compte qu'on rentrait dans ce répertoire.


On Fri, Sep 14, 2012 at 06:35:29PM +0200, Bzzz wrote:
> On Fri, 14 Sep 2012 18:08:37 +0200
> Fabien LUCE >
> > http://serverfault.com/questions/198772/unable-to-access-files-thr
> > ou gh-autofs-on-first-attempt-only-afterwards
> > exactement le même pronbleme.
>
> Aucun PB ici, client=squeeze+bpo & server=sid Ligne de Cde de test:
> sshfs :/VD/vwx/en /home/user1/VD -C -o
> cache_timeout=2
>
> ls ~/VD répond instantanément.
>
> --
> * Le Zoophile est entré sur le chan.
> * pti_hamster92 a quitté le chan.
>
> --
> Lisez la FAQ de la liste avant de poser une question :
> http://wiki.debian.org/fr/FrenchLists
>
> Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
> vers
> En cas de soucis, contactez EN ANGLAIS
> Archive:
> http://lists.debian.org/
>

--
Fabien LUCE
Jabber ID:
Identi.ca: http://identi.ca/ftg
Web: www.lutix.org

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive:
http://lists.debian.org/

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive:
http://lists.debian.org/
e.france.prosodie.local




--
Fabien LUCE
Jabber ID:
Identi.ca: http://identi.ca/ftg
Web: www.lutix.org

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme