LDAP - pas de fichier slapd.conf crée

Le
Amandine VITAL
Coucou,

voilà, j'essaie d'installer ldap et samba.
je suis la doc suivante :
http://damstux.free.fr/wiki/index.php?title=PDC_Samba_et_LDAP

Je tourne sur la version ubuntu-server 9.04. et dans une autre doc,
j'ai lu que slapd.conf n'est pas crée et remplacé par slapd.d
Mais, si je suis la doc, je dois éditer slapd.conf qui n'est pas crÃ=
©e.

Comment faire ? dois-je créer ce fichier ? ou comment puis-je intÃ=
©grer SSHA ?

Merci
Amandine

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Amandine VITAL
Le #19422701
> voilà, j'essaie d'installer ldap et samba.
je suis la doc suivante :
http://damstux.free.fr/wiki/index.php?title=PDC_Samba_et_LDAP

Je tourne sur la version ubuntu-server 9.04. et dans une autre doc,
j'ai lu que slapd.conf n'est pas crée et remplacé par slapd.d
Mais, si je suis la doc, je dois éditer slapd.conf qui n'est pas cr ée.

Comment faire ? dois-je créer ce fichier ? ou comment puis-je intà ©grer SSHA ?



En recherchant sur le net, je comprends que le slapd.conf est remplacé
par slapd.d

Est-il mieux de créer le fichier slapd.conf ou de rester sur slapd.d ?

Amandine

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Amandine VITAL
Le #19423411
>> voilà, j'essaie d'installer ldap et samba.
je suis la doc suivante :
http://damstux.free.fr/wiki/index.php?title=PDC_Samba_et_LDAP

Je tourne sur la version ubuntu-server 9.04. et dans une autre doc,
j'ai lu que slapd.conf n'est pas crée et remplacé par slapd.d
Mais, si je suis la doc, je dois éditer slapd.conf qui n'est pas cr ée.

Comment faire ? dois-je créer ce fichier ? ou comment puis-je int égrer SSHA ?



En recherchant sur le net, je comprends que le slapd.conf est remplacà ©
par slapd.d

Est-il mieux de créer le fichier slapd.conf ou de rester sur slapd.d ?



J'ai copier un fichier slapd.conf et configuré SSHA comme dans la doc.
# /etc/init.d/slapd restart
Stopping OpenLDAP: slapd.
Starting OpenLDAP: slapd.

Comment puis-je savoir si tout est bien configuré ?

Amandine

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Amandine VITAL
Le #19424421
> J'ai copier un fichier slapd.conf et configuré SSHA comme dans la do c.
# /etc/init.d/slapd restart
Stopping OpenLDAP: slapd.
Starting OpenLDAP: slapd.

Comment puis-je savoir si tout est bien configuré ?



verifie que tu as slapd qui tourne vi ps -edf |grep slapd ou via le port :
netstat -latupen |grep slap



$ ps -edf |grep slapd
openldap 3160 1 0 11:11 ? 00:00:00 /usr/sbin/slapd -h
ldap://127.0.0.1:389/ ldapi:/// -g openldap -u openldap -F
/etc/ldap/slapd.d/
amandine 8129 2738 0 13:05 pts/0 00:00:00 grep slapd

# netstat -latupen |grep slap
tcp 0 0 127.0.0.1:389 0.0.0.0:*
LISTEN 0 10119 3160/slapd
tcp 0 0 127.0.0.1:389 127.0.0.1:48613
ESTABLISHED 111 18969 3160/slapd

Amandine

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Amandine VITAL
Le #19432551
> J'ai copier un fichier slapd.conf et configuré SSHA comme dans la do c.
# /etc/init.d/slapd restart
Stopping OpenLDAP: slapd.
Starting OpenLDAP: slapd.


BDB ne tourne pas, c'est normal ?


Comment puis-je savoir si tout est bien configuré ?




verifie que tu as slapd qui tourne vi ps -edf |grep slapd ou via le port :
netstat -latupen |grep slap


$ ps -edf |grep slapd
openldap 3160 1 0 11:11 ? 00:00:00 /usr/sbin/slapd -h
ldap://127.0.0.1:389/ ldapi:/// -g openldap -u openldap -F
/etc/ldap/slapd.d/
amandine 8129 2738 0 13:05 pts/0 00:00:00 grep slapd

# netstat -latupen |grep slap
tcp 0 0 127.0.0.1:389 0.0.0.0:*
LISTEN 0 10119 3160/slapd
tcp 0 0 127.0.0.1:389 127.0.0.1:48613
ESTABLISHED 111 18969 3160/slapd

Amandine



cela signifie que ton slapd tourne bien ce qui m'etonne c est que ce ne s oit
pas accessible de ton réseau
je pense que tu devrais avoir
0.0.0.0:389 au lieu de 127.0.0.1:389


C'est où que je dois régler ça ?

je n'ai plus l'erreur que je fais

# smbldap-populate

Populating LDAP directory for domain servervital
(S-1-5-21-4066323071-2866129122-3196301921)
(using builtin directory structure)

entry dc=servervital,dc=fr already exist.
entry ou=Users,dc=servervital,dc=fr already exist.
entry ou=Groups,dc=servervital,dc=fr already exist.
entry ou=Machines,dc=servervital,dc=fr already exist.
entry ou=Idmap,dc=servervital,dc=fr already exist.
entry uid=root,ou=Users,dc=servervital,dc=fr already exist.
entry uid=nobody,ou=Users,dc=servervital,dc=fr already exist.
entry cn=Domain Admins,ou=Groups,dc=servervital,dc=fr already exist .
entry cn=Domain Users,ou=Groups,dc=servervital,dc=fr already exist.
entry cn=Domain Guests,ou=Groups,dc=servervital,dc=fr already exist .
entry cn=Domain Computers,ou=Groups,dc=servervital,dc=fr already ex ist.
entry cn­ministrators,ou=Groups,dc=servervital,dc=fr already exis t.
entry cn¬count Operators,ou=Groups,dc=servervital,dc=fr already e xist.
entry cn=Print Operators,ou=Groups,dc=servervital,dc=fr already exi st.
entry cnºckup Operators,ou=Groups,dc=servervital,dc=fr already ex ist.
entry cn=Replicators,ou=Groups,dc=servervital,dc=fr already exist.
entry sambaDomainName=servervital,dc=servervital,dc=fr already exist.
Updating it...

Please provide a password for the domain root:

regarde dans ton / tes fichiers de conf si tu peux pas changer localhost ou
127.0.0.1 par ton adresse ip


j'ai remplacé dans :
sed -i 's/127.0.0.1/192.168.10.1/g' /etc/samba/smb.conf
sed -i 's/127.0.0.1/192.168.10.1/g' /etc/smbldap-tools/smbldap.conf
sed -i 's/127.0.0.1/192.168.10.1/g' /etc/libnss-ldap.conf
sed -i 's/127.0.0.1/192.168.10.1/g' /etc/pam_ldap.conf

Quand je me connecte que le poste windows
Je rentre dans domaine :
servervital.fr
j'ai un message d'erreur comme quoi il n'a pas pu contacter servervital.fr
L'erreur était : "Le nom DNS n'existe pas."
(code d'erreur 0x0000232B RCODE_NAME_ERROR)
L'interrogation portait sur l'enregistrement SRV pour
_ldap._tcp.dc._msdcs.servervital.fr
Les causes de cette erreur peuvent être :
- L'enregistrement SRV de DNS n'est pas inscrit dans le DNS.
- Une ou plusieurs des zones suivantes n'incluent pas la délégati on à
leur zone fille :
servervital.fr
fr
. (zone racine)



philippe




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Amandine VITAL
Le #19435761
Le 28 mai 2009 10:43, Amandine VITAL
J'ai copier un fichier slapd.conf et configuré SSHA comme dans la d oc.
# /etc/init.d/slapd restart
Stopping OpenLDAP: slapd.
Starting OpenLDAP: slapd.


BDB ne tourne pas, c'est normal ?


Comment puis-je savoir si tout est bien configuré ?




verifie que tu as slapd qui tourne vi ps -edf |grep slapd ou via le port :
netstat -latupen |grep slap


$ ps -edf |grep slapd
openldap  3160     1  0 11:11 ?        00:00:00 /usr/sbin/slapd -h
ldap://127.0.0.1:389/ ldapi:/// -g openldap -u openldap -F
/etc/ldap/slapd.d/
amandine   8129  2738  0 13:05 pts/0    00:00:0 0 grep slapd

# netstat -latupen |grep slap
tcp        0      0 127.0.0.1:389            0.0.0.0:*
LISTEN      0          10119        3160/slapd
tcp        0      0 127.0.0.1:389            127.0.0.1:48613
ESTABLISHED 111        18969       31 60/slapd

Amandine



cela signifie que ton slapd tourne bien ce qui m'etonne c est que ce ne soit
pas accessible de ton réseau
je pense que tu devrais avoir
0.0.0.0:389 au lieu de 127.0.0.1:389


C'est où que je dois régler ça ?

je n'ai plus l'erreur que je fais

# smbldap-populate

Populating LDAP directory for domain servervital
(S-1-5-21-4066323071-2866129122-3196301921)
(using builtin directory structure)

entry dc=servervital,dc=fr already exist.
entry ou=Users,dc=servervital,dc=fr already exist.
entry ou=Groups,dc=servervital,dc=fr already exist.
entry ou=Machines,dc=servervital,dc=fr already exist.
entry ou=Idmap,dc=servervital,dc=fr already exist.
entry uid=root,ou=Users,dc=servervital,dc=fr already exist.
entry uid=nobody,ou=Users,dc=servervital,dc=fr already exist.
entry cn=Domain Admins,ou=Groups,dc=servervital,dc=fr already exi st.
entry cn=Domain Users,ou=Groups,dc=servervital,dc=fr already exis t.
entry cn=Domain Guests,ou=Groups,dc=servervital,dc=fr already exi st.
entry cn=Domain Computers,ou=Groups,dc=servervital,dc=fr already exist.
entry cn­ministrators,ou=Groups,dc=servervital,dc=fr already ex ist.
entry cn¬count Operators,ou=Groups,dc=servervital,dc=fr already exist.
entry cn=Print Operators,ou=Groups,dc=servervital,dc=fr already e xist.
entry cnºckup Operators,ou=Groups,dc=servervital,dc=fr already exist.
entry cn=Replicators,ou=Groups,dc=servervital,dc=fr already exist .
entry sambaDomainName=servervital,dc=servervital,dc=fr already exis t.
Updating it...

Please provide a password for the domain root:

regarde dans ton / tes fichiers de conf si tu peux pas changer localhost ou
127.0.0.1 par ton adresse ip


j'ai remplacé dans :
sed -i 's/127.0.0.1/192.168.10.1/g' /etc/samba/smb.conf
sed -i 's/127.0.0.1/192.168.10.1/g' /etc/smbldap-tools/smbldap.conf
sed -i 's/127.0.0.1/192.168.10.1/g' /etc/libnss-ldap.conf
sed -i 's/127.0.0.1/192.168.10.1/g' /etc/pam_ldap.conf

Quand je me connecte que le poste windows
Je rentre dans domaine :
servervital.fr
j'ai un message d'erreur comme quoi il n'a pas pu contacter servervital.f r
L'erreur était : "Le nom DNS n'existe pas."
(code d'erreur 0x0000232B RCODE_NAME_ERROR)
L'interrogation portait sur l'enregistrement SRV pour
_ldap._tcp.dc._msdcs.servervital.fr
Les causes de cette erreur peuvent être :
- L'enregistrement SRV de DNS n'est pas inscrit dans le DNS.
- Une ou plusieurs des zones suivantes n'incluent pas la déléga tion à
leur zone fille :
servervital.fr
fr
. (zone racine)




Je ne parviens pas à pinguer sur ma machine windows.
alors que je vois bien cette machine dans arp -a.
ça peut venir de quoi ?

Amandine

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Philippe Laquet
Le #19438621
> Je ne parviens pas à pinguer sur ma machine windows.
alors que je vois bien cette machine dans arp -a.
ça peut venir de quoi ?

Amandine





(entre deux mails de "geek attitude")

Ton slapd tourne bien, par contre il n'écoute que sur la loopback :
* après tes modifications pour que le démon écoute sur la 192.168.10.1
tu as reloadé le démon? (et vérifié via netstat -nltp ?)
* si tu vois une adresse MAC résolue attention, c'est peut-être celle du
pont... (cf. "passerelles internet")

Enfin, si ton PING depuis la machine windows ne donne rien essaies :
* "tcpdump -ni any proto icmp" sur ta machine linux pour voir si tu vois
les echo-request arriver :
1) si tu les vois Win -> Linux = OK (route de retour pas bonne ? les
echo-reply partent bien ?)
2) si ils n'arrivent pas Win -> Linux = NOK (problème de routage aussi ?)

Tu n'as pas d'IPtables au milieu de tout ça? ;)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Etienne Bagnoud
Le #19467821
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Amandine VITAL wrote:
J'ai copier un fichier slapd.conf et configuré SSHA comme dans la doc.
# /etc/init.d/slapd restart
Stopping OpenLDAP: slapd.
Starting OpenLDAP: slapd.


BDB ne tourne pas, c'est normal ?




Pour voir si il y'a un problème avec slapd, tu peux lancer slapd comme
suit :

$sudo slapd -u openldap -g openldap -d 16383

Pour l'utilisation de slapd.d, tu accèdes à la configuration directement
par le protocole LDAP, ce n'est plus des fichiers de configurations en
texte à modifier (même si dans slapd.d tu vas trouver des fichiers texte
modifiable facilement, c'est déconseillé de le faire car cela peut
provoquer une corruption).
La configuration ce fait sur le dn: cn=config.

La configuration par sladp.d est prises par défaut si une configuration
est trouvée. Si tu as justes créer un "slapd.conf" et tu as laissé
"slapd.d", le serveur va automatiquement utiliser "slapd.d" car c'est la
méthode recommandée pour entretenir la configuration de ton serveur.

Je te conseille d'installer "phpldapadmin" pour entretenir la
configuration de ton slapd c'est beaucoup plus simple. L'avantage de
cette configuration est notamment que tu n'as pas besoin de rechargé le
serveur, c'est à chaud.


cela signifie que ton slapd tourne bien ce qui m'etonne c est que ce ne soit
pas accessible de ton réseau
je pense que tu devrais avoir
0.0.0.0:389 au lieu de 127.0.0.1:389


C'est où que je dois régler ça ?




Dans /etc/default/slapd, la ligne suivante :
# SLAPD_SERVICES="ldap://127.0.0.1:389/ ldaps:/// ldapi:///"

Remarque il est mieux de laisser ldap sur 127.0.0.1 et ldaps sur le
reste. Le protocole ldap passe tout en clair sur le réseau et si tu
n'utilises pas SASL pour l'authentification, le mot de passe est envoyé
en clair. Donc crypter tout ça en ldaps est un plus.

Quand je me connecte que le poste windows
Je rentre dans domaine :
servervital.fr
j'ai un message d'erreur comme quoi il n'a pas pu contacter servervital.fr
L'erreur était : "Le nom DNS n'existe pas."
(code d'erreur 0x0000232B RCODE_NAME_ERROR)
L'interrogation portait sur l'enregistrement SRV pour
_ldap._tcp.dc._msdcs.servervital.fr
Les causes de cette erreur peuvent être :
- L'enregistrement SRV de DNS n'est pas inscrit dans le DNS.
- Une ou plusieurs des zones suivantes n'incluent pas la délégation à
leur zone fille :
servervital.fr
fr
. (zone racine)




Il faut activer le serveur Wins sur samba et ajouter ce serveur dans la
liste des serveurs Wins de Windows ou alors créer l'enregistrement DNS
"_ldap._tcp.dc.msdcs.servervital.fr".
Il en parle dans la documentation de samba, il faut regarder là pour
plus de détails.

Etienne.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQIcBAEBCAAGBQJKJNryAAoJEMFfL/bTFBa4ahAQALJBvS+aXf2znF1xA3qRmghD
6LBGwWBrqErG9ov5NgHcc/mXU9BdaVAbDb2yOHvMeAC2HTflCPIYq9tweFPkkdJ5
+202P48L34y9seP9tG19NSDhIigsCDbTZmqqW7VXTW4JVyMK6jYa3dZcAHXrsWQC
3NQ7Nsd5fChC6bSTfvhpN/honFMEnhk/kD7GTb6ykLHSRpSxkeoAQZva24u+x4SO
3MZtpk9TpXCSWAFGEdwiTy2PG4bAXuCeodm7+RFMJO28bGttRWV8DYO4Chi0GkT8
l+aOfLmDNBOhr+AY88X4e6SMsGmQr9/m/cPSypT5FDtEcESyWYdjMg+9OYetcvnu
LM4aFKHCa0f+/Jv+KZ1dTIWKNezCSVD1Z8qOexxZpPv+DOtBRJr7N1Uxe3gfsCBp
J9YOBL7LTUuImCr494NjrqAYMcJmN/FD6DFbbnGQXehXt7xmss2H6Cm4GCzP3uYs
Ss0M9BcG7nnowN9Rsu+j75p6835L7LA0x20qrRzFf+JmcGIa4HML79ZlJDGVl9NU
F2uJ4sgVjPJ99p4Dgd1A6cQh6kNy97aXQIuLHGcXbytUZMcthA1ar8MRct66STCU
TpjBCmdcmKDTBGki//HlNWHRGXRF3K+iVzSQx/qedFSS9rPYUdYR8k3TUZTcBJYJ
QCLcIrIprZbY39tyiqgZ
=aINe
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme