Lenny KEYEXPIRED 1356982504

Le
Olivier
--20cf303b41833a7fdb04d2f1537e
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Bonjour,

Depuis peu, sur des machines, j'ai remarqué la ligne ci-après à la fi=
n de
chaque apt-get update.
W: GPG error: http://archive.debian.org lenny/updates Release: Les
signatures suivantes ne sont pas valables : KEYEXPIRED 1356982504

Mon fichier /etc/apt/sources.list contient :

deb http://archive.debian.org/debian/ lenny main non-free
deb-src http://archive.debian.org/debian/ lenny main non-free

deb http://archive.debian.org/debian-security lenny/updates main
deb-src http://archive.debian.org/debian-security lenny/updates main

deb http://archive.debian.org/debian-volatile lenny/volatile main
deb-src http://archive.debian.org/debian-volatile lenny/volatile main


En supprimant les lignes ci-après, le pb disparaît.
###deb http://archive.debian.org/debian-security lenny/updates main
###deb-src http://archive.debian.org/debian-security lenny/updates main


Mes questions sont :
1. Pendant combien de temps, un serveur sous Lenny est-il encore
susceptible de recevoir des mises à jour de sécurité ? Si cette pér=
iode
n'est pas révolue, quelles URL ou clés GPG utiliser pour bénéficier=
de ces
mises à jour ?

2. Pendant combien de temps, un serveur sous Lenny est-il capable de migrer
par dist-upgrade ? Quelles versions stables de debian peut-il alors
atteindre ?

3. Est-il possible ou recommandé de "sauter" une version de debian lors
d'une mise à jour ?

Slts

--20cf303b41833a7fdb04d2f1537e
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Bonjour,<br><br>Depuis peu, sur des machines, j&#39;ai remarqué la ligne =
ci-après à la fin de chaque apt-get update.<br>W: GPG error: <a href==
"http://archive.debian.org">http://archive.debian.org</a> lenny/updates Rel=
ease: Les signatures suivantes ne sont pas valables : KEYEXPIRED 13569825=
04<br>
<br>Mon fichier /etc/apt/sources.list contient :<br><br>deb <a href="http=
://archive.debian.org/debian/">http://archive.debian.org/debian/</a> lenny =
main non-free<br>deb-src <a href="http://archive.debian.org/debian/">http=
://archive.debian.org/debian/</a> lenny main non-free<br>
<br>deb <a href="http://archive.debian.org/debian-security">http://archiv=
e.debian.org/debian-security</a> lenny/updates main<br>deb-src <a href="h=
ttp://archive.debian.org/debian-security">http://archive.debian.org/debian-=
security</a> lenny/updates main<br>
<br>deb <a href="http://archive.debian.org/debian-volatile">http://archiv=
e.debian.org/debian-volatile</a> lenny/volatile main<br>deb-src <a href="=
http://archive.debian.org/debian-volatile">http://archive.debian.org/debian=
-volatile</a> lenny/volatile main<br>
<br><br>En supprimant les lignes ci-après, le pb disparaît.<br>###deb <=
a href="http://archive.debian.org/debian-security">http://archive.debian.=
org/debian-security</a> lenny/updates main<br>###deb-src <a href="http://=
archive.debian.org/debian-security">http://archive.debian.org/debian-securi=
ty</a> lenny/updates main<br>
<br><br>Mes questions sont :<br>1. Pendant combien de temps, un serveur sou=
s Lenny est-il encore susceptible de recevoir des mises à jour de sécur=
ité ? Si cette période n&#39;est pas révolue, quelles URL ou clés G=
PG utiliser pour bénéficier de ces mises à jour ?<br>
<br>2. Pendant combien de temps, un serveur sous Lenny est-il capable de mi=
grer par dist-upgrade ? Quelles versions stables de debian peut-il alors at=
teindre ?<br><br>3. Est-il possible ou recommandé de &quot;sauter&quot; u=
ne version de debian lors d&#39;une mise à jour ?<br>
<br>Slts<br><br>

--20cf303b41833a7fdb04d2f1537e--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/CAPeT9ji-1o75QgZyy64LvjF1ewDRpCtXNxRSFQcp_RzX6afC8Q@mail.gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sébastien NOBILI
Le #25129152
Le jeudi 10 janvier 2013 à 17:03, Olivier a écrit :
Bonjour,



Bonjour,

[...]

1. Pendant combien de temps, un serveur sous Lenny est-il encore
susceptible de recevoir des mises à jour de sécurité ? Si cette période
n'est pas révolue, quelles URL ou clés GPG utiliser pour bénéficier de ces
mises à jour ?



Lenny n'est plus supportée (sécurité) depuis quelques mois maintenant. Il est
plus que recommandé de migrer vers Squeeze.

Si tu veux absolument rester sous Lenny (ou autre version ancienne), il faudra
reconfigurer ton sources.list pour aller chercher dans
http://archive.debian.org.

2. Pendant combien de temps, un serveur sous Lenny est-il capable de migrer
par dist-upgrade ? Quelles versions stables de debian peut-il alors
atteindre ?



Tout dépend de l'utilisation qui est faite de la machine, mais dans le cas d'un
serveur, il ne devrait pas y avoir de contre-indication à suivre les versions
stables de Debian au fur et à mesure qu'elles sont publiées.

Mon serveur maison (pas énormément de charge dessus) suit la stable depuis
quelques versions maintenant et s'en porte très bien.

3. Est-il possible ou recommandé de "sauter" une version de debian lors
d'une mise à jour ?



Non. Il vaut mieux passer par chaque étape intermédiaire, ou bien prévoir
quelques jours de bataille avec ton système.

Seb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme