[lenny]Redmine c'est possible ?

Le
Grégory Bulot
Bonjour,

ça fait plusieurs tutos que j'essais pour installer redmine, mais c'est
toujours un échec pour les pré-requis.

je bloque toujours au même endroit :

rake db:migrate RAILS_ENV="production"
(in /home/redmine/redmine-1.0.0)
rake aborted!
Could not find RubyGem rack (~> 1.0.1)


# gem install -v=1.0.1 rails
ERROR: could not find gem rails locally or in a repository

# gem environment
RubyGems Environment:
- RUBYGEMS VERSION: 1.2.0
- RUBY VERSION: 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]
- INSTALLATION DIRECTORY: /var/lib/gems/1.8
- RUBY EXECUTABLE: /usr/bin/ruby1.8
- EXECUTABLE DIRECTORY: /var/lib/gems/1.8/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86-linux
- GEM PATHS:
- /var/lib/gems/1.8
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- REMOTE SOURCES:
- http://gems.rubyforge.org/

# gem install rails
ERROR: could not find gem rails locally or in a repository


$ dpkg -l rubygems rails rack
ii rails 2.1.0-7
ii rubygems 1.2.0-3
Aucun paquet ne correspond à rack.

# gem list

*** LOCAL GEMS ***

# gem update --system
ERROR: While executing gem (RuntimeError)
gem update --system is disabled on Debian. RubyGems can be updated
using the official Debian repositories by aptitude or apt-get.


j'ai fais du :
aptitude install install ruby rake librmagick-ruby subversion
aptitude libmysql-ruby mysql-client rubygems
aptitude install libfcgi-ruby1.8 97 aptitude install ruby rake
rubygems
aptitude aptitude install libmysql-ruby libopenssl-ruby
aptitude install rails




note :
un tuto type essayé (celui est pour etch, mais ceux pour lenny sont
équivalent pour le résultat) :
http://howto.landure.fr/gnu-linux/debian-4-0-etch/installer-le-gestionnaire=
-de-projet-redmine-sur-debian-4-0-etch

il y a eu un test ou je suis allé plus loin mais c'est activesupport q=
ui
foirait (sur incompatibilité de version entre rails et activesupport )



--
Cordialement
Grégory BULOT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20100815170913.1a4d7ada@morpheus.bulot-fr.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Grégory Bulot
Le #22491811
Bonjour,

Je me permet ce 'up', au cas ou ma question serait passé au travers des
mailles du filet.

Je remet en copie mon mail initial ci-dessous

Si effectivement si personne ne peux/souhaite répondre, désolà © pour le
bruit ...


Bonjour,

ça fait plusieurs tutos que j'essais pour installer redmine, mais
c'est toujours un échec pour les pré-requis.

je bloque toujours au même endroit :

rake db:migrate RAILS_ENV="production"
(in /home/redmine/redmine-1.0.0)
rake aborted!
Could not find RubyGem rack (~> 1.0.1)


# gem install -v=1.0.1 rails
ERROR: could not find gem rails locally or in a repository

# gem environment
RubyGems Environment:
- RUBYGEMS VERSION: 1.2.0
- RUBY VERSION: 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]
- INSTALLATION DIRECTORY: /var/lib/gems/1.8
- RUBY EXECUTABLE: /usr/bin/ruby1.8
- EXECUTABLE DIRECTORY: /var/lib/gems/1.8/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86-linux
- GEM PATHS:
- /var/lib/gems/1.8
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- REMOTE SOURCES:
- http://gems.rubyforge.org/

# gem install rails
ERROR: could not find gem rails locally or in a repository


$ dpkg -l rubygems rails rack
ii rails 2.1.0-7
ii rubygems 1.2.0-3
Aucun paquet ne correspond à rack.

# gem list

*** LOCAL GEMS ***

# gem update --system
ERROR: While executing gem ... (RuntimeError)
gem update --system is disabled on Debian. RubyGems can be updated
using the official Debian repositories by aptitude or apt-get.


j'ai fais du :
aptitude install install ruby rake librmagick-ruby subversion
aptitude libmysql-ruby mysql-client rubygems
aptitude install libfcgi-ruby1.8 97 aptitude install ruby rake
rubygems
aptitude aptitude install libmysql-ruby libopenssl-ruby
aptitude install rails




note :
un tuto type essayé (celui est pour etch, mais ceux pour lenny sont
équivalent pour le résultat) :
http://howto.landure.fr/gnu-linux/debian-4-0-etch/installer-le-gestionnai re-de-projet-redmine-sur-debian-4-0-etch

il y a eu un test ou je suis allé plus loin mais c'est activesupport
qui foirait (sur incompatibilité de version entre rails et
activesupport )






--
Cordialement
Grégory BULOT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain Sauvage
Le #22491871
Grégory Bulot, samedi 21 août 2010, 12:04:41 CEST

Bonjour,



’jour,

Je me permet ce 'up', au cas ou ma question serait passé au travers des
mailles du filet.

Je remet en copie mon mail initial ci-dessous

Si effectivement si personne ne peux/souhaite répondre, désol é pour le
bruit ...



Sans doute parce ceux qui utilisent Redmine utilisent Testing
ou Sid qui ont des paquets redmine et rails à jour.
Ou bien utilisent-ils directement le tarball complet de
redmine (donc rails inclus).

Sinon, Redmine 0.9 est sur backports…

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Grégory Bulot
Le #22492371
Grégory Bulot, samedi 21 août 2010, 12:04:41 CEST
>
> Bonjour,

’jour,

> Je me permet ce 'up', au cas ou ma question serait passé au travers
> des mailles du filet.
>
> Je remet en copie mon mail initial ci-dessous
>
> Si effectivement si personne ne peux/souhaite répondre, désol é pour
> le bruit ...

Sans doute parce ceux qui utilisent Redmine utilisent Testing
ou Sid qui ont des paquets redmine et rails à jour.



en fait je n'utilise pas les paquets debian, car j'ai l'erreur suivante
après avoir choisi le type de base de donnée (dbconfig-common)

# aptitude install -t lenny-backports redmine
[...]
rake aborted!
undefined method `new' for "Rack::Head":String

== trace ==
ruby /usr/bin/rake -s redmine:load_default_data RAILS_ENV=production
X_DEBIAN_SITEIDÞfault REDMINE_LANG=fr --trace

rake aborted!
No Rakefile found (looking for: rakefile, Rakefile, rakefile.rb,
Rakefile.rb) /usr/lib/ruby/1.8/rake.rb:2377:in `raw_load_rakefile'
/usr/lib/ruby/1.8/rake.rb:2017:in `load_rakefile'
/usr/lib/ruby/1.8/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/1.8/rake.rb:2016:in `load_rakefile'
/usr/lib/ruby/1.8/rake.rb:2000:in `run'
/usr/lib/ruby/1.8/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/1.8/rake.rb:1998:in `run'
/usr/bin/rake:28
============


Ou bien utilisent-ils directement le tarball complet de
redmine (donc rails inclus).



toujours eu des problèmes avec rake (de mémoire, j'ai pas notà ©
malheureusement


Sinon, Redmine 0.9 est sur backports…




Idem version squeeze, rake aborted (mode sqlite)


--
Cordialement
Grégory BULOT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Grégory Bulot
Le #22492441
> Grégory Bulot, samedi 21 août 2010, 12:04:41 CEST
> >
> > Bonjour,
>
> ’jour,
>
> > Je me permet ce 'up', au cas ou ma question serait passé au
> > travers des mailles du filet.
> >
> > Je remet en copie mon mail initial ci-dessous
> >
> > Si effectivement si personne ne peux/souhaite répondre, dés olé
> > pour le bruit ...
>
> Sans doute parce ceux qui utilisent Redmine utilisent Testing
> ou Sid qui ont des paquets redmine et rails à jour.

en fait je n'utilise pas les paquets debian, car j'ai l'erreur
suivante après avoir choisi le type de base de donnée
(dbconfig-common)

# aptitude install -t lenny-backports redmine
[...]
rake aborted!
undefined method `new' for "Rack::Head":String

== trace ==
ruby /usr/bin/rake -s redmine:load_default_data RAILS_ENV=production
X_DEBIAN_SITEIDÞfault REDMINE_LANG=fr --trace




rhhaaa, j'étais pas dans le bon répertoire

/usr/share/redmine # ruby /usr/bin/rake -s redmine:load_default_data
RAILS_ENV=production X_DEBIAN_SITEIDÞfault REDMINE_LANG=fr --trace
/root/redmine.txt 2>&1



rien dans /root/redmine.txt ! tout sur la console ...
rake aborted!
undefined method `new' for "Rack::Head":String
/usr/lib/ruby/1.8/action_controller/middleware_stack.rb:116:in `inject'
/usr/lib/ruby/1.8/action_controller/middleware_stack.rb:116:in `build'
/usr/lib/ruby/1.8/action_controller/dispatcher.rb:130:in
`build_middleware_stack'
/usr/lib/ruby/1.8/action_controller/dispatcher.rb:81:in `initialize'
/usr/lib/ruby/1.8/action_controller/dispatcher.rb:51:in `new'
/usr/lib/ruby/1.8/action_controller/dispatcher.rb:51:in
`run_prepare_callbacks'
/usr/share/redmine/config/../vendor/rails/railties/lib/initializer.rb:631:in
`prepare_dispatcher'
/usr/share/redmine/config/../vendor/rails/railties/lib/initializer.rb:185:in
`process'
/usr/share/redmine/config/../vendor/rails/railties/lib/initializer.rb:113:in
`send'
/usr/share/redmine/config/../vendor/rails/railties/lib/initializer.rb:113:in
`run'
/usr/share/redmine/config/environment.rb:44
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
/usr/lib/ruby/1.8/active_support/dependencies.rb:156:in `require'
/usr/lib/ruby/1.8/active_support/dependencies.rb:521:in
`new_constants_in'
/usr/lib/ruby/1.8/active_support/dependencies.rb:156:in `require'
/usr/share/redmine/vendor/rails/railties/lib/tasks/misc.rake:4
/usr/lib/ruby/1.8/rake.rb:636:in `call'
/usr/lib/ruby/1.8/rake.rb:636:in `execute'
/usr/lib/ruby/1.8/rake.rb:631:in `each'
/usr/lib/ruby/1.8/rake.rb:631:in `execute'
/usr/lib/ruby/1.8/rake.rb:597:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/usr/lib/ruby/1.8/rake.rb:590:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/rake.rb:607:in `invoke_prerequisites'
/usr/lib/ruby/1.8/rake.rb:604:in `each'
/usr/lib/ruby/1.8/rake.rb:604:in `invoke_prerequisites'
/usr/lib/ruby/1.8/rake.rb:596:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/usr/lib/ruby/1.8/rake.rb:590:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/rake.rb:583:in `invoke'
/usr/lib/ruby/1.8/rake.rb:2051:in `invoke_task'
/usr/lib/ruby/1.8/rake.rb:2029:in `top_level'
/usr/lib/ruby/1.8/rake.rb:2029:in `each'
/usr/lib/ruby/1.8/rake.rb:2029:in `top_level'
/usr/lib/ruby/1.8/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/1.8/rake.rb:2023:in `top_level'
/usr/lib/ruby/1.8/rake.rb:2001:in `run'
/usr/lib/ruby/1.8/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/1.8/rake.rb:1998:in `run'
/usr/bin/rake:28








--
Cordialement
Grégory BULOT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
pmenier
Le #22510461
Grégory Bulot a écrit :
Bonjour,

Je me permet ce 'up', au cas ou ma question serait passé au travers des
mailles du filet.

Je remet en copie mon mail initial ci-dessous

Si effectivement si personne ne peux/souhaite répondre, désolé pour le
bruit ...


Bonjour,

ça fait plusieurs tutos que j'essais pour installer redmine, mais
c'est toujours un échec pour les pré-requis.

je bloque toujours au même endroit :

rake db:migrate RAILS_ENV="production"
(in /home/redmine/redmine-1.0.0)
rake aborted!
Could not find RubyGem rack (~> 1.0.1)


# gem install -v=1.0.1 rails
ERROR: could not find gem rails locally or in a repository

# gem environment
RubyGems Environment:
- RUBYGEMS VERSION: 1.2.0
- RUBY VERSION: 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]
- INSTALLATION DIRECTORY: /var/lib/gems/1.8
- RUBY EXECUTABLE: /usr/bin/ruby1.8
- EXECUTABLE DIRECTORY: /var/lib/gems/1.8/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86-linux
- GEM PATHS:
- /var/lib/gems/1.8
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- REMOTE SOURCES:
- http://gems.rubyforge.org/

# gem install rails
ERROR: could not find gem rails locally or in a repository


$ dpkg -l rubygems rails rack
ii rails 2.1.0-7
ii rubygems 1.2.0-3
Aucun paquet ne correspond à rack.

# gem list

*** LOCAL GEMS ***

# gem update --system
ERROR: While executing gem ... (RuntimeError)
gem update --system is disabled on Debian. RubyGems can be updated
using the official Debian repositories by aptitude or apt-get.


j'ai fais du :
aptitude install install ruby rake librmagick-ruby subversion
aptitude libmysql-ruby mysql-client rubygems
aptitude install libfcgi-ruby1.8 97 aptitude install ruby rake
rubygems
aptitude aptitude install libmysql-ruby libopenssl-ruby
aptitude install rails




note :
un tuto type essayé (celui est pour etch, mais ceux pour lenny sont
équivalent pour le résultat) :
http://howto.landure.fr/gnu-linux/debian-4-0-etch/installer-le-gestionnaire-de-projet-redmine-sur-debian-4-0-etch

il y a eu un test ou je suis allé plus loin mais c'est activesupport
qui foirait (sur incompatibilité de version entre rails et
activesupport )






--
Cordialement
Grégory BULOT



Salut

Je sais pas si ça peut t'aider mais j'avais installé redmine dans un
vserver que j'avais justement upgradé en lenny pour la circonstance.

Tu peux toujours jeter un oeil:
http://blogpmenier.dynalias.net/docext/redmine/

Patrick

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/i589ud$che$
Grégory Bulot
Le #22515961
Je sais pas si ça peut t'aider mais j'avais installé redmine da ns un
vserver que j'avais justement upgradé en lenny pour la circonstance.

Tu peux toujours jeter un oeil:
http://blogpmenier.dynalias.net/docext/redmine/

Patrick




j'ai regardé, il y a des différences sur l'init de la bdd, je ne pense
pas que mon problème avec le package redmine se passe là.
Mais s'il me reste du temps ce soir je tenterais, sachant que je suis
dans un container openvz, ce container à déjà d'autres acc ès mysql
fonctionnels.



--
Cordialement
Grégory BULOT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme