Lenteur absolue de debien testing sur un macbook

Le
Goldy
Bonjour,

j'utilise l'actuelle testing de debian sur un macbook (ceux en plastique
qui datent de 2007 je crois), et je constate que le système est vraiment
très très lent globalement.

Par exemple, une mise à jour avec aptitude d'une trentaine de paquet met
plus de 15 min à se faire (téléchargement non compris), et de la même
façon, le système arrive facilement à se bloquer lorsqu'il est
nécessaire de swaper (alors qu'il y a pourtant de 2go de ram). Je
constate énormément de latence IO, sans savoir d'où vient cette latence.

Je constate aussi que le boot est vraiment très très lent

J'ai installé mon système avec une couche de chiffrement, mais je ne
pense pas qu'il s'agisse de la raison pour laquelle le système est
ralentie, lorsque je copie des données, les performances sont bonnes et
il n'y a pas de consommation de cpu particulière dû au chiffrement, par
contre, le filesystem que j'ai choisie est btrfs, et je me demande si
cela ne viendrait pas à tout hasard de là

De plus, j'avais avant ce macbook un autre laptop moins performant avec
la même configuration et la réactivité était nettement meilleurs (à la
différence que j'avais utilisé ext4 à la place de btrfs).

Si quelqu'un aurait des pistes éventuels pour m'aider à comprendre
pourquoi le système semble si lent, merci d'avance ^^

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4DECDA5B.7040708@goldenfish.info
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bernard Schoenacker
Le #23429371
Le Mon, 06 Jun 2011 15:47:07 +0200,
Goldy
Bonjour,

j'utilise l'actuelle testing de debian sur un macbook (ceux en
plastique qui datent de 2007 je crois), et je constate que le système
est vraiment très très lent globalement.

Par exemple, une mise à jour avec aptitude d'une trentaine de paquet
met plus de 15 min à se faire (téléchargement non compris), et de la
même façon, le système arrive facilement à se bloquer lorsqu'il e st
nécessaire de swaper (alors qu'il y a pourtant de 2go de ram). Je
constate énormément de latence IO, sans savoir d'où vient cette
latence.

Je constate aussi que le boot est vraiment très très lent...

J'ai installé mon système avec une couche de chiffrement, mais je ne
pense pas qu'il s'agisse de la raison pour laquelle le système est
ralentie, lorsque je copie des données, les performances sont bonnes
et il n'y a pas de consommation de cpu particulière dû au
chiffrement, par contre, le filesystem que j'ai choisie est btrfs, et
je me demande si cela ne viendrait pas à tout hasard de là...

De plus, j'avais avant ce macbook un autre laptop moins performant
avec la même configuration et la réactivité était nettement meill eurs
(à la différence que j'avais utilisé ext4 à la place de btrfs).

Si quelqu'un aurait des pistes éventuels pour m'aider à comprendre
pourquoi le système semble si lent, merci d'avance ^^




bonjour,

quelle est la route employée ?


slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard Schoenacker
Le #23429481
Le Mon, 06 Jun 2011 15:47:07 +0200,
Goldy
Bonjour,

j'utilise l'actuelle testing de debian sur un macbook (ceux en
plastique qui datent de 2007 je crois), et je constate que le système
est vraiment très très lent globalement.

Par exemple, une mise à jour avec aptitude d'une trentaine de paquet
met plus de 15 min à se faire (téléchargement non compris), et de la
même façon, le système arrive facilement à se bloquer lorsqu'il e st
nécessaire de swaper (alors qu'il y a pourtant de 2go de ram). Je
constate énormément de latence IO, sans savoir d'où vient cette
latence.

Je constate aussi que le boot est vraiment très très lent...

J'ai installé mon système avec une couche de chiffrement, mais je ne
pense pas qu'il s'agisse de la raison pour laquelle le système est
ralentie, lorsque je copie des données, les performances sont bonnes
et il n'y a pas de consommation de cpu particulière dû au
chiffrement, par contre, le filesystem que j'ai choisie est btrfs, et
je me demande si cela ne viendrait pas à tout hasard de là...

De plus, j'avais avant ce macbook un autre laptop moins performant
avec la même configuration et la réactivité était nettement meill eurs
(à la différence que j'avais utilisé ext4 à la place de btrfs).

Si quelqu'un aurait des pistes éventuels pour m'aider à comprendre
pourquoi le système semble si lent, merci d'avance ^^




bonjour,


puisque j'ai été trop rapide à répondre :

cat /etc/modules
cat /etc/fstab
uname -ar |awk '{print $1" "$3}'
cat /etc/issue |awk '{print $1" "$3}'

liste des paquets :
apt-cache search apple laptop

question :

activation hdparm [ y || n ]
activation sdparm [ y || n ]


liste des paquets installés
for pkg in firmware dkms linux pam grub;do dpkg -l |grep $pkg '{"
"print $2" "$3}'

essaye de donner le maximum possible d'info

slt
bernard






--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Goldy
Le #23434011
Le 06/06/2011 22:11, Bernard Schoenacker a écrit :

bonjour,




Bonjour Bernard, merci pour ta réponse.




puisque j'ai été trop rapide à répondre :

cat /etc/modules



~$ cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
# Parameters can be specified after the module name.

firewire-sbp2
loop



cat /etc/fstab



$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/mapper/cub-root / btrfs defaults 0 1
# /boot was on /dev/sda3 during installation
UUIDüc09283-c7ef-4203-9cf2-ad90b4a8d788 /boot ext4
defaults 0 2
/dev/mapper/cub-swap none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
tmpfs /home/goldy/.thumbnails tmpfs defaults,size 0m 0 0
tmpfs /home/goldy/.cache/chromium tmpfs defaults,size0m 0 0
tmpfs /home/goldy/tmp_fs tmpfs defaults,size=1g 0 0



uname -ar |awk '{print $1" "$3}'


$ uname -ar |awk '{print $1" "$3}'
Linux 2.6.38-7.dmz.2-liquorix-686

cat /etc/issue |awk '{print $1" "$3}'


$ cat /etc/issue |awk '{print $1" "$3}'
Debian wheezy/sid


liste des paquets :
apt-cache search apple laptop



$ apt-cache search apple laptop
cairo-dock-powermanager-plugin - Cairo-dock - Powermanager plug-in
hdapsd - HDAPS daemon for IBM/Lenovo ThinkPads and Apple iBooks/PowerBooks
i8kutils - utilities for Dell Inspiron and Latitude laptops
netapplet - User-friendly network interface control applet
gpomme - graphical client for pommed
pommed - Apple laptops hotkeys event handler
wmpomme - WindowMaker dockapp client for pommed
sensors-applet - Display readings from hardware sensors in your Gnome panel


question :

activation hdparm [ y || n ]
activation sdparm [ y || n ]




sdparm n'est pas installé, hdparm retourne ceci :
$ sudo hdparm /dev/sda

/dev/sda:
multcount = 16 (on)
IO_support = 1 (32-bit)
readonly = 0 (off)
readahead = 256 (on)
geometry = 60801/255/63, sectors = 976773168, start = 0



liste des paquets installés
for pkg in firmware dkms linux pam grub;do dpkg -l |grep $pkg '{"
"print $2" "$3}'



La commande grep ne marche pas, j'ai du enlever print et j'ai netoyé la
sortie à la main ^^ :
ii bluez-firmware 1.2-2
ii firmware-atheros 0.30
ii firmware-linux-free 3
ii isight-firmware-tools 1.5.93-1
ii dkms 2.1.1.2-6
ii bluez-tools 0.1.38+git662e-2
ii doc-linux-fr-text 2005.08-1
ii doc-linux-text 2008.08-1
ii firmware-linux-free 3
ii libselinux1 2.0.98-1+b1
ii libv4l-0 0.8.3-2
ii linux-base 3.2
ii linux-headers-2.6-liquorix-686 2.6.38-11
ii linux-headers-2.6.38-7.dmz.2-liquorix-686 2.6.38-11
ii linux-image-2.6-686 2.6.38+34
ii linux-image-2.6-liquorix-686 2.6.38-11
ii linux-image-2.6.38-2-686 2.6.38-5
ii linux-image-2.6.38-6.dmz.1-liquorix-686 2.6.38-9
ii linux-image-2.6.38-7.dmz.1-liquorix-686 2.6.38-10
ii linux-image-2.6.38-7.dmz.2-liquorix-686 2.6.38-11
ii linux-libc-dev 2.6.38-5
ii linux-sound-base 1.0.23+dfsg-4
ii util-linux 2.17.2-9.1
ii bogofilter 1.2.2-3
ii bogofilter-bdb 1.2.2-3
ii bogofilter-common 1.2.2-3
ii libpam-ck-connector 0.4.5-1
ii libpam-gnome-keyring 3.0.0-3
ii libpam-modules 1.1.2-3
ii libpam-runtime 1.1.2-3
ii libpam0g 1.1.2-3
ii paman 0.9.4-1
ii python-pam 0.4.2-12.3+b1
rc grub 0.97-65
ii grub-common 1.99~rc1-13
ii grub-pc 1.99~rc1-13
ii grub2 1.99~rc1-13
ii grub2-splashimages 1.0.1




essaye de donner le maximum possible d'info

slt
bernard




Voilà tout ce que tu m'as demandé ^^

Cordialement

Christophe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Goldy
Le #23454861
Le problème semble finalement venir de btrfs. Après une rapide recherche
sur google, il s'avère que beaucoup de problèmes similaires ont été
constatés. Je vais faire une sauvegarde de mon laptop et réinstaller le
système sur ext4 pour voir s'il s'agissait effectivement de ça.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Charles Plessy
Le #23456381
Le Sun, Jun 12, 2011 at 08:47:18AM +0200, Goldy a écrit :
Le problème semble finalement venir de btrfs. Après une rapide recherche
sur google, il s'avère que beaucoup de problèmes similaires ont été
constatés. Je vais faire une sauvegarde de mon laptop et réinstaller le
système sur ext4 pour voir s'il s'agissait effectivement de ça.



Bonjour,

étant donné que ext4 a aussi causé des gros problèmes de lenteur dans le passé,
en particulier avec dpkg, il vaut peut-être mieux faire la comparaison avec
ext3.

Amicalement,

--
Charles Plessy
Tsurumi, Kanagawa, Japon

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain L. Sauvage
Le #23456541
Le lundi 13 juin 2011 à 02:27:39, Charles Plessy a écrit :
[…]
Bonjour,



’jour,

étant donné que ext4 a aussi causé des gros problèmes de
lenteur dans le passé, en particulier avec dpkg, il vaut
peut-être mieux faire la comparaison avec ext3.



C’est récent ou encore d’actualité ?
Tous les systèmes que j’ai testés sont (bien) plus rapi des en
ext4 qu’en ext3 (ext4 à l’installation ou en recopie c omplète,
je n’ai pas encore testé la conversion).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Goldy
Le #23458101
Le 13/06/2011 02:27, Charles Plessy a écrit :
Le Sun, Jun 12, 2011 at 08:47:18AM +0200, Goldy a écrit :
Le problème semble finalement venir de btrfs. Après une rapide recherche
sur google, il s'avère que beaucoup de problèmes similaires ont été
constatés. Je vais faire une sauvegarde de mon laptop et réinstaller le
système sur ext4 pour voir s'il s'agissait effectivement de ça.



Bonjour,

étant donné que ext4 a aussi causé des gros problèmes de lenteur dans le passé,
en particulier avec dpkg, il vaut peut-être mieux faire la comparaison avec
ext3.

Amicalement,




J'ai fait la réinstallation du système hier soir et le système est
beaucoup plus réactif maintenant que je suis en ext4.

j'ai lu qu'on pouvait corriger le problème avec btrfs en modifiant les
options de montages, mais si c'est pour désactiver la majorité des
fonctionnalité du filesystem, je préfère retourner en ext4, d'autant que
l'absence d'outils de vérification du filesystem me faisait craindre
pour mes données.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Charles Plessy
Le #23460281
Le Mon, Jun 13, 2011 at 08:30:36AM +0200, Sylvain L. Sauvage a écrit :
Le lundi 13 juin 2011 à 02:27:39, Charles Plessy a écrit :

> étant donné que ext4 a aussi causé des gros problèmes de
> lenteur dans le passé, en particulier avec dpkg, il vaut
> peut-être mieux faire la comparaison avec ext3.

C’est récent ou encore d’actualité ?
Tous les systèmes que j’ai testés sont (bien) plus rapides en
ext4 qu’en ext3 (ext4 à l’installation ou en recopie complète,
je n’ai pas encore testé la conversion).



Si j'ai bien compris, le problème de dpkg avec ext4 a été réglé dans dpkg, donc
les mêmes causes pourraient créer les mêmes conséquences ailleurs. Ceci dit le
problème était assez spécifique.

http://www.google.com/search?q=dpkg+ext4+site%3Abugs.debian.org

Bonne journée,

--
Charles Plessy
Tsurumi, Kanagawa, Japon

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain L. Sauvage
Le #23461401
Le mardi 14 juin 2011 à 14:57:18, Charles Plessy a écrit :
[…]
Si j'ai bien compris, le problème de dpkg avec ext4 a été
réglé dans dpkg, donc les mêmes causes pourraient cré er les
mêmes conséquences ailleurs. Ceci dit le problème ét ait
assez spécifique.




http://www.google.com/search?q=dpkg+ext4+site%3Abugs.debian.org

Hmm, ok, le même genre de « problème » de la lenteur de 'sync'
qui avait fait du bruit il y a quelque temps, notamment avec
Firefox (et son utilisation de sqlite), à savoir que tout
ralentit quand certains se mettent à faire les choses proprement
alors que d’autres préfèreraient continuer à ne pas prendre de
précaution (ou plutôt à prendre de fausses précautions plus
rapides).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme