Lenteur généralisée depuis changement matériel

Le
Bastien Durel
Bonjour,

Suite à un crash matériel, j'ai du changer la carte mère (et donc la
mémoire et le CPU) d'une de mes machines. Depuis lors, le système est
très fortement ralenti sans que j'arrive à en déduire la cause.
Rien que le boot est très lent à partir du moment où init prend la main
(plusieurs minutes sur le message "Init version 2.86 booting")
Certaines opération se font en temps normal, te d'autres non. si ls est
ralenti, je ne le vois pas, mais il me faut près d'une minute pour me
logger -- dont 50s d'attente *après* l'affichage de /etc/motd -- , un
logcheck prend plus de deux heures (60 fois plus long qu'avant avec un
CPU plus musclé), spamd fait souvent un timeout, et j'ai même vu udev
faire de même.
j'ai recompilé le noyau en spécifiant l'architecture du nouveau CPU
(C3->PENTIUM4) sans constater d'amélioration significative.
Avez-vous d'autres pistes ?

Merci,

--
Bastien
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas S.
Le #1907018
Bastien Durel
Avez-vous d'autres pistes ?


Enlever le maximum de périphérique et comparer. Ça permettra de réd uire
le champ des suppositions dans un premier temps.

Vraiment rien dans les logs?

--
Nicolas S.

capfree
Le #1907015
Bonjour,

Suite à un crash matériel, j'ai du changer la carte mère (et donc la
mémoire et le CPU) d'une de mes machines. Depuis lors, le système est
très fortement ralenti sans que j'arrive à en déduire la cause.
Rien que le boot est très lent à partir du moment où init prend la main
(plusieurs minutes sur le message "Init version 2.86 booting")
Certaines opération se font en temps normal, te d'autres non. si ls est
ralenti, je ne le vois pas, mais il me faut près d'une minute pour me
logger -- dont 50s d'attente *après* l'affichage de /etc/motd -- , un
logcheck prend plus de deux heures (60 fois plus long qu'avant avec un
CPU plus musclé), spamd fait souvent un timeout, et j'ai même vu udev
faire de même.
j'ai recompilé le noyau en spécifiant l'architecture du nouveau CPU
(C3->PENTIUM4) sans constater d'amélioration significative.
Avez-vous d'autres pistes ?

Merci,



Tester avec une Knoppix.

--
capfree

Fabien LE LEZ
Le #1907014
On Tue, 20 Nov 2007 11:06:16 +0100, Bastien Durel :

Depuis lors, le système est
très fortement ralenti sans que j'arrive à en déduire la cause.


C'est le système qui est plus lent, ou c'est un processus qui bouffe
toute la puissance du processeur ?

Bastien Durel
Le #1907003
Bastien Durel
Avez-vous d'autres pistes ?


Enlever le maximum de périphérique et comparer. Ça permettra de réduire
le champ des suppositions dans un premier temps.

Vraiment rien dans les logs?

Il n'y a aucun périphérique branché, juste un clavier, et les machins

soudés sur la carte mère (ethernet, USB) ; plus un CPU et une barette de
RAM.

/var/log/messages ne contient que les redémarrages de syslog et quelques
erreurs de mots de passe ; dmesg ne remonte aucune erreur ; quand à
/var/log/syslog, tout ce qui remonte ce sont des lignes du genre :

Nov 20 15:10:35 arrakeen spamd[19094]: spamd: copy_config timeout,
respawning child process after 5 messages at /usr/sbin/spamd line 1103.

(Je suis sous Debian)

--
Bastien


Bastien Durel
Le #1907002
[...]

Tester avec une Knoppix.

Je n'ai pas de lecteur de CD ;)


Blague à part, si je gravais un live-CD et que je montais un lecteur
optique dans cette machine, je regarderais quoi ?

--
Bastien

Fabien LE LEZ
Le #1907001
On Tue, 20 Nov 2007 23:07:54 +0100, Bastien Durel

Je n'ai pas de lecteur de CD


Il existe des "live-clé-USB".

Blague à part, si je gravais un live-CD et que je montais un lecteur
optique dans cette machine, je regarderais quoi ?


Pour commencer, si le problème vient du matériel ou de ton
installation de Linux.

Nicolas S.
Le #1906999
Bastien Durel
Blague à part, si je gravais un live-CD et que je montais un lecteur
optique dans cette machine, je regarderais quoi ?


Si tu as toujours des ralentissements. Ça permettrait de savoir - à peu
près sûrement - si la cause est matérielle ou logicielle.

--
Nicolas S.

Luc.Habert.00__arjf
Le #1906998
Bastien Durel :

Certaines opération se font en temps normal, te d'autres non. si ls est
ralenti, je ne le vois pas, mais il me faut près d'une minute pour me
logger -- dont 50s d'attente *après* l'affichage de /etc/motd --


Est-ce que le disque tourne à ce moment là? Que donne

hdparm -tT /dev/ledisquedur

? Est-ce que si, après, tu te logues dans une console à côté, ça rame autant?
Si oui, tu peux essayer dans la première console où tu es logué de lancer

strace -p piddugettylancedanslasecondeconsoleoutuvasteloguer

puis te loguer dans la console à côté, revenir dans la console où tu as
lancé le strace, et voir ce qu'il se passe pendant les moments de rame.

Bastien Durel
Le #1906997
On Tue, 20 Nov 2007 11:06:16 +0100, Bastien Durel :

Depuis lors, le système est
très fortement ralenti sans que j'arrive à en déduire la cause.


C'est le système qui est plus lent, ou c'est un processus qui bouffe
toute la puissance du processeur ?

C'est le système qui est lent. La lenteur commence dès que init prend la

main. J'ai un load average très élevé, mais un taux d'occupation du CPU
relativement bas


load average: 2.04, 3.00, 3.09

Cpu(s): 36.8%us, 1.7%sy, 0.0%ni, 61.4%id, 0.0%wa, 0.0%hi, 0.0%si,
0.0%st
(dont 12% rien que pour le top)

http://www.geekwu.org/cgi-bin/stats/sysstats

--
Bastien


Luc.Habert.00__arjf
Le #1906996
Bastien Durel :

(dont 12% rien que pour le top)


Wow... Tu as bien réglé la vitesse de ton processeur?

Publicité
Poster une réponse
Anonyme