lenteur serveur de fichier

Le
bob66622
bonjour, nous venons de changer tout récemment un serveur de fichiers chez un
client, 8 postes en tout avec le serveur

ce serveur ne sert qu'à travailler avec des fichiers adobe, les ouvrir les
modifier et les enregistrer.

tous les postes sont sur un switch gigabit, le serveur aussi, donc bonne
bande passante
pourtant lorsqu'une machine accède à un repertoire du disk serveur contenant
,par ex, 3000 fichiers, cela rame enormément, la meme chose lorsqu'on
enregistre un fichier sur le serveur c'est tres long et ca perturbe les
aurtres postes, qui eux n'ont quasiment plus accès au serveur,
quelqu'un aurait une idée pour ce genre de souci?

config serveur:
intel Xeon 5150 bouble coeur
500 Go Sata II, 2 partitions, systeme + données
lto ultrium 200/400Go
512Mo RAM --> seul point noir
la charge du serveur au niveau memoire ram est tout le temp à 400Mo environ
utilisée sur 512Mo
les fichiers d'échange sont de 10 Go sur les 2 disk cumulés

merci, beaucoup.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Lionel Palant
Le #734669
On 26 avr, 13:28, bob66622
bonjour, nous venons de changer tout récemment un serveur de fichiers c hez un
client, 8 postes en tout avec le serveur

512Mo RAM --> seul point noir
la charge du serveur au niveau memoire ram est tout le temp à 400Mo env iron
utilisée sur 512Mo
les fichiers d'échange sont de 10 Go sur les 2 disk cumulés

merci, beaucoup.


Tu as donné le diagnostic : doubler la RAM et réduire le swap (à 1Go
pour 512M ou 1.5Go pour 1Go RAM)
Vas dans le moniteur de performances et regardes la queue disque, les
défauts de pages par seconde (processus, Total, défauts de pages/s),
Cela devrait permettre de confirmer si c'est bien ça. Tu peux aussi
cocher les colonnes Erreurs de pages et Ecarts d'erreurs de pagination
dans "Sélectionner les colonnes" de l'onglet Processus du gestionnaire
de tâches.

Ciao

F. Dunoyer [MVP]
Le #734383
Il se trouve que Lionel Palant a formulé :
On 26 avr, 13:28, bob66622
bonjour, nous venons de changer tout récemment un serveur de fichiers chez
un client, 8 postes en tout avec le serveur

512Mo RAM --> seul point noir
la charge du serveur au niveau memoire ram est tout le temp à 400Mo environ
utilisée sur 512Mo
les fichiers d'échange sont de 10 Go sur les 2 disk cumulés

merci, beaucoup.


Tu as donné le diagnostic : doubler la RAM et réduire le swap (à 1Go
pour 512M ou 1.5Go pour 1Go RAM)
Vas dans le moniteur de performances et regardes la queue disque, les
défauts de pages par seconde (processus, Total, défauts de pages/s),
Cela devrait permettre de confirmer si c'est bien ça. Tu peux aussi
cocher les colonnes Erreurs de pages et Ecarts d'erreurs de pagination
dans "Sélectionner les colonnes" de l'onglet Processus du gestionnaire
de tâches.

Ciao


Humm c'est peut etre pas si net que ça.
j'ai un vieux serveur (AMD K6 300 (300 c'est 300 Mhz)) avec juste 512
Mo de RAM qui me sert encore et comme serveur de fichiers il n'ya rien
a redire meme quand je lui balance des images ISO de 600 ou 700 Mo.
400Mo de charge systeme sur 512, ça ne me parait pas incorrect.
Le soucis mémoire se manifesterait à mon avis si la charge mémoire
dépassait la mémoire physique.
Bon cest sur que quand on a une sauvegarde LTO, rajouter 512Mo c'est
peanuts.

Tout en suivant la piste que tu proposes, je conseillerai aussi de
regarder du cote des antivirus (antvirus server s'il existe) et aussi
antivirus des postes de travail.

Autre piste, la configuration des cartes réseaux. Il y'a parfois des
soucis quand les cartes sont configurés en détection de vitesse
automatique.
Je conseille (mais c'est un conseil qui revient souvent) de "forcer" la
vitesse en 100 Full (ou 100O Full) selon les equipements. Ca évites à
certains équipements de begayer sur la détection.

--
François Dunoyer [MVP Windows Server / Security]
Boite à outils NT/2000 : http://fds.mvps.org/ta/outils.htm
Boite à Outils Admin : http://fds.mvps.org/ta/outils-Admin.htm
Site perso : http://www.fdunoyer.net


bob66622
Le #734382
bonjour,
Merci pour toute vos reponses, fructueuse.
j'ai mis en place un perfmon sur le serveur, il s'avère que la mémoire
physique était à toc, moins de 30Mo dispo, et pas en pleine charge..
une upgrade à été effectuée (passage de 512Mo à 1Go, pour l'instant car
c'est le client qui paye et c'est un petit client...) et a priori cela
améliore grandement les choses, reste à suivre l'evolution des alertes sur le
perfmon afin de bien etre sur que rien d'autres ne viennent fausser la donne.
merci encore


Il se trouve que Lionel Palant a formulé :
On 26 avr, 13:28, bob66622
bonjour, nous venons de changer tout récemment un serveur de fichiers chez
un client, 8 postes en tout avec le serveur

512Mo RAM --> seul point noir
la charge du serveur au niveau memoire ram est tout le temp à 400Mo environ
utilisée sur 512Mo
les fichiers d'échange sont de 10 Go sur les 2 disk cumulés

merci, beaucoup.


Tu as donné le diagnostic : doubler la RAM et réduire le swap (à 1Go
pour 512M ou 1.5Go pour 1Go RAM)
Vas dans le moniteur de performances et regardes la queue disque, les
défauts de pages par seconde (processus, Total, défauts de pages/s),
Cela devrait permettre de confirmer si c'est bien ça. Tu peux aussi
cocher les colonnes Erreurs de pages et Ecarts d'erreurs de pagination
dans "Sélectionner les colonnes" de l'onglet Processus du gestionnaire
de tâches.

Ciao


Humm c'est peut etre pas si net que ça.
j'ai un vieux serveur (AMD K6 300 (300 c'est 300 Mhz)) avec juste 512
Mo de RAM qui me sert encore et comme serveur de fichiers il n'ya rien
a redire meme quand je lui balance des images ISO de 600 ou 700 Mo.
400Mo de charge systeme sur 512, ça ne me parait pas incorrect.
Le soucis mémoire se manifesterait à mon avis si la charge mémoire
dépassait la mémoire physique.
Bon cest sur que quand on a une sauvegarde LTO, rajouter 512Mo c'est
peanuts.

Tout en suivant la piste que tu proposes, je conseillerai aussi de
regarder du cote des antivirus (antvirus server s'il existe) et aussi
antivirus des postes de travail.

Autre piste, la configuration des cartes réseaux. Il y'a parfois des
soucis quand les cartes sont configurés en détection de vitesse
automatique.
Je conseille (mais c'est un conseil qui revient souvent) de "forcer" la
vitesse en 100 Full (ou 100O Full) selon les equipements. Ca évites à
certains équipements de begayer sur la détection.

--
François Dunoyer [MVP Windows Server / Security]
Boite à outils NT/2000 : http://fds.mvps.org/ta/outils.htm
Boite à Outils Admin : http://fds.mvps.org/ta/outils-Admin.htm
Site perso : http://www.fdunoyer.net







Publicité
Poster une réponse
Anonyme