Lenteur site ASP Net 2.0 et controle liste des certificats révoqués

Le
Michelle Martin
Bonjour,

Je viens de déployer un site intranet dans mon entreprise et au premier
démarrage du pool, j'ai un problème de lenteur. J'ai trouvé que ce problème
venait d'une tentative d'accès à "crl.microsoft.com". Pour résoudre ce
problème, j'ai trouvé sur le net qu'il faut décocher l'option internet
"Vérifier la révocation des certificats", mais dans mon environnement, cela
ne marche que si je laisse une session ouverte sur le serveur ce qui
n'est pas satisfaisant !

Détails sur l'environnement :
- Serveur Windows 2003 SP2
- Domaine active directory
- Utilisation d'un proxy pour accès au web mais sans restriction sur
".microsoft.com"
- Stratégie de groupe pour internet explorer
- Site "toto" avec son propre pool d'application
- Pool d'application dont l'identité est un compte du domaine (car avec
l'utilisateur prédéfini "Service réseau" je ne suis arrivée à rien)
- Site qui utilise Ajax

Pour que le démarrage du pool soit immédiat, il me suffit d'avoir sur le
serveur, un "internet explorer" exécuté en tant que "compte de domaine
d'identité du pool" avec l'option "Vérifier la révocation des certificats"
décochée. (Ca marche aussi dans le cas ou j'ai ouvert de la même façon ie et
que j'ai fourni des crédentials pour accéder à internet si l'option est
décochée)
Comment configurer l'ensemble pour être indépendant d'une session ouverte
avec une internet explorer ouvert ?

Merci
Michelle
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Marc Lognoul [MVP]
Le #19736741
Bonsoir,

Une solution "cowboy": ajouter au fichier "HOSTS" du server un entrée
127.0.0.1 crl.microsoft.com.
Une solution bien plus élégante: http://support.microsoft.com/kb/936707/fr,
soit la modification du fichier machine.config.

---
Marc Lognoul [MCSE, MCTS, MVP]
Heureux celui qui a pu pénétrer les causes secrètes des choses
Happy is the one who could enter the secret causes of things

Blog EN: http://www.marc-antho-etc.net/blog/



"Michelle Martin" news:4a49c7c7$0$437$
Bonjour,

Je viens de déployer un site intranet dans mon entreprise et au premier
démarrage du pool, j'ai un problème de lenteur. J'ai trouvé que ce
problème
venait d'une tentative d'accès à "crl.microsoft.com". Pour résoudre ce
problème, j'ai trouvé sur le net qu'il faut décocher l'option internet
"Vérifier la révocation des certificats", mais dans mon environnement,
cela
ne marche que si je laisse une session ouverte sur le serveur... ce qui
n'est pas satisfaisant !

Détails sur l'environnement :
- Serveur Windows 2003 SP2
- Domaine active directory
- Utilisation d'un proxy pour accès au web mais sans restriction sur
".microsoft.com"
- Stratégie de groupe pour internet explorer
- Site "toto" avec son propre pool d'application
- Pool d'application dont l'identité est un compte du domaine (car avec
l'utilisateur prédéfini "Service réseau" je ne suis arrivée à rien)
- Site qui utilise Ajax

Pour que le démarrage du pool soit immédiat, il me suffit d'avoir sur le
serveur, un "internet explorer" exécuté en tant que "compte de domaine
d'identité du pool" avec l'option "Vérifier la révocation des certificats"
décochée. (Ca marche aussi dans le cas ou j'ai ouvert de la même façon ie
et
que j'ai fourni des crédentials pour accéder à internet si l'option est
décochée)...
Comment configurer l'ensemble pour être indépendant d'une session ouverte
avec une internet explorer ouvert ?

Merci
Michelle





Publicité
Poster une réponse
Anonyme