Lettres accentuées avec Outlook 2007

Le
Kiriasse
Bonjour,

J'ai changé d'ordinateur et j'ai installé Outlook 2007 sur ce nouvel
ordinateur.
Sur mon ancien ordinateur, avec la précédente version d'Outlook, quand des
personnes m'envoyaient un message en utilisant mon formulaire
http://www.kiriasse.fr/mailtokir/mailtokir.html
je recevais leur message dans Outlook et les lettres accentuées et autres
caractères diacritiques du français étaient respectés.
Je constate que ce n'est plus le cas maintenant.
J'ai essayé de vérifier la configuration d'Outlook 2007 et je ne trouve rien
d'anormal.
Qui peut m'aider ?
Vous pouvez pour cela tester en utilisant mon formulaire. Ce que vous y
écrirez vous sera transmis à vous aussi.
Merci d'avance.
Kiriasse
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Le Claude
Le #16564731
Salut,

Dans Outlook, va au menu : [Outils] ==> [Options] ==> onglet[Format du courrier]
bouton [Internet] et [International], tu choisis la réception en HTML et au au format ISO
Occidental. Quelques fois aussi, il est possible que le problème vienne de ton
correspondant qui écrit sous un codage "exotique". Je t'envoie un message d'essai, je suis
en ISO Occidental.
--
Amicalement, Claude.

Claude CHARNEAU MVP-Windows Desktop Experience.

La fé sens òbras, mòrta es.


"Kiriasse" groupe de discussion : 48a7ed33$0$921$
Bonjour,

J'ai changé d'ordinateur et j'ai installé Outlook 2007 sur ce nouvel
ordinateur.
Sur mon ancien ordinateur, avec la précédente version d'Outlook, quand des
personnes m'envoyaient un message en utilisant mon formulaire
http://www.kiriasse.fr/mailtokir/mailtokir.html
je recevais leur message dans Outlook et les lettres accentuées et autres
caractères diacritiques du français étaient respectés.
Je constate que ce n'est plus le cas maintenant.
J'ai essayé de vérifier la configuration d'Outlook 2007 et je ne trouve rien
d'anormal.
Qui peut m'aider ?
Vous pouvez pour cela tester en utilisant mon formulaire. Ce que vous y
écrirez vous sera transmis à vous aussi.
Merci d'avance.
Kiriasse





JièL
Le #16565231
Bonjoir(c) Kiriasse

Le 17/08/2008 11:19 vous avez écrit ceci :
Bonjour,

J'ai changé d'ordinateur et j'ai installé Outlook 2007 sur ce nouvel
ordinateur.
Sur mon ancien ordinateur, avec la précédente version d'Outlook, quand des
personnes m'envoyaient un message en utilisant mon formulaire
http://www.kiriasse.fr/mailtokir/mailtokir.html
je recevais leur message dans Outlook et les lettres accentuées et autres
caractères diacritiques du français étaient respectés.
Je constate que ce n'est plus le cas maintenant.



Il semblerait que ce soit un pb sur Outlook car j'ai parfaitement reçu mon
test avec Thunderbird
Essayez ceci : ouvrez un mail (pas juste l'aperçu, ça ne suffit pas),
bouton "Autres actions", Codage. Essayez différent codage pour voir
Pour moi il s'affiche correctement en "Europe occidentale (ISO)" ce qui
correspond au "8859-1"

Par contre j'ai un message d'erreur dans l'entête du mail "X-Amavis-Alert:
BAD HEADER, MIME error: error: part did not end with expected"
Je ne sais pas d'où il vient ni ce qu'il veut dire mais je suppose que le
format "mime" n'est pas correct, il doit manquer une bricole qui indique à
Outlook quelle page de code utiliser.

Contrairement à Claude je préconise de ne pas forcer les codages car sinon
il risque d'être mal interprété par Outlook

Donc, pour 2007 : menu Outils, Options, onglet Format du courrier, Options
international, ne rien activer sauf "...prise en charge des noms de
domaine inter..."

Merci d'avance.



--
JièL / Jean-Louis GOUBERT
La FAQ Outlook a déménagé : http://faq.outlook.fr/

Boycott des questions venant de CDO
http://faq.outlook.fr/viewpage.php?page_id=2
Kiriasse
Le #16565221
Merci.
J'ai bien configuré cela comme vous dites et pourtant, je ne reçois pas
correctement les lettres accentuées.
Comment avez-vous reçu votre propre message envoyé avec MAILTOKIR ?

Cela pourrait-il provenir de ma configuration de MS Internet Explorer ? Ou
autre chose ?
Kiriasse
Répondant à

== "Le Claude"
Dans Outlook, va au menu : [Outils] ==> [Options] ==> onglet[Format du
courrier]
bouton [Internet] et [International], tu choisis la réception en HTML et au
au format ISO
Occidental. Quelques fois aussi, il est possible que le problème vienne de
ton
correspondant qui écrit sous un codage "exotique". Je t'envoie un message
d'essai, je suis
en ISO Occidental.

== "Kiriasse"
Bonjour,

J'ai changé d'ordinateur et j'ai installé Outlook 2007 sur ce nouvel
ordinateur.
Sur mon ancien ordinateur, avec la précédente version d'Outlook, quand des
personnes m'envoyaient un message en utilisant mon formulaire
http://www.kiriasse.fr/mailtokir/mailtokir.html
je recevais leur message dans Outlook et les lettres accentuées et autres
caractères diacritiques du français étaient respectés.
Je constate que ce n'est plus le cas maintenant.
J'ai essayé de vérifier la configuration d'Outlook 2007 et je ne trouve
rien
d'anormal.
Qui peut m'aider ?
Vous pouvez pour cela tester en utilisant mon formulaire. Ce que vous y
écrirez vous sera transmis à vous aussi.
Merci d'avance.
Kiriasse


Kiriasse
Le #16565211
Merci
C'est ainsi que mon Outlook 2007 est configuré.
Je sèche.
Kiriasse
Répondant à

== "JièL"
Il semblerait que ce soit un pb sur Outlook car j'ai parfaitement reçu mon
test avec Thunderbird
Essayez ceci : ouvrez un mail (pas juste l'aperçu, ça ne suffit pas),
bouton "Autres actions", Codage. Essayez différent codage pour voir
Pour moi il s'affiche correctement en "Europe occidentale (ISO)" ce qui
correspond au "8859-1"

Par contre j'ai un message d'erreur dans l'entête du mail "X-Amavis-Alert:
BAD HEADER, MIME error: error: part did not end with expected"
Je ne sais pas d'où il vient ni ce qu'il veut dire mais je suppose que le
format "mime" n'est pas correct, il doit manquer une bricole qui indique à
Outlook quelle page de code utiliser.

Contrairement à Claude je préconise de ne pas forcer les codages car sinon
il risque d'être mal interprété par Outlook

Donc, pour 2007 : menu Outils, Options, onglet Format du courrier, Options
international, ne rien activer sauf "...prise en charge des noms de
domaine inter..."
JièL
Le #16565401
Bonjoir(c) Kiriasse

Le 17/08/2008 13:07 vous avez écrit ceci :
Merci
C'est ainsi que mon Outlook 2007 est configuré.



Le pb n'est pas (AMHA) dans outlook mais plutot dans le prog de mail qui
ne formate pas correctement l'entête et Outlook 2007 n'arrive pas à
l'interpréter correctement

Par contre j'ai un message d'erreur dans l'entête du mail "X-Amavis-Alert:
BAD HEADER, MIME error: error: part did not end with expected"



--
JièL / Jean-Louis GOUBERT
La FAQ Outlook a déménagé : http://faq.outlook.fr/

Boycott des questions venant de CDO
http://faq.outlook.fr/viewpage.php?page_id=2
Kiriasse
Le #16565391
C'est moi qui ai écrit le petit programme PHP correspondant (en m'inspirant
d'un script trouvé sur Internet car je ne maîtrise pas bien le PHP).
Mais il marchait parfaitement avec mon ancien ordi sur lequel j'utilisais
une version antérieure d'Outlook.
Kiriasse
Répondant à

== "JièL"
Le pb n'est pas (AMHA) dans outlook mais plutot dans le prog de mail qui
ne formate pas correctement l'entête et Outlook 2007 n'arrive pas à
l'interpréter correctement

Par contre j'ai un message d'erreur dans l'entête du mail "X-Amavis-Alert:
BAD HEADER, MIME error: error: part did not end with expected"


JièL
Le #16565551
Bonjoir(c) Kiriasse

Le 17/08/2008 13:34 vous avez écrit ceci :
C'est moi qui ai écrit le petit programme PHP correspondant (en m'inspirant
d'un script trouvé sur Internet car je ne maîtrise pas bien le PHP).
Mais il marchait parfaitement avec mon ancien ordi sur lequel j'utilisais
une version antérieure d'Outlook.



Voui, pour moi l'affichage est correct aussi avec Thunderbird, par contre
Outlook 2007 à du mal, lui, avec cette erreur... semble t'il.

Donc, soit vous rectifiez le programme PHP, soit vous ouvrez chacun de vos
mail et vous choisissez le codage approprié ;-)

--
JièL / Jean-Louis GOUBERT
La FAQ Outlook a déménagé : http://faq.outlook.fr/

Boycott des questions venant de CDO
http://faq.outlook.fr/viewpage.php?page_id=2
Le Claude
Le #16566061
Re...

J'arrive que la guerre est finie-:) Mais bon je réponds...
Pour Kiriase qui a dit : Comment avez-vous reçu votre propre message envoyé avec MAILTOKIR
?
AFFREUX, les é deviennent des i les lettres comme ê sont absentes etc...

--
Amicalement, Claude.

Claude CHARNEAU MVP-Windows Desktop Experience.

La fé sens òbras, mòrta es.


"Kiriasse" groupe de discussion : 48a7ed33$0$921$
Bonjour,

J'ai changé d'ordinateur et j'ai installé Outlook 2007 sur ce nouvel
ordinateur.
Sur mon ancien ordinateur, avec la précédente version d'Outlook, quand des
personnes m'envoyaient un message en utilisant mon formulaire
http://www.kiriasse.fr/mailtokir/mailtokir.html
je recevais leur message dans Outlook et les lettres accentuées et autres
caractères diacritiques du français étaient respectés.
Je constate que ce n'est plus le cas maintenant.
J'ai essayé de vérifier la configuration d'Outlook 2007 et je ne trouve rien
d'anormal.
Qui peut m'aider ?
Vous pouvez pour cela tester en utilisant mon formulaire. Ce que vous y
écrirez vous sera transmis à vous aussi.
Merci d'avance.
Kiriasse





Kiriasse
Le #16566241
Il me faudrait revoir mon petit programme PHP. Mais je n'ai guère le temps
et je ne sais pas trop comment le modifier.
Merci en tout cas de m'avoir répondu et d'avoir fait le test.
Ce merci s'adresse bien sûr aux deux personnes qui m'ont répondu.
Bon dimanche.
Kiriasse
Kiriasse
Le #16568341
J'ai remplacé un passage existant dans mon script PHP par ce qui suit :
charset=iso-8859-1nContent-Transfer-Encoding: 8bitnn
Et je crois bien que ça a réglé mon problème.
Kiriasse
Se complétant

== "Kiriasse" Il me faudrait revoir mon petit programme PHP. Mais je n'ai guère le temps
et je ne sais pas trop comment le modifier.
Merci en tout cas de m'avoir répondu et d'avoir fait le test.
Ce merci s'adresse bien sûr aux deux personnes qui m'ont répondu.
Bon dimanche.
Kiriasse
Publicité
Poster une réponse
Anonyme