libglade2-ruby pour wheezy

Le
Tahar BEN ACHOUR
Bonjour, Y a-t-il un moyen d'installer libglade2-ruby sur debian whe=
ezy ? le paquet n'existe plus dans les dépôts et l'installation d'un pa=
quet en provenance de squeeze dépend de libgtk2-ruby1.8 (= 0.19.3-2+b=
1) alors que ma version est la 1.1.3-2.  Merci pour votre aide

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/1384945217.95434.YahooMailNeo@web172505.mail.ir2.yahoo.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Stéphane GARGOLY
Le #25800582
Bonjour à tous les utilisateurs et développeurs de Debian :

Le 20/11/2013, Tahar BEN ACHOUR
Y a-t-il un moyen d'installer libglade2-ruby sur debian wheezy ? le paque t
n'existe plus dans les dépôts et l'installation d'un paquet en proven ance de
squeeze dépend de libgtk2-ruby1.8 (= 0.19.3-2+b1) alors que ma versio n est
la 1.1.3-2.



Est-ce que ce paquet (venant de Squeeze) peut être mise à jour lors du
passage à Wheezy ? Peut-être cela résoudra ton problème.

Un petit conseil : n'oublie pas de donner le nom du paquet (qui dépend
de libglade2-ruby), cela peut nous aider à trouver (et à te proposer)
des solutions. ;-)

Cordialement et à bientôt,

Stéphane.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/CAAqHXE6D7j5K_J-9h6kko+-SA-_wwk2QSru-+
Tahar BEN ACHOUR
Le #25800622
Est-ce que ce paquet (venant de Squeeze) peut être mise à jour lors d u

passage à Wheezy ? Peut-être cela résoudra ton problème.



Je ne sais pas trop, j'ai fait une nouvelle insatllation à zéro j e ne suis pas passé de Squeeze à Wheezy, 

Un petit conseil : n'oublie pas de donner le nom du paquet (qui dépend
de libglade2-rub y), cela peut nous aider à trouver (et à te proposer)
des solutions . ;-)



comme mentionné libglade2-ruby dépend de libgtk2-ruby1.8 ver sion  0.19.3-2+b1 avec wheezy on a libgtk2-ruby1.8 version 1.1.3-2 il d épend aussi de ruby1.8 qui est installé et de libglade2 qui est install é aussi c'est vraiment l'extension glade-ruby qui pose problème.

M erci beaucoup.


Cordialement et à bientôt,

Stépha ne.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, e nvoyez un message avec comme objet
"unsubscribe"

vers debian-
En cas de soucis, contactez EN ANG LAIS
Archive:
http://lists.debian.org/ CAAqHXE6D7j5K_J-9h6kko+-SA-_wwk2QSru-+




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sébastien NOBILI
Le #25800652
Bonjour,

Le mercredi 20 novembre 2013 à 12:02, Tahar BEN ACHOUR a écrit :
> Est-ce que ce paquet (venant de Squeeze) peut être mise à jour lors du

> passage à Wheezy ? Peut-être cela résoudra ton problème.

Je ne sais pas trop, j'ai fait une nouvelle insatllation à zéro je ne suis pas passé de Squeeze à Wheezy, 



Installation fraîche ou mise-à-jour, le résultat sera le même.

Sur une installation fraîche, le paquet n'est pas présent car pas disponible
dans les dépôts de Wheezy.

Sur une mise-à-jour, tu peux conserver un paquet de Squeeze si il n'est pas
présent dans Wheezy (il n'est tout simplement pas mis à jour).

Or là, si j'ai bien suivi, la version de Squeeze du paquet en question ne peut
pas cohabiter avec le reste de Wheezy (dépendance sur une version fixe d'un
paquet qui existe dans Wheezy).

Donc, dans le cas d'une mise-à-jour ton paquet sera supprimé car une de ses
dépendances est en conflit avec le reste.

Les seules solutions que je vois à ton problème sont de recompiler la version
Jessie pour Wheezy, de rétrograder une partie de ton système en Squeeze (ce qui
n'est pas à conseiller car bientôt en fin de vie) ou bien de passer une partie
de ton système en Jessie.

Seb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain L. Sauvage
Le #25801212
Le mercredi 20 novembre 2013 13:27:14 Sébastien NOBILI a écri t :
Bonjour,



’jour,

Les seules solutions que je vois à ton problème sont de
recompiler la version Jessie pour Wheezy,



Ça va être difficile : il n’y a pas de version Jess ie.
En fait, il n’y a plus aucun paquet concernant à la fois Glade
et Ruby, ni dans Wheezy, ni dans Jessie, ni dans Sid.

En plus, il y a une migration en cours pour virer Ruby 1.8.

de rétrograder une
partie de ton système en Squeeze (ce qui n'est pas à
conseiller car bientôt en fin de vie) ou bien de passer une
partie de ton système en Jessie.



Autres solutions :

— ne plus utiliser Glade ;
(je dirais même volontiers de ne plus utiliser Gtk et de p.ex.
passer à Qt mais l’état de Ruby-Qt n’est pas vraiment
meilleur : toujours pas de version 1.9…)

— se passer de Ruby (argh) ;

— faire soi-même son paquet (ou installer soi-même) à   partir de
l’amont (ruby-gnome2 → http://ruby-gnome2.sourceforg e.jp/ ).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bzzz
Le #25801352
On Wed, 20 Nov 2013 15:05:56 +0100
"Sylvain L. Sauvage"
Autres solutions :
(argh) ;



Ou se tirer une balle dans la tête; ce qui
résoudrait définitivement le PB en faisant
moins chier la ML :)

--
<bogoss23142> TG konar jvé tmassacré
<bogoss23142> issi je sui le metre
<HelloWorld> Ah ouais attends j'appelle mon kilomètre, il est 1000 fois
plus fort que toi

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Stéphane GARGOLY
Le #25802122
Bonjour à tous les utilisateurs et développeurs de Debian :

Le 20/11/2013, Tahar BEN ACHOUR
comme mentionné libglade2-ruby dépend de libgtk2-ruby1.8 version
0.19.3-2+b1 avec wheezy on a libgtk2-ruby1.8 version 1.1.3-2 il dépend
aussi de ruby1.8 qui est installé et de libglade2 qui est installé au ssi
c'est vraiment l'extension glade-ruby qui pose problème.



Mille excuses ! Cela m'apprendra à lire trop rapidement les messages
(de la liste) pendant mon repas de midi. ;-)

S'agissant de libgtk2-ruby1.8 et d'après mes recherches, il semblerait
que ce paquet ne figure plus dans les versions qui suivent Squeeze -
comprendre Wheezy et Jessie - ni même dans Sid (sauf pour les
architectures hppa et sparc64... de façon non officielle).

Je te donne la page de recherche :
http://packages.debian.org/search?keywords=libglade2-ruby&searchon=name s&suite=all&section=all

Mais en allant plus loin, je remarque que libgtk2-ruby1.8 a été
compilé à partir du paquet "source" ruby-gnome2 qui, lui, est maintenu
dans Wheezy (en version 1.1.3-2).

Peut-être que, parmi les paquets compilés (pour Wheezy - attention,
une partie d'entre eux sont dites "de transition" donc
inexploitables), tu trouveras un ou plusieurs qui remplacerai(n)t
libgtk2-ruby1.8.

Là encore, je te donne le lien :
http://packages.debian.org/source/wheezy/ruby-gnome2

Cordialement et à bientôt,

Stéphane.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/CAAqHXE6vXm9jpMdXRo4G35FpbBr2NnvH+rgx8mNoh=f+
Stéphane GARGOLY
Le #25802322
Bonjour à tous les utilisateurs et développeurs de Debian :

Le 20/11/2013, Stéphane GARGOLY
S'agissant de libgtk2-ruby1.8 et d'après mes recherches, il semblerait


^^^^^^^^^^^^^^^^^
que ce paquet ne figure plus dans les versions qui suivent Squeeze -
comprendre Wheezy et Jessie - ni même dans Sid (sauf pour les
architectures hppa et sparc64... de façon non officielle).

Mais en allant plus loin, je remarque que libgtk2-ruby1.8 a été


^^^^^^^^^^^^^ ^^^^^
compilé à partir du paquet "source" ruby-gnome2 qui, lui, est mainten u
dans Wheezy (en version 1.1.3-2).

Peut-être que, parmi les paquets compilés (pour Wheezy - attention,
une partie d'entre eux sont dites "de transition" donc
inexploitables), tu trouveras un ou plusieurs qui remplacerai(n)t
libgtk2-ruby1.8.


^^^^^^^^^^^^^^^^^
libgtk2-ruby1.8 ? Euh, je veux dire "libglade2-ruby" bien sûr !

Bon, je crois bien que je suis un peu fatigué ce soir. Je vais dormir
de bonne heure... o:-)

Cordialement et à bientôt,

Stéphane.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/CAAqHXE6bAT03D+F_XCDjwk8Kz8y1vt2tNY7=-=
Publicité
Poster une réponse
Anonyme