libgnutls

Le
Jean-Michel OLTRA
Bonjour,


Chez moi, Jessie à jour (normalement) en amd64, j'ai une dépendance de
Libreoffice (et google-chrome) sur libgnutls.so.26, qui n'existe
pas/plus. Une dépendance sur ldd, ce qui fait que l'appli ne se lance
pas en disant qu'elle ne trouve pas la lib. J'ai une libgnutls-deb0-28,
et pas 26

Ça vous dit quelque chose ? Ce qui m'étonne, c'est que je n'ai pas
trouvé de référence sur G. là-dessus, ce qui laisserait à penser que
c'est chez moi que ça déconne.

Merci.

--
jm

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/20141115104717.GD2840@espinasse
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Haricophile
Le #26323146
Le Sat, 15 Nov 2014 11:47:17 +0100,
Jean-Michel OLTRA
Bonjour,


Chez moi, Jessie à jour (normalement) en amd64, j'ai une dépend ance de
Libreoffice (et google-chrome) sur libgnutls.so.26, qui n'existe
pas/plus. Une dépendance sur ldd, ce qui fait que l'appli ne se lance
pas en disant qu'elle ne trouve pas la lib. J'ai une
libgnutls-deb0-28, et pas 26

Ça vous dit quelque chose ? Ce qui m'étonne, c'est que je n'ai pas
trouvé de référence sur G. là-dessus, ce qui laissera it à penser que
c'est chez moi que ça déconne.

Merci.



Ça c'est l'inconvénient de Testing. Perso j'utilise aussi les d épots de
Unstable avec un pinning à 100, ça me permet de ne pas être bloqué avec
des paquets qui manquent transitoirement.

Ceci étant en jetant juste un coup œil rapide j'ai une version .28

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Gaëtan PERRIER
Le #26323166
Le Sat, 15 Nov 2014 11:47:17 +0100
Jean-Michel OLTRA

Bonjour,


Chez moi, Jessie à jour (normalement) en amd64, j'ai une dépendance de
Libreoffice (et google-chrome) sur libgnutls.so.26, qui n'existe
pas/plus. Une dépendance sur ldd, ce qui fait que l'appli ne se lance
pas en disant qu'elle ne trouve pas la lib. J'ai une libgnutls-deb0-28,
et pas 26

Ça vous dit quelque chose ? Ce qui m'étonne, c'est que je n'ai pas
trouvé de référence sur G. là-dessus, ce qui laisserait à pense r que
c'est chez moi que ça déconne.

Merci.




Bizarre je suis aussi en testing amd64 et je n'ai pas ce problème...

Voici ce que retourne apt-show-versions | grep gnutls
libcurl3-gnutls:amd64/jessie 7.38.0-3 uptodate
libcurl4-gnutls-dev:amd64/jessie 7.38.0-3 uptodate
libgnutls-deb0-28:amd64/jessie 3.3.8-4 uptodate
libgnutls-deb0-28:i386/jessie 3.3.8-4 uptodate
libgnutls-openssl27:amd64/jessie 3.3.8-4 uptodate
libgnutlsxx28:amd64/jessie 3.3.8-4 uptodate
libneon27-gnutls:amd64/jessie 0.30.1-1 uptodate
libxmlsec1-gnutls:amd64/jessie 1.2.20-2+b1 uptodate

Gaëtan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Jean-Michel OLTRA
Le #26323172
Bonjour,


Le samedi 15 novembre 2014, Gaëtan PERRIER a écrit...


Bizarre je suis aussi en testing amd64 et je n'ai pas ce problème...



Mince. Bizarre.

libgnutls-deb0-28:amd64/jessie 3.3.8-4 uptodate



Ce qui voudrait dire que c'est mon libreoffice qui pose problème ?

Qu'as tu comme version de libreoffice ? Perso, j'ai la 1:4.3.3~rc2-1

Merci.

--
jm

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Gaëtan PERRIER
Le #26323176
Le Sat, 15 Nov 2014 13:32:21 +0100
Jean-Michel OLTRA

Ce qui voudrait dire que c'est mon libreoffice qui pose problème ?

Qu'as tu comme version de libreoffice ? Perso, j'ai la 1:4.3.3~rc2-1




J'ai la même ...

Par contre quand tu dis que tu as google chrome tu parles de chromium des
dépôts debian ou du paquet google-chrome de google ? Dans ce dernier cas
est-ce que ça ne serait pas lui qui de par ses dépendances bloquerait u ne mise
à jour ?

Gaëtan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Jean-Michel OLTRA
Le #26323216
Bonjour,


Le samedi 15 novembre 2014, Gaëtan PERRIER a écrit...


J'ai la même ...

Par contre quand tu dis que tu as google chrome tu parles de chromium des
dépôts debian ou du paquet google-chrome de google ? Dans ce dernier cas
est-ce que ça ne serait pas lui qui de par ses dépendances bloquerait une mise
à jour ?



J'ai le chrome de Google. J'ai désactivé sa mise à jour, mais c'est
pareil. Ce qui est un peu normal. J'ai les paquets à jour, semble t-il,
mais le ldd sur /usr/lib/libreoffice/program/soffice.bin montre une
dépendance sur la libgnutls.so.26. Je me demande bien pourquoi.

/usr/lib/libreoffice/program/soffice.bin: error while loading shared
libraries: libgnutls.so.26: cannot open shared object file: No such file
or directory

--
jm

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Jean-Marc
Le #26323231
--Signature=_Sat__15_Nov_2014_18_42_57_+0100__dE=5.xKZiq+=djb
Content-Type: text/plain; charset=ISO-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Sat, 15 Nov 2014 18:11:12 +0100
Jean-Michel OLTRA

Bonjour,



salut Jean-Michel,

[...]
pareil. Ce qui est un peu normal. J'ai les paquets à jour, semble t-il,
mais le ldd sur /usr/lib/libreoffice/program/soffice.bin montre une
dépendance sur la libgnutls.so.26. Je me demande bien pourquoi.



soffice.bin appartient au paquet libreoffice-core :

$ apt-file search /usr/lib/libreoffice/program/soffice.bin
libreoffice-core: /usr/lib/libreoffice/program/soffice.bin

Qu'est-ce que donne un <apt-cache policy libreoffice-core> ?

Et un
Chez moi, Jessie à jour, ça donne ça :
$ apt-cache policy libreoffice-core
libreoffice-core:
Installé : 1:4.3.3~rc2-1
Candidat : 1:4.3.3~rc2-1
Table de version :
1:4.3.3-1 0
100 http://ftp.be.debian.org/debian/ unstable/main amd64 Packages
*** 1:4.3.3~rc2-1 0
500 http://ftp.be.debian.org/debian/ testing/main amd64 Packages
100 /var/lib/dpkg/status

$ /usr/lib/libreoffice/program/soffice.bin --version
LibreOffice 4.3.3.2 430m0(Build:2)


/usr/lib/libreoffice/program/soffice.bin: error while loading shared
libraries: libgnutls.so.26: cannot open shared object file: No such file
or directory



Et pas d'utilisation de la version 26 de libgnutls mais de la version 28 :
$ ldd /usr/lib/libreoffice/program/soffice.bin | grep gnutls
libgnutls-deb0.so.28 => /usr/lib/x86_64-linux-gnu/libgnutls-deb0.so.28 ( 0x00007f77e4067000)

Bizarre. Comme une inconsistance ou un soucis dans les mises à jour.

Une sortie pour un <dpkg --audit> ?

--
jm



Jean-Marc
--Signature=_Sat__15_Nov_2014_18_42_57_+0100__dE=5.xKZiq+=djb
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCAAGBQJUZ5ClAAoJEECwQOvthjrRUOIP/ji/x4+DlHRvzL/lBp2KXkh9
IYvNXiBf59lKFLWA/SRJATjMSKRQ59/eiMg2yrtHMVb/aNIQgLeXzz/TpE+ESj9u
TbPYQOP4KoH/j6yxZ8FpWBlpWN8HYC9/Jx8Vu5TUlp36E95F4ZGk4HrFVMYSzo6A
FWCbY8gXMRGjgSRS3thQN9MGS7qM+Z7OOMf/EhM5O5300t76TMYugQo5f1XT5Urj
0CW5O2fHaTnq819hI29ZEBHQ9hMmlBgTMKxJhNgRvtFy4JOHrXf5bLgQxOxlB5JF
pr/yHKLFjbw6MCPcoUVW93iTwo/G6elivi7ebPNb3KudTY0eaVhHW2QFkw/xHz/2
6aCo89SAx6lqbsvH8rIIPIGBZcOP/ZlW7dFT5sEgvIHfMXicqKg4AZ/+S5nsSgXn
4zJNifuaR7SOB6A+jL2P3II3btKQtLvAoLKn+xeNyMGZYAIPt47yUKdWE5b2pANJ
4WQMneYxHmgVASPJu6b4o/SS1/ZCMN7iBAXzdD/aLnI3YZjbRGU/cok6KET8elVQ
2PJbZVfXGxBe9RsHTdPRNjTCzdGuO7kyyd664VXulHZ8XC2iA1DS1gMsNay9aDCI
KxXiIHUtzZEM61F6/RU0bWQTNFMn7+EVMJoNqhTfo9+mhLDoD6AC6ixBqnzoWL3i
O/k7GYSFl9l8n7um/cvA
=FvQy
-----END PGP SIGNATURE-----

--Signature=_Sat__15_Nov_2014_18_42_57_+0100__dE=5.xKZiq+=djb--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Jean-Michel OLTRA
Le #26323273
Bonjour,


Le samedi 15 novembre 2014, Jean-Marc a écrit...


soffice.bin appartient au paquet libreoffice-core :

$ apt-file search /usr/lib/libreoffice/program/soffice.bin
libreoffice-core: /usr/lib/libreoffice/program/soffice.bin



Oui.

Qu'est-ce que donne un <apt-cache policy libreoffice-core> ?

Chez moi, Jessie à jour, ça donne ça :
$ apt-cache policy libreoffice-core
libreoffice-core:
Installé : 1:4.3.3~rc2-1
Candidat : 1:4.3.3~rc2-1
Table de version :
1:4.3.3-1 0
100 http://ftp.be.debian.org/debian/ unstable/main amd64 Packages
*** 1:4.3.3~rc2-1 0
500 http://ftp.be.debian.org/debian/ testing/main amd64 Packages
100 /var/lib/dpkg/status



Pareil, presque :

libreoffice-core:
Installé : 1:4.3.3~rc2-1
Candidat : 1:4.3.3~rc2-1
Table de version :
*** 1:4.3.3~rc2-1 0
500 http://ftp.fr.debian.org/debian/ testing/main amd64 Packages
100 /var/lib/dpkg/status

J'ai testing/main, et pas unstable/main

$ /usr/lib/libreoffice/program/soffice.bin --version
LibreOffice 4.3.3.2 430m0(Build:2)



Ça, je ne peux pas l'avoir, car j'ai l'erreur sur la liaison avec
libgnutls.so.26

Bizarre. Comme une inconsistance ou un soucis dans les mises à jour.

Une sortie pour un <dpkg --audit> ?



Ben, rien du tout, ni pour libreoffice-core, ni pour le reste


--
jm

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Jean-Michel OLTRA
Le #26323347
Bonjour,


Le samedi 15 novembre 2014, Jean-Marc a écrit...


libreoffice-core:
Installé : 1:4.3.3~rc2-1
Candidat : 1:4.3.3~rc2-1
Table de version :
1:4.3.3-1 0
100 http://ftp.be.debian.org/debian/ unstable/main amd64 Packages
*** 1:4.3.3~rc2-1 0
500 http://ftp.be.debian.org/debian/ testing/main amd64 Packages
100 /var/lib/dpkg/status

$ /usr/lib/libreoffice/program/soffice.bin --version
LibreOffice 4.3.3.2 430m0(Build:2)



Tiens je suis allé chercher, sur ftp.be.debian.org, le paquet
libreoffice-core_4.3.3~rc2-1_amd64.deb, car je m'étais dit que mon dépôt
sur ftp.fr pouvait avoir un paquet bugué.
Je l'installe : pas mieux
Je l'ouvre juste, je copie soffice.bin à sa place, dès fois que
l'installation n'ai pas bien écrasé ce qu'il y avait avant : pas mieux

Je me demande si les dépôts de Debian n'ont pas récupéré une archive
daubée entre temps, et que, personnellement, j'ai effectué cette mise à
jour sur ce paquet bugué ???? Est ce possible, même ?

--
jm

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Sylvain L. Sauvage
Le #26323350
Le dimanche 16 novembre 2014, 11:16:44 Jean-Michel OLTRA a écrit
:
Bonjour,



’jour,

[…]
Tiens je suis allé chercher, sur ftp.be.debian.org, le paquet
libreoffice-core_4.3.3~rc2-1_amd64.deb, car je m'étais dit que
mon dépôt sur ftp.fr pouvait avoir un paquet bugué.
Je l'installe : pas mieux
Je l'ouvre juste, je copie soffice.bin à sa place, dès fois
que l'installation n'ai pas bien écrasé ce qu'il y avait
avant : pas mieux



Euh, qu’est-ce que tu veux dire par « pas mieux » ?

Car si je récupère le même fichier, je le désarch ive (dpkg -x)
(suis en Sid et j’ai pas Libreoffice) et je fais un ldd sur
soffice.bin :
$ ldd usr/lib/libreoffice/program/soffice.bin | grep tls
libgnutls-deb0.so.28 => /usr/lib/x86_64-linux-
gnu/libgnutls-deb0.so.28 (0x00007f85560bc000)

donc on a bien la 28. Pas de trace de la 26.

T’es sûr que tu lances bien le bon soffice.bin ?
Est-ce que t’as pas des trucs peu ordinaires (mount bind,
liens symboliques ou durs ou je ne sais quoi) ?

Fais un md5sum (ou sha1sum…) sur tous les soffice.bin que tu
as…

Je me demande si les dépôts de Debian n'ont pas récupà ©ré une
archive daubée entre temps, et que, personnellement, j'ai
effectué cette mise à jour sur ce paquet bugué ???? Es t ce
possible, même ?



Et t’aurais été le seul ? Peu probable.

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Jean-Marc
Le #26323357
--Signature=_Sun__16_Nov_2014_11_42_24_+0100_AGa+.8C_ZQq7v.86
Content-Type: text/plain; charset=ISO-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Sun, 16 Nov 2014 11:16:44 +0100
Jean-Michel OLTRA

Bonjour,



salut,

[...]



Que donne <$ apt-cache policy libgnutls-deb0-28 libgnutls26> ?


--
jm




Jean-Marc
--Signature=_Sun__16_Nov_2014_11_42_24_+0100_AGa+.8C_ZQq7v.86
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCAAGBQJUaH+WAAoJEECwQOvthjrRiqIQAIH5KT8GLoi8vNY006tpaFzP
O5pAOAknQ+j5B+e1Dk02a4WhyvmXwy0hteL/lwHMOTOkq2WnuTnbU9VZkim97TSN
3EtKL0tVvYUc5GYk/hw0OmUSC5PkI4kkgO0fb2i9VhEPr2NIhhO1mXhTpdpnd6C2
2y4QRxT7IigJaCj1UhQxFg19fdluqvUfTrXH/NJF562FmmYHyOg8O54wK20JGSnq
cPZ0lw5YD09vqvJzL0VAyNxr9y5zH+fKy1aM5LDz8MMPgnLb+vDkAdTnh7LFbBSG
jUS+BG5tRmokDFUhahK7koHNymSPUqJTKYSvBV6kTl5Lirp0V7rKmgHOlvT88n0f
eXMxMA68rz6n0uHigCwcxsmCKz3YF4yfv/oZMAVGs0AY7oNOevER+yk3Z6pb5EB6
RrHtVJ6wy7a4sVpHDrWRJ+LSJCJjOE0ZHBgV9ctUKymlAdncZBe7aJ+0Q2Kipt7V
OmxjxtnXYctKvuCpy5fZB3Cp4WgwRglPb3T3A7UiMkiCGnnD+yZYEfPrsRTaCBpf
GB+lHyWFwiI5SchscfOC4OEx6CZn3mpzqic0l7eMs7n+9hxh7NiFguBzRbOFUob6
BTuLXDtznsaN/p0JJFaNVoI1qqxilhZSwARs+kplXFzHxk32Ev2JuKnp4xQVKf6y
cTBIBGxOpuZdkYYbkgZb
ûX0
-----END PGP SIGNATURE-----

--Signature=_Sun__16_Nov_2014_11_42_24_+0100_AGa+.8C_ZQq7v.86--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Publicité
Poster une réponse
Anonyme