Lien hypertexte

Le
GOWAP
Bonjour,

dans une cellule, je mets la formule suivante :

=SI(VRAI;"";LIEN_HYPERTEXTE("a";"b"))

La cellule affiche "" et est cliquable ! Le pointeur a la forme cliquable
! Ce qui n'est pas normal, car il n'y a pas de lien Web sur "".
Si je clique dessus, j'ai une supperbe fenetre affichant :

Ouverture de c:temp
Certains fichiers peuvent conteir des virus ou peuvent porter préjudice à
votre ordinateur..


Comment faire pour que la cellule ne soit pas un lien ?

Merci,
GOWAP
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
lSteph
Le #4680781
Bonjour,

Remplace "---" par "C:"
tu vas comprendre....

A partir du moment ou tu mets
LIEN_HYPERTEXTE dans une formule elle devient cliquable
simplement le chemin "---" n'est pas valide, le reste est probablement
lié à tes parametres de sécurité voire parefeu ou antivirus

Cordialement.

lSteph


On 30 août, 16:53, "GOWAP"
Bonjour,

dans une cellule, je mets la formule suivante :

=SI(VRAI;"---";LIEN_HYPERTEXTE("a";"b"))

La cellule affiche "---" et est cliquable ! Le pointeur a la forme cliqua ble
! Ce qui n'est pas normal, car il n'y a pas de lien Web sur "---".
Si je clique dessus, j'ai une supperbe fenetre affichant :

Ouverture de c:temp---
Certains fichiers peuvent conteir des virus ou peuvent porter préjudice à
votre ordinateur.....

Comment faire pour que la cellule ne soit pas un lien ?

Merci,
GOWAP


GOWAP
Le #4680261
"lSteph"
Bonjour,

Remplace "---" par "C:"
tu vas comprendre....

A partir du moment ou tu mets
LIEN_HYPERTEXTE dans une formule elle devient cliquable
simplement le chemin "---" n'est pas valide, le reste est probablement
lié à tes parametres de sécurité voire parefeu ou antivirus

Cordialement.

lSteph


On 30 août, 16:53, "GOWAP"
Bonjour,

dans une cellule, je mets la formule suivante :

=SI(VRAI;"---";LIEN_HYPERTEXTE("a";"b"))

La cellule affiche "---" et est cliquable ! Le pointeur a la forme
cliquable
! Ce qui n'est pas normal, car il n'y a pas de lien Web sur "---".
Si je clique dessus, j'ai une supperbe fenetre affichant :

Ouverture de c:temp---
Certains fichiers peuvent conteir des virus ou peuvent porter préjudice à
votre ordinateur.....

Comment faire pour que la cellule ne soit pas un lien ?

Merci,
GOWAP



Le "---" n'a pas pour but d'être cliquable !
Le but est d'avoir un lien cliquable que lorsque la condition n'est pas
rempli sur cette exemple.

Il est vrai qu'avec un exemple ce serai plus parlant.

Dans A1, si le texte commence par "TCK" (pour ticket) alors le texte
référenci un numéro de ticket. Pour visualiser le ticket, il faut aller sur
le lien intranet suivant "http://intra.com?id=" & A1
Si le texte A1 ne correspond pas au schémat, alors écrire "---" dans la
cellule.

D'ou

Si (gauche(A1;3)="TCK";LIEN_HYPERTEXTE(http://intra.com?id= &
A1;"Lnk");"---")


Le problème, c'est que même sur la valeur "---" la cellule est cliquable.


GOWAP

Misange
Le #4678661
Bonjour,

Le simple fait d'écrire dans une cellule une formule contenant quelque
part LIEN_HYPERTEXTE produit ce comportement que tu observes...

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

"lSteph"
Bonjour,

Remplace "---" par "C:"
tu vas comprendre....

A partir du moment ou tu mets
LIEN_HYPERTEXTE dans une formule elle devient cliquable
simplement le chemin "---" n'est pas valide, le reste est probablement
lié à tes parametres de sécurité voire parefeu ou antivirus

Cordialement.

lSteph


On 30 août, 16:53, "GOWAP"
Bonjour,

dans une cellule, je mets la formule suivante :

=SI(VRAI;"---";LIEN_HYPERTEXTE("a";"b"))

La cellule affiche "---" et est cliquable ! Le pointeur a la forme
cliquable
! Ce qui n'est pas normal, car il n'y a pas de lien Web sur "---".
Si je clique dessus, j'ai une supperbe fenetre affichant :

Ouverture de c:temp---
Certains fichiers peuvent conteir des virus ou peuvent porter préjudice à
votre ordinateur.....

Comment faire pour que la cellule ne soit pas un lien ?

Merci,
GOWAP



Le "---" n'a pas pour but d'être cliquable !
Le but est d'avoir un lien cliquable que lorsque la condition n'est pas
rempli sur cette exemple.

Il est vrai qu'avec un exemple ce serai plus parlant.

Dans A1, si le texte commence par "TCK" (pour ticket) alors le texte
référenci un numéro de ticket. Pour visualiser le ticket, il faut aller sur
le lien intranet suivant "http://intra.com?id=" & A1
Si le texte A1 ne correspond pas au schémat, alors écrire "---" dans la
cellule.

D'ou

Si (gauche(A1;3)="TCK";LIEN_HYPERTEXTE(http://intra.com?id= &
A1;"Lnk");"---")


Le problème, c'est que même sur la valeur "---" la cellule est cliquable.


GOWAP





LSteph
Le #4677951
Bonsoir,

Et...si tu lisais ce que j'ai écris dans ma réponse!?

A partir du moment ou tu mets
LIEN_HYPERTEXTE dans une formule elle devient cliquable


;o) même ceci: "---"

Amicordialement.

lSteph

JB
Le #4677921
Bonsoir,

Exemple: =SI(B2<C2;LIEN_HYPERTEXTE("["&A2&".xls]";A2);"")

http://boisgontierjacques.free.fr/pages_site/lienshypertextes.htm

JB





On 31 août, 09:24, "GOWAP"
"lSteph"
Bonjour,

Remplace "---" par "C:"
tu vas comprendre....

A partir du moment ou tu mets
LIEN_HYPERTEXTE dans une formule elle devient cliquable
simplement le chemin "---" n'est pas valide, le reste est probablement
lié à tes parametres de sécurité voire parefeu ou antivirus

Cordialement.

lSteph

On 30 août, 16:53, "GOWAP"




Bonjour,

dans une cellule, je mets la formule suivante :

=SI(VRAI;"---";LIEN_HYPERTEXTE("a";"b"))

La cellule affiche "---" et est cliquable ! Le pointeur a la forme
cliquable
! Ce qui n'est pas normal, car il n'y a pas de lien Web sur "---".
Si je clique dessus, j'ai une supperbe fenetre affichant :

Ouverture de c:temp---
Certains fichiers peuvent conteir des virus ou peuvent porter préjudi ce à
votre ordinateur.....

Comment faire pour que la cellule ne soit pas un lien ?

Merci,
GOWAP


Le "---" n'a pas pour but d'être cliquable !
Le but est d'avoir un lien cliquable que lorsque la condition n'est pas
rempli sur cette exemple.

Il est vrai qu'avec un exemple ce serai plus parlant.

Dans A1, si le texte commence par "TCK" (pour ticket) alors le texte
référenci un numéro de ticket. Pour visualiser le ticket, il faut a ller sur
le lien intranet suivant "http://intra.com?id=" & A1
Si le texte A1 ne correspond pas au schémat, alors écrire "---" dans la
cellule.

D'ou

Si (gauche(A1;3)="TCK";LIEN_HYPERTEXTE(http://intra.com?id=&
A1;"Lnk");"---")

Le problème, c'est que même sur la valeur "---" la cellule est cliqua ble.

GOWAP- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -



Misange
Le #4677831
bravo :-) j'y étais presque mais tout est dans le presque dans ce cas là
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Bonsoir,

Exemple: =SI(B2<C2;LIEN_HYPERTEXTE("["&A2&".xls]";A2);"")

http://boisgontierjacques.free.fr/pages_site/lienshypertextes.htm

JB





On 31 août, 09:24, "GOWAP"
"lSteph"
Bonjour,

Remplace "---" par "C:"
tu vas comprendre....

A partir du moment ou tu mets
LIEN_HYPERTEXTE dans une formule elle devient cliquable
simplement le chemin "---" n'est pas valide, le reste est probablement
lié à tes parametres de sécurité voire parefeu ou antivirus

Cordialement.

lSteph

On 30 août, 16:53, "GOWAP"




Bonjour,
dans une cellule, je mets la formule suivante :
=SI(VRAI;"---";LIEN_HYPERTEXTE("a";"b"))
La cellule affiche "---" et est cliquable ! Le pointeur a la forme
cliquable
! Ce qui n'est pas normal, car il n'y a pas de lien Web sur "---".
Si je clique dessus, j'ai une supperbe fenetre affichant :
Ouverture de c:temp---
Certains fichiers peuvent conteir des virus ou peuvent porter préjudice à
votre ordinateur.....
Comment faire pour que la cellule ne soit pas un lien ?
Merci,
GOWAP
Le "---" n'a pas pour but d'être cliquable !

Le but est d'avoir un lien cliquable que lorsque la condition n'est pas
rempli sur cette exemple.

Il est vrai qu'avec un exemple ce serai plus parlant.

Dans A1, si le texte commence par "TCK" (pour ticket) alors le texte
référenci un numéro de ticket. Pour visualiser le ticket, il faut aller sur
le lien intranet suivant "http://intra.com?id=" & A1
Si le texte A1 ne correspond pas au schémat, alors écrire "---" dans la
cellule.

D'ou

Si (gauche(A1;3)="TCK";LIEN_HYPERTEXTE(http://intra.com?id=&
A1;"Lnk");"---")

Le problème, c'est que même sur la valeur "---" la cellule est cliquable.

GOWAP- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -







Publicité
Poster une réponse
Anonyme