Liens visités

Le
sep_ghis
Bonjour,

Depuis que j'ai IE 7, j'ai remarqué ceci:

Les liens hypertextes d'une page web principale ne deviennent pas en mauve
lorsqu'on clique sur les boutons de navigation prévus dans les bas de pages.
(EX:
http://www.novell.com/documentation/zenworks65/index.html?page=/documentation/zenworks65/dmadmin/data/bssit9p.html)

Dans le lien précédent, nous arrivons à une page principale d'une
documentation, quand nous naviguons dans celle-ci via les liens hypertexte,
pas de problème les liens visités deviennent en mauve. Par contre, quand nous
naviguons dans cette documentation via les boutons en bas de page, les liens
visités restent en bleu. Pourquoi? Cela fonctionnait bien avec IE 6.

Par contre, j'ai lu que quelqu'un a eu le même genre de problème (
http://www.technologyquestions.com/technology/internet-explorer/121517-visited-hyperlink-color-not-changing-ie7-javascript-link.html),
mais aucune solution n'est proposée. Il semblerait que c'est un problème avec
les boutons en JAVA. En effet, le site de la documentation proposée plus haut
contient des boutons en JAVA.

Comment faire pour corriger la situation?

Merci,
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bernard Lempel
Le #16476901
Bonjour,

Le problème n'est pas dans ton navigateur.
C'est le site visité qui est conçu ainsi.

Au revoir.
Bernard Lempel
http://lempel.net

"sep_ghis" news:
Bonjour,

Depuis que j'ai IE 7, j'ai remarqué ceci:

Les liens hypertextes d'une page web principale ne deviennent pas en mauve
lorsqu'on clique sur les boutons de navigation prévus dans les bas de
pages.
(EX:
http://www.novell.com/documentation/zenworks65/index.html?page=/documentation/zenworks65/dmadmin/data/bssit9p.html)

Dans le lien précédent, nous arrivons à une page principale d'une
documentation, quand nous naviguons dans celle-ci via les liens
hypertexte,
pas de problème les liens visités deviennent en mauve. Par contre, quand
nous
naviguons dans cette documentation via les boutons en bas de page, les
liens
visités restent en bleu. Pourquoi? Cela fonctionnait bien avec IE 6.

Par contre, j'ai lu que quelqu'un a eu le même genre de problème (
http://www.technologyquestions.com/technology/internet-explorer/121517-visited-hyperlink-color-not-changing-ie7-javascript-link.html),
mais aucune solution n'est proposée. Il semblerait que c'est un problème
avec
les boutons en JAVA. En effet, le site de la documentation proposée plus
haut
contient des boutons en JAVA.

Comment faire pour corriger la situation?

Merci,


sep_ghis
Le #16476991
Merci d'avoir répondu, mais je m'en doutais bien. Mais, pourquoi ça réagit
comme ça? Pourquoi ça fonctionne bien avec IE 6 et ça ne fonctionne plus avec
IE 7? Il doit y avoir une raison?

Merci,


"Bernard Lempel" a écrit :

Bonjour,

Le problème n'est pas dans ton navigateur.
C'est le site visité qui est conçu ainsi.

Au revoir.
Bernard Lempel
http://lempel.net

"sep_ghis" news:
> Bonjour,
>
> Depuis que j'ai IE 7, j'ai remarqué ceci:
>
> Les liens hypertextes d'une page web principale ne deviennent pas en mauve
> lorsqu'on clique sur les boutons de navigation prévus dans les bas de
> pages.
> (EX:
> http://www.novell.com/documentation/zenworks65/index.html?page=/documentation/zenworks65/dmadmin/data/bssit9p.html)
>
> Dans le lien précédent, nous arrivons à une page principale d'une
> documentation, quand nous naviguons dans celle-ci via les liens
> hypertexte,
> pas de problème les liens visités deviennent en mauve. Par contre, quand
> nous
> naviguons dans cette documentation via les boutons en bas de page, les
> liens
> visités restent en bleu. Pourquoi? Cela fonctionnait bien avec IE 6.
>
> Par contre, j'ai lu que quelqu'un a eu le même genre de problème (
> http://www.technologyquestions.com/technology/internet-explorer/121517-visited-hyperlink-color-not-changing-ie7-javascript-link.html),
> mais aucune solution n'est proposée. Il semblerait que c'est un problème
> avec
> les boutons en JAVA. En effet, le site de la documentation proposée plus
> haut
> contient des boutons en JAVA.
>
> Comment faire pour corriger la situation?
>
> Merci,





MCI (ex do ré Mi chel la si do) [MVP]
Le #16478091
Bonsoir !

Sans doute que la gestion des CSS concernées a évoluée.

@+

Michel Claveau
Hans Le Roy
Le #16479061
Bonjour,

A mon avis il s'agit de la façon dont les adresses sont codées dans ce
site - et donc tu ne peux rien faire.

Les liens dans les pages contiennent des anchors (page.htm#abc) que ne
contiennent pas la navigation en bas de page (page.htm).

Amitiés

Hans

"sep_ghis" news:
Bonjour,

Depuis que j'ai IE 7, j'ai remarqué ceci:

Les liens hypertextes d'une page web principale ne deviennent pas en mauve
lorsqu'on clique sur les boutons de navigation prévus dans les bas de
pages.
(EX:
http://www.novell.com/documentation/zenworks65/index.html?page=/documentation/zenworks65/dmadmin/data/bssit9p.html)

Dans le lien précédent, nous arrivons à une page principale d'une
documentation, quand nous naviguons dans celle-ci via les liens
hypertexte,
pas de problème les liens visités deviennent en mauve. Par contre, quand
nous
naviguons dans cette documentation via les boutons en bas de page, les
liens
visités restent en bleu. Pourquoi? Cela fonctionnait bien avec IE 6.

Par contre, j'ai lu que quelqu'un a eu le même genre de problème (
http://www.technologyquestions.com/technology/internet-explorer/121517-visited-hyperlink-color-not-changing-ie7-javascript-link.html),
mais aucune solution n'est proposée. Il semblerait que c'est un problème
avec
les boutons en JAVA. En effet, le site de la documentation proposée plus
haut
contient des boutons en JAVA.

Comment faire pour corriger la situation?

Merci,


MCI (ex do ré Mi chel la si do) [MVP]
Le #16485131
Bonjour !


A la réflexion, il y a peut-être un moyen pour modifier l'aspect à la
volée.

Attention, c'est, peut-être, très légèrement tordu.

La démarche :
- ajouter un bouton, dans IE, qui va lancer un script
- ce script se connecte au contenu de la page, via le DOM
- une fois la page chargée, le script injecte de nouveaux styles
(conformes à tes désirs)
- ensuite, le même script modifie l'attribut "style" des éléments
"link", pour qu'ils utilisent les nouveaux styles

C'est tout. Certains appellent ça de l'injection HTML.

Une astuce (à ne pas trop diffuser), pour faciliter cette injection : on
peut passer par le protocole javascript: (c'est à dire mettre une
commande javascript dans l'URL (la barre d'adresse), en la faisant
précéder du mot "javascript:")


Ceci étant dit, je ne sais pas si le jeu vaut vraiment la chandelle.
Quoique, cela pourrait être assez formateur...


@-salutations

Michel Claveau
sep_ghis
Le #16490271
Merci tout le monde pour vos réponses. Ce que je tiens à savoir, c'est
pourquoi ça fonctionnait avec IE 6 et maintenant ça ne fonctionne plus avec
IE 7? Il doit y avoir une raison pourquoi IE 7 réagit d'une telle façon?
Est-ce une question de sécurité, une amélioration (permettez moi de rire) ou
bien est-ce un bug? Si oui, existe-t-il une documentation?

Merci encore!
BYe,


"MCI (ex do ré Mi chel la si do) [MVP]" a écrit :

Bonjour !


A la réflexion, il y a peut-être un moyen pour modifier l'aspect à la
volée.

Attention, c'est, peut-être, très légèrement tordu.

La démarche :
- ajouter un bouton, dans IE, qui va lancer un script
- ce script se connecte au contenu de la page, via le DOM
- une fois la page chargée, le script injecte de nouveaux styles
(conformes à tes désirs)
- ensuite, le même script modifie l'attribut "style" des éléments
"link", pour qu'ils utilisent les nouveaux styles

C'est tout. Certains appellent ça de l'injection HTML.

Une astuce (à ne pas trop diffuser), pour faciliter cette injection : on
peut passer par le protocole javascript: (c'est à dire mettre une
commande javascript dans l'URL (la barre d'adresse), en la faisant
précéder du mot "javascript:")


Ceci étant dit, je ne sais pas si le jeu vaut vraiment la chandelle.
Quoique, cela pourrait être assez formateur...


@-salutations

Michel Claveau





MCI (ex do ré Mi chel la si do) [MVP]
Le #16492241
Re !

existe-t-il une documentation?



http://www.w3.org/TR/REC-html40/present/styles.html


@-salutations
--
Michel Claveau
Publicité
Poster une réponse
Anonyme