Lifelines 3.0.61

Le
Bernard
Bonjour à tous,

Je viens d'installer le package 'Lifelines' (logiciel de généalogie) sur
mes deux systèmes (desktop sous Sarge et laptop sous Etch). La version
disponible pour l'un et l'autre est la 3.0.50 or il y a sur cette
version un bug Dans la liste de genealogie software, il m'a été
recommandé de passer à la version 3.0.61. Celle ci est disponible dans
les debian packages pour Lenny, auxquels je pourrais accéder en
modifiant mon fichier /etc/apt/sources.list. Mais est-ce bien
raisonnable à votre avis ? Peut-être y a-t-il des risques de problèmes
ou conflits, au cas où l'architecture des répertoires serait différente
entre les deux versions ? Aurais-je plutôt avantage à télécharger une
version à compiler sur mon système, comme je l'avais fait il y a de cela
quelques années avec Lifelines 3.0.2 sous RedHat 7.2 ?

Merci d'avance pour vos avis et recommandations

Bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain Sauvage
Le #17854331
Bernard, samedi 15 novembre 2008, 18:00:12 CET

Bonjour à tous,



’jour,

Je viens d'installer le package 'Lifelines' (logiciel de
généalogie) sur mes deux systèmes (desktop sous Sarge et
laptop sous Etch).



Petit note au passage : tu pourrais mettre à jour ta Sarge en
Etch (Sarge n’est plus maintenu)…

La version disponible pour l'un et l'autre
est la 3.0.50... or il y a sur cette version un bug... Dans la
liste de genealogie software, il m'a été recommandé de pas ser
à la version 3.0.61. Celle ci est disponible dans les debian
packages pour Lenny, auxquels je pourrais accéder en modifiant
mon fichier /etc/apt/sources.list. Mais est-ce bien
raisonnable à votre avis ? Peut-être y a-t-il des risques de
problèmes ou conflits, au cas où l'architecture des
répertoires serait différente entre les deux versions ?
Aurais-je plutôt avantage à télécharger une version à compiler
sur mon système, comme je l'avais fait il y a de cela quelques
années avec Lifelines 3.0.2 sous RedHat 7.2 ?



Étant donné que Lifelines ne dépend que de la libc6 et
libncursesw5, une compilation ne devrait poser aucun problème.
Donc une compilation à la Debian :

Dans ton sources.list, mets les lignes deb-src sur testing (ou
lenny) (si tu n’as pas de ligne deb-src, ce sont les mêmes que
les deb sauf qu’elles commencent par deb-src et qu’elles
permettent de récupérer les sources des paquets).

En root (ou sudo…) :
# apt-get -s build-dep lifelines
te donnera la liste (un peu excessive mais complète) des paquets
dont tu auras besoin.
Tu les installes avec l’outil que tu préfères (aptitude …) et
tu pourras les désinstaller après coup.

Tu auras aussi besoin de fakeroot (ou alors tu fais la
compilation en root (ouh, c’est pas bien)).

En utilisateur normal :
$ apt-get source lifelines
$ cd lifelines-*
$ dpkg-buildpackage -rfakeroot -us -uc
$ cd ..

En root (ou sudo…) :
# dpkg -i lifelines*deb

Et voilà, un paquet local (donc gestion comme les autres, sauf
qu’il sera indiqué Obsolète/Local dans aptitude et cie).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Xavier Brochard
Le #17854321
Le samedi 15 novembre 2008 18:00:12 Bernard, vous avez écrit :
Je viens d'installer le package 'Lifelines' (logiciel de généalogie) sur
mes deux systèmes (desktop sous Sarge et laptop sous Etch). La version
disponible pour l'un et l'autre est la 3.0.50... or il y a sur cette
version un bug... Dans la liste de genealogie software, il m'a été
recommandé de passer à la version 3.0.61. Celle ci est disponible dans
les debian packages pour Lenny, auxquels je pourrais accéder en
modifiant mon fichier /etc/apt/sources.list. Mais est-ce bien
raisonnable à votre avis ? Peut-être y a-t-il des risques de probl èmes
ou conflits, au cas où l'architecture des répertoires serait différ ente
entre les deux versions ? Aurais-je plutôt avantage à télécharge r une
version à compiler sur mon système, comme je l'avais fait il y a de c ela
quelques années avec Lifelines 3.0.2 sous RedHat 7.2 ?



je complète ma réponse:
si tu compile à partir des sources sur htttp://lifelines.sf.net
utilise checkinstall pour gérer ton programme comme un paquet Debian.
Checkinstall n'est pas dans Etch, tu peux le trouver ici
deb http://boisson.homeip.net/debian etch divers
apparemment il faut le lancer avec l'option --fstrans=no pour contourner un
bug.

--
Xavier


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme