(Lin)modem du Toshiba Satellite P200

Le
JKB
Bonjour à tous,

Considérons le Toshiba Satellite P200 modèle 1DE. Ce sale truc est
muni d'un modem interne que j'essaye de faire fonctionner depuis ce
matin sans succès, malgré beaucoup avoir beaucoup rtfmé et
googlisé

lspci ne voit rien. lshw non plus. Par contre, il y a deux cartes
son, donc je subodore que l'une d'elles est un modem soft :

Root cauchy:[~] > ls /proc/asound/
card0 cards HDMI Intel oss seq version
card1 devices hwdep modules pcm timers
Root cauchy:[~] >

Le son fonctionne parfaitement sur cette machine si j'indique :
options snd-hda-intel model=toshiba
dans le fichier /etc/modprobe.d/alsa-base

Sinon, j'ai simplement le droit au klaxon traditionnel du PC d'il y
a presque trente ans..

J'ai essayé de compiler les modules suivants :
* slmodem-2.9.11-20080629

Compilation terminant par un FATAL: modpost quelque chose qui
provient certainement d'une erreur plus haut dans le makefile :

/bin/sh: line 0: [: 26/build: integer expression expected

* slusb64bit-2.9.11-20070813

Qui plante sur un superbe :
make[3]: entrant dans le répertoire « /usr/src/linux-2.6.26 »
CC [M] /home/bertrand/modem/slusb64bit-2.9.11-20070813/drivers/st7554.o
LD [M] /home/bertrand/modem/slusb64bit-2.9.11-20070813/drivers/slusb.o
Building modules, stage 2.
MODPOST 1 modules
FATAL: modpost: GPL-incompatible module slusb.ko uses GPL-only symbol
'usb_unlink_urb'

Question à deux cents balles Y a-t-il moyen de faire fonctionner
ce #@{[^~@{^[@~{[^ de modem ? Sinon, est-il possible d'utiliser un
adaptateur express card/pcmcia qui accepterait un modem pcmcia ? Je
n'ai pas de modem express card

Cordialement,

JKB

--
Le cerveau, c'est un véritable scandale écologique. Il représente 2% de notre
masse corporelle, mais disperse à lui seul 25% de l'énergie que nous
consommons tous les jours.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #16372371
JKB wrote in message
Root cauchy:[~] > ls /proc/asound/



cat /proc/asound/cards

/bin/sh: line 0: [: 26/build: integer expression expected



Probablement un script écrit avec des bashismes, alors que ton /bin/sh n'est
pas bash.

Ceci dit, si ton modem est reconnu par ALSA, tu n'as pas besoin de modules
noyau supplémentaires, tu peux te contenter de slmodemd (que je n'ai pas
réussi à faire fonctionner avec mon modem ALSA, mais je n'ai pas essayé très
sérieusement encore).
JKB
Le #16372751
Le 19-07-2008, à propos de
Re: (Lin)modem du Toshiba Satellite P200,
Nicolas George écrivait dans fr.comp.os.linux.configuration :
JKB wrote in message
Root cauchy:[~] > ls /proc/asound/



cat /proc/asound/cards



cauchy:[~] > cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf4700000 irq 22
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xf4010000 irq 17

/bin/sh: line 0: [: 26/build: integer expression expected



Probablement un script écrit avec des bashismes, alors que ton /bin/sh n'est
pas bash.

Ceci dit, si ton modem est reconnu par ALSA, tu n'as pas besoin de modules
noyau supplémentaires, tu peux te contenter de slmodemd (que je n'ai pas
réussi à faire fonctionner avec mon modem ALSA, mais je n'ai pas essayé très
sérieusement encore).



Nous sommes bien d'accord. Maintenant, ce que je trouve bizarre,
c'est que nulle part n'apparaît 'modem' dans la configuration
d'ALSA. Et si quelqu'un a réussi à faire fonctionner ce truc, qu'il
se manifeste ;-)

JKB

--
Le cerveau, c'est un véritable scandale écologique. Il représente 2% de notre
masse corporelle, mais disperse à lui seul 25% de l'énergie que nous
consommons tous les jours.
Nicolas George
Le #16372901
JKB wrote in message
cauchy:[~] > cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf4700000 irq 22
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xf4010000 irq 17




Bon, ben non, pas de chance, ta carte n'est pas reconnue par ALSA. Il va
falloir chercher ailleurs.
Jean Bon (de Parme)
Le #16373111
On Sat, 19 Jul 2008 21:19:06 +0000 (UTC), JKB

Nous sommes bien d'accord. Maintenant, ce que je trouve bizarre,
c'est que nulle part n'apparaît 'modem' dans la configuration
d'ALSA. Et si quelqu'un a réussi à faire fonctionner ce truc, qu'il
se manifeste ;-)



Parce que c'est pas un modem. C'est simplement une carte son branché
sur un port (pci ?) dont le processeur gere les entree/sortie.

http://www.linuxplusvalue.be/mylpv.php?id%4
JKB
Le #16373781
Le 19-07-2008, à propos de
Re: (Lin)modem du Toshiba Satellite P200,
Nicolas George écrivait dans fr.comp.os.linux.configuration :
JKB wrote in message
cauchy:[~] > cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf4700000 irq 22
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xf4010000 irq 17




Bon, ben non, pas de chance, ta carte n'est pas reconnue par ALSA. Il va
falloir chercher ailleurs.



Juste une question. Un modem, même non reconnu devrait apparaître
dans la sortie de lspci, non ? Sur tous mes portables précédents,
c'était le cas. Ici, la sortie de lspci donne :

Root cauchy:[/proc/asound] > lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory
Controlle
r Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI
Express Root
Port (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controll
er #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controll
er #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI
Control
ler #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio
Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express
Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express
Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express
Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express
Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2
EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface
Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E)
IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E)
SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller
(rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M76 [Radeon
Mobility HD 2600 Series]
01:00.1 Audio device: ATI Technologies Inc RV630/M76 audio device
[Radeon HD 2600 Series]
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E
PCI Express Fast Ethernet controller (rev 01)
05:00.0 Network controller: Atheros Communications Inc. AR5418
802.11abgn Wireless PCI Express Adapter (rev 01)
06:00.0 Memory controller: Intel Corporation Turbo Memory Controller
(rev 01)
0c:04.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
0c:04.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant
IEEE 1394 Host Controller
0c:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia
Card Reader (SD/MMC/MS/MS PRO/xD)
0c:04.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard
Compliant SD Host Controller
Root cauchy:[/proc/asound] >

Où serait ce fichu modem ?

JKB

--
Le cerveau, c'est un véritable scandale écologique. Il représente 2% de notre
masse corporelle, mais disperse à lui seul 25% de l'énergie que nous
consommons tous les jours.
Nicolas George
Le #16374441
JKB wrote in message
Juste une question. Un modem, même non reconnu devrait apparaître
dans la sortie de lspci, non ? Sur tous mes portables précédents,
c'était le cas. Ici, la sortie de lspci donne :



Pas forcément. Il pourrait être connecté en ISA (sur cette machine, j'ai des
doutes) ou en USB (pas impossible, j'ai un contrôleur bluetooth qui est
connecté en USB internet). Et je suis sûr que les fabricants peuvent penser
à plein d'autres gags.
François Patte
Le #16374681
JKB a écrit :
Le 19-07-2008, à propos de
Re: (Lin)modem du Toshiba Satellite P200,
Nicolas George écrivait dans fr.comp.os.linux.configuration :
JKB wrote in message
cauchy:[~] > cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf4700000 irq 22
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xf4010000 irq 17



Bon, ben non, pas de chance, ta carte n'est pas reconnue par ALSA. Il va
falloir chercher ailleurs.



Juste une question. Un modem, même non reconnu devrait apparaître
dans la sortie de lspci, non ? Sur tous mes portables précédents,
c'était le cas. Ici, la sortie de lspci donne :

Root cauchy:[/proc/asound] > lspci

Où serait ce fichu modem ?



C'est un véritable problème, j'ai récemment configuré un portable Dell
avec le même genre de problème: en fait le modem se cachait dans les USB
devices....


J'utilise fedora: il y a un fichier /etc/sysconfig/hwconf où on trouve
les différents hard. Ca aide (par élimination)

Maintenant on peut faire bavarder un peu plus lspci en ajoutant -n ou -nn

J'ai un toshiba avec une carte modem/son qui fonctionne avec slmodem
(installé par rpm de chez livna). Si le modem existe et est reconnu par
slmodem, un "device" ttySL0 est créé au démarrage de slmodem: il suffit
alors d'indiquer /dev/ttySL0 comme adresse du modem.

Sur le Dell, j'ai un peu plus bataillé et, en fait, le modem fonctionne
avec des drivers connexant voir:

http://www.linuxant.com/drivers/hsf/full/downloads.php

Et trouver (éventuellement) son bonheur!


Enfin, une dernière(?) solution existe: installer ndiswrapper et faire
fonctionner le modem avec le driver win (sans doute fourni avec les
utilitaires donnés avec le portable ou sur le site Toshiba)

C'est un peu long et ingras à faire, bonne chance.

--
François Patte
Université Paris 5 - Paris
JKB
Le #16374951
Le 20-07-2008, à propos de
Re: (Lin)modem du Toshiba Satellite P200,
Nicolas George écrivait dans fr.comp.os.linux.configuration :
JKB wrote in message
Juste une question. Un modem, même non reconnu devrait apparaître
dans la sortie de lspci, non ? Sur tous mes portables précédents,
c'était le cas. Ici, la sortie de lspci donne :



Pas forcément. Il pourrait être connecté en ISA (sur cette machine, j'ai des
doutes) ou en USB (pas impossible, j'ai un contrôleur bluetooth qui est
connecté en USB internet). Et je suis sûr que les fabricants peuvent penser
à plein d'autres gags.



J'y avais déjà pensé... Mais rien non plus :

Root cauchy:[~] > lsusb
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 04f2:b008 Chicony Electronics Co., Ltd
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Root cauchy:[~] >

Le truc Chicony est la webcam.

JKB

--
Le cerveau, c'est un véritable scandale écologique. Il représente 2% de notre
masse corporelle, mais disperse à lui seul 25% de l'énergie que nous
consommons tous les jours.
JKB
Le #16375101
Le 20-07-2008, à propos de
Re: (Lin)modem du Toshiba Satellite P200,
François Patte écrivait dans fr.comp.os.linux.configuration :
JKB a écrit :
Le 19-07-2008, à propos de
Re: (Lin)modem du Toshiba Satellite P200,
Nicolas George écrivait dans fr.comp.os.linux.configuration :
JKB wrote in message
cauchy:[~] > cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf4700000 irq 22
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xf4010000 irq 17



Bon, ben non, pas de chance, ta carte n'est pas reconnue par ALSA. Il va
falloir chercher ailleurs.



Juste une question. Un modem, même non reconnu devrait apparaître
dans la sortie de lspci, non ? Sur tous mes portables précédents,
c'était le cas. Ici, la sortie de lspci donne :

Root cauchy:[/proc/asound] > lspci

Où serait ce fichu modem ?



C'est un véritable problème, j'ai récemment configuré un portable Dell
avec le même genre de problème: en fait le modem se cachait dans les USB
devices....


J'utilise fedora: il y a un fichier /etc/sysconfig/hwconf où on trouve
les différents hard. Ca aide (par élimination)

Maintenant on peut faire bavarder un peu plus lspci en ajoutant -n ou -nn

J'ai un toshiba avec une carte modem/son qui fonctionne avec slmodem
(installé par rpm de chez livna). Si le modem existe et est reconnu par
slmodem, un "device" ttySL0 est créé au démarrage de slmodem: il suffit
alors d'indiquer /dev/ttySL0 comme adresse du modem.

Sur le Dell, j'ai un peu plus bataillé et, en fait, le modem fonctionne
avec des drivers connexant voir:

http://www.linuxant.com/drivers/hsf/full/downloads.php

Et trouver (éventuellement) son bonheur!


Enfin, une dernière(?) solution existe: installer ndiswrapper et faire
fonctionner le modem avec le driver win (sans doute fourni avec les
utilitaires donnés avec le portable ou sur le site Toshiba)

C'est un peu long et ingras à faire, bonne chance.



J'ai trouvé ceci :

Root cauchy:[/etc/modprobe.d] > cat /proc/asound/card0/codec#1
Codec: LSI ID 1040
Address: 1
Vendor Id: 0x11c11040
Subsystem Id: 0x11790001
Revision Id: 0x100200
Modem Function Group: 0x1
Root cauchy:[/etc/modprobe.d] >

Donc un modem est bien reconnu comme une sous-partie d'une des deux
cartes son. Reste à savoir quoi faire de ce truc...

J'y retourne...

JKB

--
Le cerveau, c'est un véritable scandale écologique. Il représente 2% de notre
masse corporelle, mais disperse à lui seul 25% de l'énergie que nous
consommons tous les jours.
Nicolas George
Le #16375601
JKB wrote in message
Donc un modem est bien reconnu comme une sous-partie d'une des deux
cartes son. Reste à savoir quoi faire de ce truc...



C'est original. Qu'est-ce qu'il y a d'autre dans le répertoire
/proc/asound/card0 ?

Essaie de jouer avec « aplay -D hw:0,1 », jusqu'à arriver à jouer du son que
tu n'entends pas : ce serait peut-être bon signe.
Publicité
Poster une réponse
Anonyme