D-Link dwl-510 debian wheezy / rt2561

Le
Cyrille
Bonjour,
Je n'arrive pas à faire fonctionner ma carte wifi D-Link dwl-510 sous deb=
ian wheezy

lspci
01:00.0 Network controller: RaLink RT2561/RT61 rev B 802.11g


J'ai pourtant bien installé les firmware.

Voici le message de dmesg
[ 29.559439] rt61pci 0000:01:00.0: firmware: requesting rt2561.bin
[ 29.642111] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 34.709517] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 37.926165] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 38.107878] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 38.264616] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 41.516239] wlan0: direct probe to AP 5c:33:8e:cd:3c:7a (try 1)
[ 41.712078] wlan0: direct probe to AP 5c:33:8e:cd:3c:7a (try 2)
[ 41.912095] wlan0: direct probe to AP 5c:33:8e:cd:3c:7a (try 3)
[ 42.112065] wlan0: direct probe to AP 5c:33:8e:cd:3c:7a timed out
[ 80.724831] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 80.893101] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 84.750146] ADDRCONF(NETDEV_UP): wlan0: link is not ready

Donc à priori
[ 29.559439] rt61pci 0000:01:00.0: firmware: requesting rt2561.bin

Pourtant j'ai installé le paquet contenant ce fichier
root@debian:/home/tristan# dpkg -i /media/ecole/firmware-ralink_0.36+wheezy=
.1_all.deb
Sélection du paquet firmware-ralink précédemment désÃ=
©lectionné.
(Lecture de la base de données 48328 fichiers et répertoires d=
éjà installés.)
Dépaquetage de firmware-ralink (à partir de /firmware-ralink_0.3=
6+wheezy.1_all.deb)
Paramétrage de firmware-ralink (0.36+wheezy.1)
root@debian:/home/tristan# modprobe rt61pci


Et le fichier non trouvé en fait partie
root@debian:/home/tristan# modinfo rt61pci
filename: /lib/modules/2.6.32-5-686/kernel/drivers/net/wireless/rt2x0=
0/rt61pci.ko
license: GPL
firmware: rt2661.bin
firmware: rt2561s.bin
firmware: rt2561.bin
description: Ralink RT61 PCI & PCMCIA Wireless LAN driver.
version: 2.3.0
author: http://rt2x00.serialmonkey.com
srcversion: 58CB8FB9B8C50DC7068D2D6
alias: pci:v00001814d00000401sv*sd*bc*sc*i*
alias: pci:v00001814d00000302sv*sd*bc*sc*i*
alias: pci:v00001814d00000301sv*sd*bc*sc*i*
depends: rt2x00lib,rt2x00pci,eeprom_93cx6,crc-itu-t
vermagic: 2.6.32-5-686 SMP mod_unload modversions 686
parm: nohwcrypt:Disable hardware encryption. (bool)




Le module est bien chargé :
crc_itu_t 1035 1 rt61pci
ac97_bus 710 1 snd_ac97_codec
rt2x00pci 3773 1 rt61pci
rt2x00lib 19101 2 rt61pci,rt2x00pci


ça semble rouler côté réseau
root@debian:/home/tristan# ifconfig
eth0 Link encap:Ethernet HWaddr 00:0e:a6:f0:a8:f9
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:118 errors:0 dropped:0 overruns:0 frame:0
TX packets:118 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:8172 (7.9 KiB) TX bytes:8172 (7.9 KiB)

wlan0 Link encap:Ethernet HWaddr 00:19:5b:78:c9:7f
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)



Par contre iwlist scanning ne me retourne rien, bien entendu

Le kernel c'est 2.6.32.


Une piste ? Des idées ?

Merci d'avance

Cyrille

-

[ cyrille@cbiot.fr | http://cbiot.fr ]


"Ils ne me comprennent point,
je ne suis pas la bouche qui convient à ces oreilles"
- - - Ainsi parlait Zarathoustra - - -
- - - - - - - - - - - NIETZSCHE - - -

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20130203091211.37e2a348be6f6ed2b00248a3@cbiot.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal Hambourg
Le #25195632
Cyrille a écrit :

Donc à priori
[ 29.559439] rt61pci 0000:01:00.0: firmware: requesting rt2561.bin

Pourtant j'ai installé le paquet contenant ce fichier



Il n'y a pas de message d'erreur donc le firmware a bien été chargé.
Dans le cas contraire l'interface réseau wlan0 ne serait même pas créée.

Le kernel c'est 2.6.32.



Sur Wheezy ? C'est la version de Squeeze, ça. Wheezy a un noyau 3.2.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Cyrille
Le #25195662
Sur Wheezy ? C'est la version de Squeeze, ça. Wheezy a un noyau 3.2.


Exact comme un âne j'ai mal inscrit les CD de mes ISO !
C'est donc une stable.
En fait je suis finalement parvenu à l'installer, via un cable RJ 45 mais le signal est très très faible.
J'ai retrouvé une netgear WN1100 qui fait très bien l'affaire , désol é pour le dérangement.


----

[ | http://cbiot.fr ]


"Ils ne me comprennent point,
je ne suis pas la bouche qui convient à ces oreilles"
- - - Ainsi parlait Zarathoustra - - -
- - - - - - - - - - - NIETZSCHE - - -

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme