linux-kbuild-3.1.0

Le
garnier
Bonjour,

J'essaye de passer mon noyau en 3.1.0 (epérimental) et je suis bloqué à
l'installation du pilote proprio de ATI :
manque linux-kbuild-3.1.0 que je ne trouve dans aucun dép^ot.
Existe t'il une solution pour faire croire au système que
linux-kbuild-3.0.0 est en fait linux-kbuild-3.1.0 ?
Bonne ou mauvaise idée, faisable ? Autre solution ?

Merci par avance

JC GARNIER

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/1318784801.23561.8.camel@garnier-PC-asus
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
garnier
Le #23876851
Le lundi 17 octobre 2011 à 13:53 +0200, Antoine a écrit :
Le 16/10/2011 19:06, garnier a écrit :
> manque linux-kbuild-3.1.0 que je ne trouve dans aucun dépôt
Des instructions existent pour le construire:
http://wiki.debian.org/HowToRebuildAnOfficialDebianKernelPackage#Thestoryoflinux-kbuild-2.6
avec notamment le script build-linux-kbuild.sh

Ce dernier a été conçu avant le passage en 3.x (contre 2.6.x)
les outils genorig.py et gencontrol.py ne sont plus dans
svn://svn.debian.org/kernel/dists/trunk/linux-kbuild-2.6 mais dans
svn://svn.debian.org/kernel/dists/trunk/linux-tools, mais s'attendent à
une structure de la forme linux-x.x.x, or pour l'instant on en est
encore à du linux-x.x (3.1)

J'en avais besoin récemment et j'ai donc modifié ce script, Cf en pj
build-linux-kbuild.3.x.sh
librement - antoine


Bonsoir,

Merci pour ta réponse et le script.
Mais je n'arrive pas jusqu'au bout : il semblerait qu'il faille que
j'upgrade python mais ça me désinstallerait les 3/4 du système et j'ai
peur de basculer en expérimental.
-------------
./build-linux-kbuild.3.x.sh: 63: ./build-linux-kbuild.3.x.sh: dch: not
found
genorig.py
Using source name linux-tools, version 3.1.0~rc9, dfsg 0
Extracting tarball ../linux-3.1.0-rc4.tar.bz2
Traceback (most recent call last):
File "./debian/bin/genorig.py", line 199, in <module>
Main(args, options.override_version, options.override_tag)()
File "./debian/bin/genorig.py", line 79, in __call__
self.upstream_extract(self.input_files[0])
File "./debian/bin/genorig.py", line 117, in upstream_extract
os.rename(os.path.join(self.dir, match.group('dir')),
os.path.join(self.dir, 'temp'))
OSError: [Errno 2] No such file or directory

dpkg-checkbuilddeps : dépendances de construction non trouvées :
python-dev
--------------------------------
Je préfère rester en stable/testing avec pining donc je repasse en
3.0.0. Dommage !
A moins qu'une autre solution existe ?

Merci encore,

JC


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Antoine
Le #23877221
bonsoir,
Le 17/10/2011 21:07, garnier a écrit :
./build-linux-kbuild.3.x.sh: 63: ./build-linux-kbuild.3.x.sh: dch: not
found


l'outil dch (debchange) fait partie du paquet devscripts et sert à
ajouter une nouvelle ligne de commentaire au fichier debian/change‐log
dans le répertoire des sources
dpkg-checkbuilddeps : dépendances de construction non trouvées :
python-dev
--------------------------------
Je préfère rester en stable/testing avec pining donc je repasse en
3.0.0. Dommage !
A moins qu'une autre solution existe ?


ré-essayer en installant devscripts + python-dev de stable ?
antoine

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme