Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Hugolino
Le #25685422
On 2013-09-25, Hugolino
Yo!

Sur une Linux Mint 15 fraichement install
Sébastien Kirche
Le #25685442
Le 26 septembre 2013 à 01:20, Hugolino s'est exprimé ainsi :

Salut Hugo,

Juste hallucinant: En lecture avec le m.me slrn qui vient de le
poster, ce message voit ses e accent aigu remplac. par <E9> et a
accent aigu par <E0>, mais en .dition pour y r.pondre, les
accents apparaissent correctement.



De mémoire E9 c'est le 'é' (lire : &eacute; ou e accent aigü) en
iso8859-1 / latin1 (ou -15), par ailleurs je vois dans tes entêtes que tu es
censé poster de l'utf-8, et qu'en réalité c'est du latin-1 (en regardant
le texte du message brut).

Je hais cette histoire d'encodage...



:)

--
Sébastien Kirche
Hugolino
Le #25685502
On 2013-09-25, Sébastien Kirche
Le 26 septembre 2013 à 01:20, Hugolino s'est exprimé ainsi :

Salut Hugo,

> Juste hallucinant: En lecture avec le m.me slrn qui vient de le
> poster, ce message voit ses e accent aigu remplac. par <E9> et a
> accent aigu par <E0>, mais en .dition pour y r.pondre, les
> accents apparaissent correctement.

De mémoire E9 c'est le 'é' (lire : &eacute; ou e accent aigü) en
iso8859-1 / latin1 (ou -15), par ailleurs je vois dans tes entêtes que tu es
censé poster de l'utf-8, et qu'en réalité c'est du latin-1 (en regardant
le texte du message brut).



Oui, tu as raison, je viens de le vérifier par un file sur le fichier
381 qui contient mon message dans /var/spool/news/fr/comp/os/linux/configuration
381: news, ISO-8859 text

> Je hais cette histoire d'encodage...

:)



OK...

J'avais un "set fileencodings=utf-8,iso-8859-15,iso-8859-1" qui traînait
dans mon ~/.vimrc, je corrige en "set fileencodings=utf-8" avant
d'écrire ce message, et on voit.


--
$ grep -R fuck linux-2.6.15/* | wc -l
48
Hugo (n? il y a 1 559 607 474 secondes)
Hugolino
Le #25685522
On 2013-09-26, Hugolino
On 2013-09-25, Sébastien Kirche > Le 26 septembre 2013 à 01:20, Hugolino s'est exprimé ainsi :
>
> Salut Hugo,
>
> > Juste hallucinant: En lecture avec le m.me slrn qui vient de le
> > poster, ce message voit ses e accent aigu remplac. par <E9> et a
> > accent aigu par <E0>, mais en .dition pour y r.pondre, les
> > accents apparaissent correctement.
>
> De mémoire E9 c'est le 'é' (lire : &eacute; ou e accent aigü) en
> iso8859-1 / latin1 (ou -15), par ailleurs je vois dans tes entêtes que tu es
> censé poster de l'utf-8, et qu'en réalité c'est du latin-1 (en regardant
> le texte du message brut).

Oui, tu as raison, je viens de le vérifier par un file sur le fichier
381 qui contient mon message dans /var/spool/news/fr/comp/os/linux/configuration
381: news, ISO-8859 text

> > Je hais cette histoire d'encodage...
>
> :)

OK...

J'avais un "set fileencodings=utf-8,iso-8859-15,iso-8859-1" qui traînait
dans mon ~/.vimrc, je corrige en "set fileencodings=utf-8" avant
d'écrire ce message, et on voit.



Très bizarrement, ce message auquel je réponds maintenant est le 386, et
$ file 386 raconte:
386: news, ISO-8859 text

Mais les accents sont maintenant correctement traités... pour moi en
tout cas. Je ne sais pas ce qu'il en est pour ceux qui me lisent.

On avance peut-être...


--
Ils doivent se dire que si le commercial l'a vendu sans savoir de quoi
ca parle, tu dois pouvoir le faire de la meme maniere.
Hugo (n? il y a 1 559 612 699 secondes)
Sébastien Kirche
Le #25685642
Le 26 septembre 2013 à 02:52, Hugolino s'est exprimé ainsi :

Très bizarrement, ce message auquel je réponds maintenant est le 386,
et $ file 386 raconte: 386: news, ISO-8859 text

Mais les accents sont maintenant correctement traités... pour moi en
tout cas. Je ne sais pas ce qu'il en est pour ceux qui me lisent.

On avance peut-être...



Et pourtant, elle tou^W^W ce coup-ci tes entêtes indiquent utf-8 et le
contenu brut le confirme. Les accents 'é' ne trompent pas.

Je ne pratique pas slrn, mais il y a peut-être édition avec un charset,
puis conversion dans un autre quand tu postes le message ?

--
Sébastien Kirche
Doug713705
Le #25685812
Le 26-09-2013, Sébastien Kirche nous expliquait dans
fr.comp.os.linux.configuration :

Je ne pratique pas slrn, mais il y a peut-être édition avec un charset,
puis conversion dans un autre quand tu postes le message ?



Tout à fait.

Pour ma part j'ai dans mon .slrnrc les options suivantes :

charset display utf8

charset editor "utf-8"

charset outgoing "iso-8859-15,utf-8"

De cette manière j'affiche et édite en utf-8 (tout mon système est en
utf-8, je n'ai pas de raison de faire autrement) mais j'envoie en
iso-8859-15 _sauf_ si au moins un des caractères du message que
j'envoie ne fait pas partie de ce jeu de caractères auquel cas slrn
bascule automatiquement vers utf-8.

On peut mettre plusieurs jeux de caractères à la suite, c'est pratique
pour ceux qui écrivent en japonais mais également en russe et en
chinois. Slrn se chargeant de tout de lui même.

Notez la différence d'écriture d'utf8 sans guillements ni tiret pour
display (je ne me rapelle pas pourquoi).

--
Doug - Linux user #307925 - Slackware64 roulaize ;-)
Without freedom of choice there is no creativity.
-- Kirk, "The return of the Archons", stardate 3157.4
Olivier Miakinen
Le #25685722
Le 26/09/2013 02:49, Hugolino a écrit :

J'avais un "set fileencodings=utf-8,iso-8859-15,iso-8859-1" qui traînait
dans mon ~/.vimrc, je corrige en "set fileencodings=utf-8" avant
d'écrire ce message, et on voit.



C'est exactement ça. Ton vim sauvait le fichier en ISO-8859-1 (ou
-15, les accents employés ne me permettant pas de distinguer l'un
de l'autre), et ton slrn annonçait de l'UTF-8. Maintenant ton vim
sauve le fichier en UTF-8 et ton slrn annonce toujours UTF-8.
Hugolino
Le #25686752
On 2013-09-26, Olivier Miakinen
Le 26/09/2013 02:49, Hugolino a écrit :

> J'avais un "set fileencodings=utf-8,iso-8859-15,iso-8859-1" qui
> traînait dans mon ~/.vimrc, je corrige en "set fileencodings=utf-8"
> avant d'écrire ce message, et on voit.

C'est exactement ça. Ton vim sauvait le fichier en ISO-8859-1 (ou
-15, les accents employés ne me permettant pas de distinguer l'un
de l'autre), et ton slrn annonçait de l'UTF-8. Maintenant ton vim
sauve le fichier en UTF-8 et ton slrn annonce toujours UTF-8.



OK...
En fait, ce qui me génait pour trouver la solution, c'est qu'avec la
version 14 de Linux Mint que j'utilisais jusqu'alors, ça n'aurait pas dû
fonctionner correctement ;-))

Merci à toi, ainsi qu'à Sébastien et Doug, dont je copie les trois
lignes de config dans mon .slrnrc: ceinture et bretelle !!


--
,--. ,= ,-_-. =.
/ ,- ) ((_/)o o(_))
`-' Debian, a variant of the GNU operating system `-'(. .)`-'
`-. _/
Publicité
Poster une réponse
Anonyme