Liste déroulante avec saisie semi automatique pour EXCEL pour les nombres

Le
Voici une procédure publié gbinforme que je remercie en passant qui marche
parfaitement pour les lettres

la première valeur de la liste se nomme "d_noms"
la colonne de la liste se nomme "c_noms".

formule nommée, afin de délimiter la zone renseignée de la liste : "l_noms"
la formule ÞCALER(d_noms;0;0;NBVAL(c_noms)-1;1)

formule dans l'onglet de validation :
=SI(A1<>"";DECALER(d_noms;EQUIV(A1&"*";l_noms;0)-1;;SOMME((STXT(l_noms;1;NBCAR(A1))=TEXTE(A1;"0"))*1));l_noms)

Je ne suis pas arrivé à transformer cette formule pour que la solution soit
aussi pour une liste de nombres.

Auriez vous une idée ? Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #18961001
Bonjour,

Formatter la colonne en texte

ÞCALER(Nombres;EQUIV(A2&"*";Nombres;0)-1;;NB.SI(Nombres;A2&"*"))

http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#premlettres
http://boisgontierjacques.free.fr/fichiers/DonneesValidation/DVPremiersChif fres.xls

JB
http://boisgontierjacques.free.fr

On 23 mar, 10:52, wrote:
Voici une procédure publié gbinforme que je remercie en passant qui m arche
parfaitement pour les lettres

la première valeur de la liste se nomme "d_noms"
la colonne de la liste se nomme "c_noms".

formule nommée, afin de délimiter la zone renseignée de la liste  : "l_noms"
la formule ÞCALER(d_noms;0;0;NBVAL(c_noms)-1;1)

formule dans l'onglet de validation :
=SI(A1<>"";DECALER(d_noms;EQUIV(A1&"*";l_noms;0)-1;;SOMME((STXT(l_noms; 1;NB­CAR(A1))=TEXTE(A1;"0"))*1));l_noms)

Je ne suis pas arrivé à transformer cette formule pour que la solutio n soit
aussi pour une liste de nombres.

Auriez vous une idée ? Merci


Le #18961241
Merci

"JB"
Bonjour,

Formatter la colonne en texte

ÞCALER(Nombres;EQUIV(A2&"*";Nombres;0)-1;;NB.SI(Nombres;A2&"*"))

http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#premlettres
http://boisgontierjacques.free.fr/fichiers/DonneesValidation/DVPremiersChiffres.xls

JB
http://boisgontierjacques.free.fr

On 23 mar, 10:52, wrote:
Voici une procédure publié gbinforme que je remercie en passant qui marche
parfaitement pour les lettres

la première valeur de la liste se nomme "d_noms"
la colonne de la liste se nomme "c_noms".

formule nommée, afin de délimiter la zone renseignée de la liste :
"l_noms"
la formule ÞCALER(d_noms;0;0;NBVAL(c_noms)-1;1)

formule dans l'onglet de validation :
=SI(A1<>"";DECALER(d_noms;EQUIV(A1&"*";l_noms;0)-1;;SOMME((STXT(l_noms;1;NB­CAR(A1))=TEXTE(A1;"0"))*1));l_noms)

Je ne suis pas arrivé à transformer cette formule pour que la solution
soit
aussi pour une liste de nombres.

Auriez vous une idée ? Merci


Le #18970141
Bonjour,

http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#premlettres

cette méthode ne semble fonctionner qu'à la condition d'être dans ma même
feuille.

Est-ce exact ? et si oui, comment faire pour que la liste soit dans une
feuille que la validation
JB
Le #18971321
Bonsoir,

Naturellement, cette méthode fonctionne aussi lorsque la liste est
dans une autre feuille.

http://cjoint.com/?dAtde5vM2S

JB
On 24 mar, 16:26, wrote:
Bonjour,

http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#preml...

cette méthode ne semble fonctionner qu'à la condition d'être dans m a même
feuille.

Est-ce exact ? et si oui, comment faire pour que la liste soit dans une
feuille que la validation


Le #18978041
Merci,

"JB"
Bonsoir,

Naturellement, cette méthode fonctionne aussi lorsque la liste est
dans une autre feuille.

http://cjoint.com/?dAtde5vM2S

JB
On 24 mar, 16:26, wrote:
Bonjour,

http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#preml...

cette méthode ne semble fonctionner qu'à la condition d'être dans ma même
feuille.

Est-ce exact ? et si oui, comment faire pour que la liste soit dans une
feuille que la validation


Le #18978151
Puis-je vous poser une question toujours en rapport avec les listes.

Sur votre site il y une méthode pour élargir la colonne de la liste mais je
suis incapable de la comprendre .

Pour obtenir une liste plus large que la colonne
-Elargir la colonne
-Faire la liste
-Rétrécir la colonne

Merci

"JB"
Bonsoir,

Naturellement, cette méthode fonctionne aussi lorsque la liste est
dans une autre feuille.

http://cjoint.com/?dAtde5vM2S

JB
On 24 mar, 16:26, wrote:
Bonjour,

http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#preml...

cette méthode ne semble fonctionner qu'à la condition d'être dans ma même
feuille.

Est-ce exact ? et si oui, comment faire pour que la liste soit dans une
feuille que la validation


Publicité
Poster une réponse
Anonyme