Liste déroulante dans le formulaire fils avec comme filtre une valeur connue dans formulaire pere

Le
Fabien
Bonjour,
J'ai une liste dont la source de donnée (rowsource) est une requete.
Cette requête a un critère qui est une zone du formulaire père.
Si, lorsque le formulaire père est actif, je lance ma requête, c'est ok.
Si je déroule la liste qui est dans le formulaire fils , une msgbox
s'ouvre :
Entrez une valeur de paramètre
Formulaires!Clubs!N°Club
Comprend pas pourquoi d'un coté ça fonctionne et pas de l'autre.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jessy Sempere
Le #6192711
Bonjour

Essais peut-être d'encadre entre crochet le nom de ta zone :

Formulaires!Clubs![N°Club]

@+
Jessy Sempere
------------------------------------
Site @ccess : http://access.fr.free.fr/
Pour l''''efficacité de tous :
http://www.mpfa.info/
------------------------------------



Bonjour,
J'ai une liste dont la source de donnée (rowsource) est une requete.
Cette requête a un critère qui est une zone du formulaire père.
Si, lorsque le formulaire père est actif, je lance ma requête, c'est ok.
Si je déroule la liste qui est dans le formulaire fils , une msgbox
s'ouvre :
Entrez une valeur de paramètre
Formulaires!Clubs!N°Club
Comprend pas pourquoi d'un coté ça fonctionne et pas de l'autre.



Fabien
Le #6192071
Bonjour,
Bon ben ma seul solution a été de refaire entièrement mes formulaires.
Et comme refaire est toujours plus rapide que faire ...
Maintenant ça marche comme prévu ;-)
Merci
a+

Bonjour

Essais peut-être d'encadre entre crochet le nom de ta zone :

Formulaires!Clubs![N°Club]

@+
Jessy Sempere
------------------------------------
Site @ccess : http://access.fr.free.fr/
Pour l''''efficacité de tous :
http://www.mpfa.info/
------------------------------------



Bonjour,
J'ai une liste dont la source de donnée (rowsource) est une requete.
Cette requête a un critère qui est une zone du formulaire père.
Si, lorsque le formulaire père est actif, je lance ma requête, c'est ok.
Si je déroule la liste qui est dans le formulaire fils , une msgbox
s'ouvre :
Entrez une valeur de paramètre
Formulaires!Clubs!N°Club
Comprend pas pourquoi d'un coté ça fonctionne et pas de l'autre.





Publicité
Poster une réponse
Anonyme