Liste déroulante

Le
Jac
Bonjour à tous,

ce matin, je coince sur le problème suivant : une liste déroulante LD2
est conditionnée par la sélection faite dans la liste déroulante LD1.
Mais j'aimerais que la LD2 affiche tout si la LD1 est vide. Donc dans
la requête qui renvoie les valeurs de la LD2, j'ai mis comme critère :

VraiFaux([formulaires]![Menu]![LD1]<>"";[formulaires]![Menu]![LD1];Comme
"*")

Mais quand LD1 est vide LD2 n'affiche aucune valeur. J'ai essayé en
remplaçant <>"" par est pas null, mais ça ne change rien au résultat.

Merci d'avance à qui pourra corriger ce critère.

Jac
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Eric
Le #6567681
Bonjour Jac,

Soit ChampARestreindre le nom du champ sur lequel tu mets le critère
dans la requête, je mettrai:
VraiFaux([formulaires]![Menu]![LD1]<>"";[formulaires]![Menu]![LD1];[ChampARestreindre])

Bonjour à tous,

ce matin, je coince sur le problème suivant : une liste déroulante LD2
est conditionnée par la sélection faite dans la liste déroulante LD1.
Mais j'aimerais que la LD2 affiche tout si la LD1 est vide. Donc dans la
requête qui renvoie les valeurs de la LD2, j'ai mis comme critère :

VraiFaux([formulaires]![Menu]![LD1]<>"";[formulaires]![Menu]![LD1];Comme
"*")

Mais quand LD1 est vide LD2 n'affiche aucune valeur. J'ai essayé en
remplaçant <>"" par est pas null, mais ça ne change rien au résultat.

Merci d'avance à qui pourra corriger ce critère.

Jac




--
A+
Eric
http://www.mpfa.info/
Archives : http://groups.google.fr/group/microsoft.public.fr.access?hl=fr

Jac
Le #6568011
... effectivement, ça tombe sous le sens. Merci encore.

Bonjour Jac,

Soit ChampARestreindre le nom du champ sur lequel tu mets le critère dans la
requête, je mettrai:
VraiFaux([formulaires]![Menu]![LD1]<>"";[formulaires]![Menu]![LD1];[ChampARestreindre])

Bonjour à tous,

ce matin, je coince sur le problème suivant : une liste déroulante LD2 est
conditionnée par la sélection faite dans la liste déroulante LD1.
Mais j'aimerais que la LD2 affiche tout si la LD1 est vide. Donc dans la
requête qui renvoie les valeurs de la LD2, j'ai mis comme critère :

VraiFaux([formulaires]![Menu]![LD1]<>"";[formulaires]![Menu]![LD1];Comme
"*")

Mais quand LD1 est vide LD2 n'affiche aucune valeur. J'ai essayé en
remplaçant <>"" par est pas null, mais ça ne change rien au résultat.

Merci d'avance à qui pourra corriger ce critère.

Jac






Publicité
Poster une réponse
Anonyme