Liste déroulante

Le
Infogroup
Bonjour à tous,



Grâce à JB, j'ai pu établir une liste dynamique nommée Noms_02

Dans cette liste, j'ai des noms propres et des noms marqués "ZZ" qui sont
cachés par une mise en forme conditionnelle.



En R6, j'ai une liste déroulante avec Données Validation Liste et la formule
suivante :



ÞCALER(Noms_02;EQUIV($R6&"*";Noms_02;0)-1;;NB.SI(Noms_02;$R6&"*"))



qui permet de taper la 1ère lettre du nom pour ne faire apparaître que les
noms correspondants à cette 1ère lettre



Le problème est que si on ne tape pas la 1ère lettre tous les noms de la
liste Noms_02 apparaissent ( jusque là c'est normal ) mais je voudrais que
les noms en "ZZ" n'apparaissent pas.



Il faudrait intégrer la condition supplémentaire NB.SI(Noms_02;"<>ZZ"), mais
je n'arrive pas à l'incruster dans la formule DECALER



Merci pour votre aide



Cordialement



Infogroup
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #19001941
Bonsoir,

D'après ce que j'ai compris, il faut créer une autre liste sans les
zz

=SI(LIGNES($1:1)<=SOMMEPROD(--(GAUCHE(ListeOrig;2)<>"ZZ"));INDEX
(ListeOrig;PETITE.VALEUR(SI(GAUCHE(ListeOrig;2)<>"ZZ";LIGNE(INDIRECT
("1:"&LIGNES(ListeOrig))));LIGNES($1:1)));0)

http://cjoint.com/?dEt2YV6ptO

JB
http://boisgontierjacques.free.fr/

On 28 mar, 17:18, "Infogroup"
Bonjour à tous,

Grâce à JB, j'ai pu établir une liste dynamique nommée Noms_02

Dans cette liste, j'ai des noms propres et des noms marqués "ZZ" qui so nt
cachés par une mise en forme conditionnelle.

En R6, j'ai une liste déroulante avec Données Validation Liste et la formule
suivante :

ÞCALER(Noms_02;EQUIV($R6&"*";Noms_02;0)-1;;NB.SI(Noms_02;$R6&"*"))

qui permet de taper la 1ère lettre du nom pour ne faire apparaître qu e les
noms correspondants à cette 1ère lettre

Le problème est que si on ne tape pas la 1ère lettre tous les noms de la
liste Noms_02 apparaissent ( jusque là c'est normal ) mais je voudrais que
les noms en "ZZ" n'apparaissent pas.

Il faudrait intégrer la condition supplémentaire NB.SI(Noms_02;"<>ZZ" ), mais
je n'arrive pas à l'incruster dans la formule DECALER

Merci pour votre aide

Cordialement

Infogroup


Infogroup
Le #19002161
Merci JB, mais ça ne répond pas tout à fait à mon pb.

Je joints un fichier pour être plus clair.

http://www.cijoint.fr/cjlink.php?file=cj200903/cijAAleuo9.xls

Merci

Cdl

Infogroup






"JB" news:
Bonsoir,

D'après ce que j'ai compris, il faut créer une autre liste sans les
zz

=SI(LIGNES($1:1)<=SOMMEPROD(--(GAUCHE(ListeOrig;2)<>"ZZ"));INDEX
(ListeOrig;PETITE.VALEUR(SI(GAUCHE(ListeOrig;2)<>"ZZ";LIGNE(INDIRECT
("1:"&LIGNES(ListeOrig))));LIGNES($1:1)));0)

http://cjoint.com/?dEt2YV6ptO

JB
http://boisgontierjacques.free.fr/

On 28 mar, 17:18, "Infogroup"
Bonjour à tous,

Grâce à JB, j'ai pu établir une liste dynamique nommée Noms_02

Dans cette liste, j'ai des noms propres et des noms marqués "ZZ" qui sont
cachés par une mise en forme conditionnelle.

En R6, j'ai une liste déroulante avec Données Validation Liste et la
formule
suivante :

ÞCALER(Noms_02;EQUIV($R6&"*";Noms_02;0)-1;;NB.SI(Noms_02;$R6&"*"))

qui permet de taper la 1ère lettre du nom pour ne faire apparaître que les
noms correspondants à cette 1ère lettre

Le problème est que si on ne tape pas la 1ère lettre tous les noms de la
liste Noms_02 apparaissent ( jusque là c'est normal ) mais je voudrais que
les noms en "ZZ" n'apparaissent pas.

Il faudrait intégrer la condition supplémentaire NB.SI(Noms_02;"<>ZZ"),
mais
je n'arrive pas à l'incruster dans la formule DECALER

Merci pour votre aide

Cordialement

Infogroup


JB
Le #19002141
Modifier le nom de champ Pilotes_02:

ÞCALER($A$1;;;NB.SI($A$1:$A$30;"<>ZZ"))

http://cjoint.com/?dEuKqfR7NL

JB


On 28 mar, 19:16, "Infogroup"
Merci JB, mais ça ne répond pas tout à fait à mon pb.

Je joints un fichier pour être plus clair.

http://www.cijoint.fr/cjlink.php?file=cj200903/cijAAleuo9.xls

Merci

Cdl

Infogroup

"JB" Bonsoir,

D'après ce  que j'ai compris, il faut créer une autre liste sans le s
zz

=SI(LIGNES($1:1)<=SOMMEPROD(--(GAUCHE(ListeOrig;2)<>"ZZ"));INDEX
(ListeOrig;PETITE.VALEUR(SI(GAUCHE(ListeOrig;2)<>"ZZ";LIGNE(INDIRECT
("1:"&LIGNES(ListeOrig))));LIGNES($1:1)));0)

http://cjoint.com/?dEt2YV6ptO

JBhttp://boisgontierjacques.free.fr/

On 28 mar, 17:18, "Infogroup"


> Bonjour à tous,

> Grâce à JB, j'ai pu établir une liste dynamique nommée Noms_02

> Dans cette liste, j'ai des noms propres et des noms marqués "ZZ" qui sont
> cachés par une mise en forme conditionnelle.

> En R6, j'ai une liste déroulante avec Données Validation Liste et l a
> formule
> suivante :

> ÞCALER(Noms_02;EQUIV($R6&"*";Noms_02;0)-1;;NB.SI(Noms_02;$R6&"*"))

> qui permet de taper la 1ère lettre du nom pour ne faire apparaître que les
> noms correspondants à cette 1ère lettre

> Le problème est que si on ne tape pas la 1ère lettre tous les noms de la
> liste Noms_02 apparaissent ( jusque là c'est normal ) mais je voudrai s que
> les noms en "ZZ" n'apparaissent pas.

> Il faudrait intégrer la condition supplémentaire NB.SI(Noms_02;"<>Z Z"),
> mais
> je n'arrive pas à l'incruster dans la formule DECALER

> Merci pour votre aide

> Cordialement

> Infogroup- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


Infogroup
Le #19002431
Re-bonsoir JB,

cette fois tout est OK

merci mille fois et bonne soirée

Cdl

Infogroup


"JB" news:
Modifier le nom de champ Pilotes_02:

ÞCALER($A$1;;;NB.SI($A$1:$A$30;"<>ZZ"))

http://cjoint.com/?dEuKqfR7NL

JB


On 28 mar, 19:16, "Infogroup"
Merci JB, mais ça ne répond pas tout à fait à mon pb.

Je joints un fichier pour être plus clair.

http://www.cijoint.fr/cjlink.php?file=cj200903/cijAAleuo9.xls

Merci

Cdl

Infogroup

"JB" denews:
Bonsoir,

D'après ce que j'ai compris, il faut créer une autre liste sans les
zz

=SI(LIGNES($1:1)<=SOMMEPROD(--(GAUCHE(ListeOrig;2)<>"ZZ"));INDEX
(ListeOrig;PETITE.VALEUR(SI(GAUCHE(ListeOrig;2)<>"ZZ";LIGNE(INDIRECT
("1:"&LIGNES(ListeOrig))));LIGNES($1:1)));0)

http://cjoint.com/?dEt2YV6ptO

JBhttp://boisgontierjacques.free.fr/

On 28 mar, 17:18, "Infogroup"


> Bonjour à tous,

> Grâce à JB, j'ai pu établir une liste dynamique nommée Noms_02

> Dans cette liste, j'ai des noms propres et des noms marqués "ZZ" qui
> sont
> cachés par une mise en forme conditionnelle.

> En R6, j'ai une liste déroulante avec Données Validation Liste et la
> formule
> suivante :

> ÞCALER(Noms_02;EQUIV($R6&"*";Noms_02;0)-1;;NB.SI(Noms_02;$R6&"*"))

> qui permet de taper la 1ère lettre du nom pour ne faire apparaître que
> les
> noms correspondants à cette 1ère lettre

> Le problème est que si on ne tape pas la 1ère lettre tous les noms de la
> liste Noms_02 apparaissent ( jusque là c'est normal ) mais je voudrais
> que
> les noms en "ZZ" n'apparaissent pas.

> Il faudrait intégrer la condition supplémentaire NB.SI(Noms_02;"<>ZZ"),
> mais
> je n'arrive pas à l'incruster dans la formule DECALER

> Merci pour votre aide

> Cordialement

> Infogroup- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


Publicité
Poster une réponse
Anonyme