de LO vers Excel ...Help !

Le
AlainL
Bonjour,

Pour gérer une grosse liste de données, j'ai un programme en Libre
Office
Ce programme étant susceptible d'être utilisé par d'autres, je voudrais
le rendre accessible via Excel


Je récupère dans une colonne P Feui1 les indices des lignes non vides
d'une colonne N avec cette formule : =SI(O7="";"";LIGNE())
Ca marche avec Lo et Excel.

Je copie ces lignes sur Feuille 2 en éliminant les lignes vides.

Avec Libre Office cette formule fonctionne :
=SI(ESTERREUR(PETITE.VALEUR($Feuil1.$P$7:$P$22;LIGNE()-1));"";INDIRECT("Feuil1.N"&PETITE.VALEUR($Feuil1.$P$7:$P$22;LIGNE()-1)))

Mais Excel (enregistré depuis LO dans les différents formats Excel
proposés) me renvoie des #REF!
J'ai essayé plusieurs modifs de la plage en Feuille 1 mais je ne m'en
tire pas !
Help SVP !!!
Merci
alainL


L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
?K?
Le #26418461
Bonjour
D'après AlainL
Je copie ces lignes sur Feuille 2 en éliminant les lignes vides.
Avec Libre Office cette formule fonctionne :
=SI(ESTERREUR(PETITE.VALEUR($Feuil1.$P$7:$P$22;LIGNE()-1));"";INDIRECT("Feuil1.N"&PETITE.VALEUR($Feuil1.$P$7:$P$22;LIGNE()-1)))
Mais Excel (enregistré depuis LO dans les différents formats Excel proposés)
me renvoie des #REF!

normal ;-)
dans LO :
þuille2.A1
et dans excel
þuil2!A1
de plus
excel ne met jamais de dollars devant le nom de feuille
la formule suivante
=SI(ESTERREUR(PETITE.VALEUR(Feuil1!$P$7:$P$22;LIGNE()-1));"";INDIRECT("Feuil1!N"&PETITE.VALEUR(Feuil1!$P$7:$P$22;LIGNE()-1)))
ne ramène pas d'errur, reste à vérifier qu'elle fait bien ce que tu
veux
cdlt
--
-
AlainL
Le #26418497
Le 25/11/2016 à 17:04, ?K? a écrit :
Bonjour
D'après AlainL
Je copie ces lignes sur Feuille 2 en éliminant les lignes vides.

Avec Libre Office cette formule fonctionne :
=SI(ESTERREUR(PETITE.VALEUR($Feuil1.$P$7:$P$22;LIGNE()-1));"";INDIRECT("Feuil1.N"&PETITE.VALEUR($Feuil1.$P$7:$P$22;LIGNE()-1)))

Mais Excel (enregistré depuis LO dans les différents formats Excel
proposés) me renvoie des #REF!

normal ;-)
dans LO :
þuille2.A1
et dans excel
þuil2!A1
de plus
excel ne met jamais de dollars devant le nom de feuille
la formule suivante
=SI(ESTERREUR(PETITE.VALEUR(Feuil1!$P$7:$P$22;LIGNE()-1));"";INDIRECT("Feuil1!N"&PETITE.VALEUR(Feuil1!$P$7:$P$22;LIGNE()-1)))
ne ramène pas d'errur, reste à vérifier qu'elle fait bien ce que tu veux
cdlt


Impec ! Grand merci, j'ai galéré un bout de temps sur "$Feuil1.N" sans
remarquer réaliser que le . devait être remplacé par ! ... alors que
je l'avais fait dans le reste de la formule. La saturation peut-être !!!
Bonne soirée
alainL
---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus
Publicité
Poster une réponse
Anonyme