Localisation des drivers Microsoft

Le
Olivier
Bonjour à tous,

Suite a un problème avec un HP Pavillon DV9000. Je me permet de vous écrire
pour savoir si quelqu'un a une solution à mon problème.

Description du problème :
=

Normalement, si j'insère une clés USB dans ce portable. Le reconnaissance
est automatique par Windows Vista. Le problème est que Windows Vista me
réclame à chaque fois les drivers ( c'est une clés standard de marque
Kingston qui fonctionne très bien dans un Windows XP ou dans un autre système
Vista ). Je dois demandé à Vista de rechercher sur mon disque C: ( et
sous-répertoires ) le driver. Après 1 min, le driver est trouvé et est
installé. Je peux alors retiré cette clés et la remettre sans problème à
condition que je la replace dans la même porte USB sinon cela recommence.
J'ai le même problème avec l'imprimante, modem 3G, etc

Je sais que dans Windows XP, les drivers se situaient dans C:WINDOWSDriver
Cachei386 et que par défault Windows XP vérifiait ce folder pour l'existence
de driver. Cela ne semble pas le cas dans Windows Vista.

Quelqu'un peut-il me dire où se situent ces drivers et si il existe une clés
dans le registre qui signale à Windows Vista où chercher les drivers par
défault.

En rermerciant déjà d'avance, la communauté.

Olivier,
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ludo
Le #1016301
Bonjour,

Effectivement, quand tu installe un périphérique USB une première fois,
les pilotes vont s'installés normalement et seront reconnus
automatiquement à chaque utilisation de l'appareil. Seulement, si tu
change de port, windows Vista devra installer à nouveau les pilotes.

c'est sans doute normal compte tenu que j'ai la même chose chez moi.
Olivier
Le #1018312
Merci Ludo,

Je sais que Windows réinstall les drivers a chaque changement de porte.
Malheureusement, il doit le faire seul sans que l'utilisateur doit à chaque
fois spécifier le chemin. De plus, je reçois frequement des autres clés pour
le transfert de fichiers donc je suppose qu'il y a un problème dans le
registre mais où ???

Cordialement,
Olivier

"ludo" wrote:

Bonjour,

Effectivement, quand tu installe un périphérique USB une première fois,
les pilotes vont s'installés normalement et seront reconnus
automatiquement à chaque utilisation de l'appareil. Seulement, si tu
change de port, windows Vista devra installer à nouveau les pilotes.

c'est sans doute normal compte tenu que j'ai la même chose chez moi.



Mathieu VDA
Le #1052859
Bonjour,

après avoir remarqué le même type de problème avec mon imprimante, je me
suis aperçu en écumant les forums qui traitent du sujet sur internet que
Vista a un gros soucis d'installation des périphériques (USB et autres),
problème qui n'apparait pas à l'installation de Vista mais après quelques
temps d'utilisation (mise à jour défectueuse ?).
Exemples ici :
http://www.keroinsite.com/view/News/Informatique/Windows_Vista_:_La_solution_au_probleme_des_peripheriques_USB_non_reconnus?/
ou
http://blogs.developpeur.org/fabrice69/archive/2007/04/08/vista-probl-me-p-nible-avec-la-recherche-des-drivers-pour-les-p-riph-riques-usb.aspx

Il faut donc, lorsque Windows Vista réclame systématiquement les drivers
d'installation, lui indiquer le chemin sur le disque dur :
windowssystem32
Tous les fichiers .inf s'y trouvent, à condition que Vista les aient en
mémoire ou qu'ils aient été déjà installés une première fois.
Il faut parfois jongler entre le CD de driver du périphérique et ce
répertoire pour faire une installation correcte.
C'est lourd, surtout que pour un seul périphérique, il y a plusieurs
composants à installer.

Parfois, le problème est engendré par une corruption du fichier Incache.1.
Outre la suppression de ce fichier qui permet de résoudre le problème, il
semblerait qu'un correctif soit proposé par Microsoft :
http://www.touslesdrivers.com/index.php?v_page=3&v_code(85

Bon courage...

Mathieu




"Olivier" groupe de discussion :
Merci Ludo,

Je sais que Windows réinstall les drivers a chaque changement de porte.
Malheureusement, il doit le faire seul sans que l'utilisateur doit à
chaque
fois spécifier le chemin. De plus, je reçois frequement des autres clés
pour
le transfert de fichiers donc je suppose qu'il y a un problème dans le
registre mais où ???

Cordialement,
Olivier

"ludo" wrote:

Bonjour,

Effectivement, quand tu installe un périphérique USB une première fois,
les pilotes vont s'installés normalement et seront reconnus
automatiquement à chaque utilisation de l'appareil. Seulement, si tu
change de port, windows Vista devra installer à nouveau les pilotes.

c'est sans doute normal compte tenu que j'ai la même chose chez moi.





Rosseels Olivier
Le #1065417
Mathieu,

Je pense que cela va pouvoir beaucoup m'aider. Je vais éssayer cela ce
week-end. Un grand merci pour l'information.

Olivier


"Mathieu VDA" news:
Bonjour,

après avoir remarqué le même type de problème avec mon imprimante, je me
suis aperçu en écumant les forums qui traitent du sujet sur internet que
Vista a un gros soucis d'installation des périphériques (USB et autres),
problème qui n'apparait pas à l'installation de Vista mais après quelques
temps d'utilisation (mise à jour défectueuse ?).
Exemples ici :
http://www.keroinsite.com/view/News/Informatique/Windows_Vista_:_La_solution_au_probleme_des_peripheriques_USB_non_reconnus?/
ou
http://blogs.developpeur.org/fabrice69/archive/2007/04/08/vista-probl-me-p-nible-avec-la-recherche-des-drivers-pour-les-p-riph-riques-usb.aspx

Il faut donc, lorsque Windows Vista réclame systématiquement les drivers
d'installation, lui indiquer le chemin sur le disque dur :
windowssystem32
Tous les fichiers .inf s'y trouvent, à condition que Vista les aient en
mémoire ou qu'ils aient été déjà installés une première fois.
Il faut parfois jongler entre le CD de driver du périphérique et ce
répertoire pour faire une installation correcte.
C'est lourd, surtout que pour un seul périphérique, il y a plusieurs
composants à installer.

Parfois, le problème est engendré par une corruption du fichier Incache.1.
Outre la suppression de ce fichier qui permet de résoudre le problème, il
semblerait qu'un correctif soit proposé par Microsoft :
http://www.touslesdrivers.com/index.php?v_page=3&v_code(85

Bon courage...

Mathieu




"Olivier" groupe de discussion :

Merci Ludo,

Je sais que Windows réinstall les drivers a chaque changement de porte.
Malheureusement, il doit le faire seul sans que l'utilisateur doit à
chaque
fois spécifier le chemin. De plus, je reçois frequement des autres clés
pour
le transfert de fichiers donc je suppose qu'il y a un problème dans le
registre mais où ???

Cordialement,
Olivier

"ludo" wrote:

Bonjour,

Effectivement, quand tu installe un périphérique USB une première fois,
les pilotes vont s'installés normalement et seront reconnus
automatiquement à chaque utilisation de l'appareil. Seulement, si tu
change de port, windows Vista devra installer à nouveau les pilotes.

c'est sans doute normal compte tenu que j'ai la même chose chez moi.







Publicité
Poster une réponse
Anonyme