LUN RAID Non VU

Le
olivier.burelli
Bonsoir,


je rencontre le problème suivant :

Une carte INTEL SRCS16 (SATA RAID) comportant un agregat de Trois disk
Raptor en strip 0.

cette carte présente huit unitées logiques.

Open BSD et FreeBSD voient bien les huit présenté.

NETBSD n'en voit que 4 (dans le SYSINSTAL NetBSD)

Et bien entendu, le disque pour NetBSD etait le 6 eme.

Comment résoudre ce problème, j'ai justement monté ce strip pour
découvrir les autres BSD.

Quelqu'un aurait une idée ?

Merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Manuel Bouyer
Le #6804541
wrote:
Bonsoir,



je rencontre le problème suivant :

Une carte INTEL SRCS16 (SATA RAID) comportant un agregat de Trois disk
Raptor en strip 0.

cette carte présente huit unitées logiques.

Open BSD et FreeBSD voient bien les huit présenté.

NETBSD n'en voit que 4 (dans le SYSINSTAL NetBSD)


Comment ces unitees sont-elle vues ? ldx, sdx ?
Je pense que le probleme viens du fait que /dev ne contient les entrees
que pour les 4 premiers disques.
Il faut sortir de sysinst (un ^C doit suffir) et creer les devices
manquant:
cd /dev; ./MAKEDEV sd5
ou
cd /dev; ./MAKEDEV ld5

(selon que les disques sont vu en sdx ou ldx).
puis relancer sysinst (cd /; sysinst)

--
Manuel Bouyer NetBSD: 26 ans d'experience feront toujours la difference
--

olivier.burelli
Le #6824991
On 8 juin, 14:23, Manuel Bouyer
wrote:
Bonsoir,
je rencontre le problème suivant :
Une carte INTEL SRCS16 (SATA RAID) comportant un agregat de Trois disk
Raptor en strip 0.
cette carte présente huit unitées logiques.
Open BSD et FreeBSD voient bien les huit présenté.
NETBSD n'en voit que 4 (dans le SYSINSTAL NetBSD)


Comment ces unitees sont-elle vues ? ldx, sdx ?
Je pense que le probleme viens du fait que /dev ne contient les entrees
que pour les 4 premiers disques.
Il faut sortir de sysinst (un ^C doit suffir) et creer les devices
manquant:
cd /dev; ./MAKEDEV sd5
ou
cd /dev; ./MAKEDEV ld5

(selon que les disques sont vu en sdx ou ldx).
puis relancer sysinst (cd /; sysinst)

--
Manuel Bouyer NetBSD: 26 ans d'experience feront toujours la difference
--


Merci,

je vais suivre vos indications.

Mes disques sont présentes sous ldx.

je vais essayer de les monter man,uellement et de relancer SYSINSTALL
derrière.

Cdlt.

Olivier


Manuel Bouyer
Le #6831461
wrote:

Merci,

je vais suivre vos indications.

Mes disques sont présentes sous ldx.

je vais essayer de les monter man,uellement et de relancer SYSINSTALL
derrière.


il n'y a a priori pas besoin de les monter; il suffit de creer les
devices dans /dev avant de relancer sysinst


--
Manuel Bouyer NetBSD: 26 ans d'experience feront toujours la difference
--

olivier.burelli
Le #6833451
On Jun 9, 8:13 pm, Manuel Bouyer
wrote:
Merci,
je vais suivre vos indications.
Mes disques sont présentes sous ldx.
je vais essayer de les monter man,uellement et de relancer SYSINSTALL
derrière.


il n'y a a priori pas besoin de les monter; il suffit de creer les
devices dans /dev avant de relancer sysinst

--
Manuel Bouyer NetBSD: 26 ans d'experience feront toujours la difference
--


bonsoir,

la présentation des disk est opérationnel apres :

/dev/MAKEDEV ld4

dans sysinst j'ai pu créer mes slices, et arrivant au formatage, je
rencontre l'erreur suivante :

/sbin/newfs -V2 -01 -1 -b 8192 -f 1024 /dev/rld4a

newfs : /dev/rld4d : open for read : No such file or directory

dois je creer plutot le disklabel en ligne de cde ? : disklabel -I -r -
e ld4 ?

si je comprends bien le message d'erreur, le périphérique /dev/rld4
n'est pas lié au device souhaité, ou ne peut écrire dessus.

merci.

Cdlt,

olivier


Manuel Bouyer
Le #6838991
wrote:
bonsoir,

la présentation des disk est opérationnel apres :

/dev/MAKEDEV ld4

dans sysinst j'ai pu créer mes slices, et arrivant au formatage, je
rencontre l'erreur suivante :

/sbin/newfs -V2 -01 -1 -b 8192 -f 1024 /dev/rld4a

newfs : /dev/rld4d : open for read : No such file or directory

dois je creer plutot le disklabel en ligne de cde ? : disklabel -I -r -
e ld4 ?

si je comprends bien le message d'erreur, le périphérique /dev/rld4
n'est pas lié au device souhaité, ou ne peut écrire dessus.


Non, le message d'erreur c'est que /dev/rld4d n'existe pas.

est-ce que avant de faire /dev/MAKEDEV ld4 vous avez fait
cd /dev ?
MAKEDEV cree les devices dans le repertoire courant, certains outils
les trouvent s'ils sont dans le repertoire courant, d'autres ne cherchent que
dans /dev ...

--
Manuel Bouyer NetBSD: 26 ans d'experience feront toujours la difference
--

olivier.burelli
Le #6844331
On Jun 9, 10:47 pm, Manuel Bouyer
wrote:
bonsoir,
la présentation des disk est opérationnel apres :
/dev/MAKEDEV ld4
dans sysinst j'ai pu créer mes slices, et arrivant au formatage, je
rencontre l'erreur suivante :
/sbin/newfs -V2 -01 -1 -b 8192 -f 1024 /dev/rld4a
newfs : /dev/rld4d : open for read : No such file or directory
dois je creer plutot le disklabel en ligne de cde ? : disklabel -I -r -
e ld4 ?
si je comprends bien le message d'erreur, le périphérique /dev/rld4
n'est pas lié au device souhaité, ou ne peut écrire dessus.


Non, le message d'erreur c'est que /dev/rld4d n'existe pas.

est-ce que avant de faire /dev/MAKEDEV ld4 vous avez fait
cd /dev ?
MAKEDEV cree les devices dans le repertoire courant, certains outils
les trouvent s'ils sont dans le repertoire courant, d'autres ne cherchent que
dans /dev ...

--
Manuel Bouyer NetBSD: 26 ans d'experience feront toujours la difference
--


effectivement le device n'a pas été crée la ou il fallait.
Merci bcp pour ces explications.

J'ai pu installé NetBSD, mais a la fin de l'install le POST
controlleur INTEL SRCS16 ne passait pas la main a la phase de boot...

J'ai du reinitialiser mon unite logique RAID 4 (disque NetBSD) pour
pouvoir booter le chargeur GRUB.

Je recommence demain :)

encore merci

cdlt,

Olivier.


Publicité
Poster une réponse
Anonyme