[Mac OS X] probleme d'installation PHP-imagick

Le
unbewusst.sein
j'ai installé imagick par :

$ phpize
$ ./configure --prefix=/opt/local --with-imagick=/opt/local
$ make
$ sudo make install

puis j'ai renseigné mon php.ini
phpinfo() me dit que l'extension est bien chargée

d'ailleurs si j'essaie un script bébête comme :
echo __FILE__."<br />";
dl('imagick.so');
echo "dl('imagick.so');";

j'obtiens :
/Users/yt/Sites/PHP/imagick_rep/examples/captcha.php

Warning: Module 'imagick' already loaded in Unknown on line 0
dl('imagick.so');

MAIS, déja-là, ce qui m'intrigue, c'est le "Unknown" bizarre ce "loaded
in Unknown" non ???

ensuite si j'essaie un autre script :
echo __FILE__."<br />";
if (function_exists('Imagick')) {
echo "Les fonctions Imagick sont disponibles.<br />";
} else {
echo "Les fonctions Imagick ne sont pas disponibles.<br />";
}


j'obtiens :
/Users/yt/Sites/PHP/imagick_rep/examples/captcha.php
Les fonctions Imagick ne sont pas disponibles.

bien sûr j'ai vérifié que mon répertoire d'extension contenait bien
"imagick.so" :

~/src/PHP/imagick-2.2.0RC1/imagick-2.2.0RC1%> ls -al
/opt/local/lib/php/extensions/no-debug-non-zts-20060613/
-rwxr-xr-x 1 root admin 679300 20 jui 08:10 imagick.so
-rwxr-xr-x 1 root admin 610240 19 jui 08:58 magickwand.so
-rwxr-xr-x 1 root admin 49456 15 jui 20:46 sqlite3.so


je me demande s'il n'y aurait pas une incompatibilité avec
"magickwand.so" qui marche et continue de marcher même après install de
imagick.

je ne vois rien d'anormal pendant le ./configure, par ex :
checking for PHP extension directory
/opt/local/lib/php/extensions/no-debug-non-zts-20060613

c'est bon,

checking ImageMagick MagickWand API configuration program found in
/opt/local/bin/MagickWand-config
checking for MagickWand.h header file found in
/opt/local/include/ImageMagick/wand/MagickWand.h
checking if ImageMagick version is at least 6.2.4 found version 6.4.0
Q16
checking if PHP version is at least 5.1.3 found version 5.2.5

c'est bon aussi


au make juste quelques WARNINGS :
pointer targets in passing argument 1 of 'MagickGetVersion' differ in
signedness
"WORDS_BIGENDIAN" redefined


au "make test" :
$ make test
Build complete.
Don't forget to run 'make test'.

bogus test name tests/


curieux que "make test" me demande de ne pas oublier de runner "make
test"

par contre il y a :
bogus test name tests/
^^^^^^^^^^^^^^^^^^^^^^^

ce que j'avais déja eu avec l'install de magickwand et sqlite3, ce qui
ne les empèche pas de marcher correctement.

au cas où quelqu'un aurait un tuyau sur l'install d'imagick sur MacOS X,
PHP Apache2 et ImageMagick ayant été installés par MacPorts

j'ai vu sur PECL qu'il y avait une nouvelle verion (sqlite3-0.6.tgz) de
sqlite3, j'hésite à faire la màj
--
Une Bévue
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
unbewusst.sein
Le #7062181
Une Bev ue
j'ai vu sur PECL qu'il y avait une nouvelle verion (sqlite3-0.6.tgz) de
sqlite3, j'hésite à faire la màj...



je n'ai pas hésité tant que ça, après install de cette version 0.6 de
sqlite3, ça ne marchait plus, bien chargé d'après phpinfo, mais la
première fonction utilisée "sqlite3_open()" me donne un message d'erreur
disant que cette fonction n'existe pas, je suis donc revenu à la version
0.5, qui remarche.

j'ai quand même l'impression que ce pb est similaire à celui rencontré
avec imagick...

la version 0.6, au "make test" m'a donné tous les tests en erreur.
--
Une Bévue
Publicité
Poster une réponse
Anonyme