Machine qui bootait de matin ne boote plus cet après_midi...

Le
Fabrice Delente
Bonjour.

Cette machine comporte un disque SATA, qui est reconnu lors du lancement du
noyau :

scsi 0:0:0:0: ATA-8: ST9250827AS, 3.AA, max UDMA/133

sda: sda1 sda2 sda3 sda4

mais un peu plus loin lors de la procédure de boot :

swapon: cannot canonicalize /dev/sda1: no such file or directory

/sbin/e2fsck: No such file or directory while trying to open /dev/sda2

Pour pouvoir faire un e2fsck -v -y /dev/sda2, j'ai booté la machine avec un
linux installé sur un disque USB externe, et e2fsck m'a dit que /dev/sda2
était clean, j'ai pu le monter, y lire des fichiers,

J'ai quand même fait un e2fsck -v -y -f /dev/sda2, aucun problème n'est
apparu

Pourtant, en rebootant la machine sans le disque externe, le même problème
se reproduit

Que se passe-t-il ? Comment régler le problème ?

Merci pour toute aide ou suggestion !

À bientôt.

--
Fabrice DELENTE

SVP, ne m'envoyez pas de pièces jointes aux formats Word, PowerPoint, RTF
(formats propriétaires). Utilisez des formats libres comme txt, html, ou
OpenOffice.Org, ou un format ouvert comme PDF. Merci. Voir
http://www.gnu.org/philosophy/no-word-attachments.fr.html
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Doug713705
Le #19305531
Le Sun, 10 May 2009 13:28:23 +0000, Fabrice Delente a écrit dans
news:4a06d677$0$5253$ des mots en forme de phrase
pour nous dire :

Bonjour.




bonjour,


Pour pouvoir faire un e2fsck -v -y /dev/sda2, j'ai booté la machine avec
un linux installé sur un disque USB externe, et e2fsck m'a dit que
/dev/sda2 était clean, j'ai pu le monter, y lire des fichiers,...



Quelles différences entre les deux systèmes ?
Les noyaux sont ils les mêmes (version identiques et mêmes options) ?

N'aurais tu pas compilé ton noyau récement ou bien fait un peu de "ménage"
dans /boot ou /lib/modules ou encore modifié les paramêtres passé au noyau ?


Que se passe-t-il ? Comment régler le problème ?



A vue de nez, ça pourrait ressembler à l'absence du support pour le
controleur sata qui va bien pour ta machine.

Mais il faudrait en savoir un peu plus :
- De quelle distribution s'agit-il ?
- Quelle version du noyau ?
- Quelles opérations ont été executées lors de la dernière session
utilisable (l'historique de l'utilsateur root peut parfois être éloquent) ?
- Il y a t-il eu une modification de la configuration de la machine
remplacement disque dur par ex.) ?

Merci pour toute aide ou suggestion !



De rien, ce sont mes 2 cents.


--
@+
Doug - Linux user #307925 - Slamd64 roulaize ;-)
[ Plus ou moins avec une chance de peut-être ]
Fabrice Delente
Le #19311641
Doug713705
N'aurais tu pas compilé ton noyau récement ou bien fait un peu de "ménage"
dans /boot ou /lib/modules ou encore modifié les paramêtres passé au noyau ?



Merci des suggestions, en fait j'avais ajouté un fichier dans
/etc/udev/rules.d, qui devait renommer des liens du genre /dev/sda; en
retirant ce fichier, tout remarche normalement.

À bientôt.

--
Fabrice DELENTE

SVP, ne m'envoyez pas de pièces jointes aux formats Word, PowerPoint, RTF
(formats propriétaires). Utilisez des formats libres comme txt, html, ou
OpenOffice.Org, ou un format ouvert comme PDF. Merci. Voir
http://www.gnu.org/philosophy/no-word-attachments.fr.html
Publicité
Poster une réponse
Anonyme