Macro excel pour convertir du texte en numérique

Le
jc
Bonjour

J'aimerai convertir une zone texte "1-" en numérique c'est à dire "-1"
Pouvez-vous m'indiquer une piste ???
j'ai cherché par "remplacer par" mais ça ne marche pas
merci pour votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #4904221
Bonsoir,

Peut-être:
=-SUBSTITUE(A1;"-";"")

--
Salutations
JJ



"jc" 468e7e36$0$8821$
Bonjour

J'aimerai convertir une zone texte "1-" en numérique c'est à dire "-1"
Pouvez-vous m'indiquer une piste ???
j'ai cherché par "remplacer par" mais ça ne marche pas
merci pour votre aide


jc
Le #4904021
Bonsoir,

Peut-être:
=-SUBSTITUE(A1;"-";"")

marche pas

les nombres positifs deviennent négatifs

merci quand même

Mon Onc'
Le #4904011
bonjout jc, Jacky,

peut-être ceci :
=SI(DROITE(A1;1)="-";"-"&GAUCHE(A1;NBCAR(A1)-1);A1)

cordialement,

Mon Onc'


jc a formulé la demande :
Bonsoir,

Peut-être:
=-SUBSTITUE(A1;"-";"")

marche pas

les nombres positifs deviennent négatifs

merci quand même



jc
Le #4903971
bonjout jc, Jacky,

peut-être ceci :
=SI(DROITE(A1;1)="-";"-"&GAUCHE(A1;NBCAR(A1)-1);A1)

cordialement,

Mon Onc'


jc a formulé la demande :
Bonsoir,

Peut-être:
=-SUBSTITUE(A1;"-";"")

marche pas

les nombres positifs deviennent négatifs

merci quand même



merci infiniment, ça marche




Jacky
Le #4903941
Re....
ou ;o)
=SI(DROITE(A1;1)="-";-SUBSTITUE(A1;"-";"");A1)
--
Salutations
JJ



"Mon Onc'"
bonjout jc, Jacky,

peut-être ceci :
=SI(DROITE(A1;1)="-";"-"&GAUCHE(A1;NBCAR(A1)-1);A1)

cordialement,

Mon Onc'


jc a formulé la demande :
Bonsoir,

Peut-être:
=-SUBSTITUE(A1;"-";"")

marche pas

les nombres positifs deviennent négatifs

merci quand même







Publicité
Poster une réponse
Anonyme