Macro si avec des caractères variables

Le
Steph
Bonjour,

Difficile de trouver un titre pour ce que je veux faire, je vais
essayer d'être claire !

Dans excel, je dois saisir des formules si de ce genre:
=SI(ET(A175165<A$160;B165<B$160);1;"")

Mes lettres, ici A et B sont en fait des variables qui se trouvent
dans les cellules du dessus.

Par exemple si je tape ma formule en A3:
- la lettre A est dans la cellule A1
- la lettre B dans la cellule A2

J'aimerais faire une macro (ou peut-être qu'il existe une formule) qui
puisse aller chercher les valeurs en A1 et A2 pour les mettre dans mon
si.

Du genre:
=SI(ET([celluleA1]175165<[celluleA1]$160;
[celluleA2]165<[celluleA2]$160);1;"")

Est-ce possible ?

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #23800841
Bonjour,

As-tu essayé avec indirect
En A1 >>> A
En A2 >>> B
Dans une cellule
=INDIRECT(A&175165)
te donneras ce qu'il y a dans A175165

=Si(ET(INDIRECT(A1&175165)<A$160;INDIRECT(A2&165)<160);1;"")
--
Salutations
JJ


"Steph"
Bonjour,

Difficile de trouver un titre pour ce que je veux faire, je vais
essayer d'être claire !

Dans excel, je dois saisir des formules si de ce genre:
=SI(ET(A175165<A$160;B165<B$160);1;"")

Mes lettres, ici A et B sont en fait des variables qui se trouvent
dans les cellules du dessus.

Par exemple si je tape ma formule en A3:
- la lettre A est dans la cellule A1
- la lettre B dans la cellule A2

J'aimerais faire une macro (ou peut-être qu'il existe une formule) qui
puisse aller chercher les valeurs en A1 et A2 pour les mettre dans mon
si.

Du genre:
=SI(ET([celluleA1]175165<[celluleA1]$160;
[celluleA2]165<[celluleA2]$160);1;"")

Est-ce possible ?

Merci
Jacky
Le #23800931
Re..
Il faut lire
=INDIRECT(A1&175165)
te donneras ce qu'il y a dans A175165
et non pas
=INDIRECT(A&175165
--
Salutations
JJ


"Jacky"
Bonjour,

As-tu essayé avec indirect
En A1 >>> A
En A2 >>> B
Dans une cellule
=INDIRECT(A&175165)
te donneras ce qu'il y a dans A175165

=Si(ET(INDIRECT(A1&175165)<A$160;INDIRECT(A2&165)<160);1;"")
--
Salutations
JJ


"Steph"
Bonjour,

Difficile de trouver un titre pour ce que je veux faire, je vais
essayer d'être claire !

Dans excel, je dois saisir des formules si de ce genre:
=SI(ET(A175165<A$160;B165<B$160);1;"")

Mes lettres, ici A et B sont en fait des variables qui se trouvent
dans les cellules du dessus.

Par exemple si je tape ma formule en A3:
- la lettre A est dans la cellule A1
- la lettre B dans la cellule A2

J'aimerais faire une macro (ou peut-être qu'il existe une formule) qui
puisse aller chercher les valeurs en A1 et A2 pour les mettre dans mon
si.

Du genre:
=SI(ET([celluleA1]175165<[celluleA1]$160;
[celluleA2]165<[celluleA2]$160);1;"")

Est-ce possible ?

Merci

Steph
Le #23805131
On 28 sep, 15:19, "Jacky"
Re..
Il faut lire
=INDIRECT(A1&175165)
te donneras ce qu'il y a dans A175165
et non pas
 =INDIRECT(A&175165
--
Salutations
JJ

"Jacky"
> Bonjour,

> As-tu essayé avec indirect
> En A1 >>> A
> En A2 >>> B
> Dans une cellule
> =INDIRECT(A&175165)
> te donneras ce qu'il y a dans A175165

> =Si(ET(INDIRECT(A1&175165)<A$160;INDIRECT(A2&165)<160);1;"")
> --
> Salutations
> JJ

> "Steph" >
> Bonjour,

> Difficile de trouver un titre pour ce que je veux faire, je vais
> essayer d'être claire !

> Dans excel, je dois saisir des formules si de ce genre:
> =SI(ET(A175165<A$160;B165<B$160);1;"")

> Mes lettres, ici A et B sont en fait des variables qui se trouvent
> dans les cellules du dessus.

> Par exemple si je tape ma formule en A3:
> - la lettre A est dans la cellule A1
> - la lettre B dans la cellule A2

> J'aimerais faire une macro (ou peut-être qu'il existe une formule) qu i
> puisse aller chercher les valeurs en A1 et A2 pour les mettre dans mon
> si.

> Du genre:
> =SI(ET([celluleA1]175165<[celluleA1]$160;
> [celluleA2]165<[celluleA2]$160);1;"")

> Est-ce possible ?

> Merci



Merci, ça fonctionne :)
Mais quand je "glisse" ma formule vers les cases du dessous, la
formule ne s'ajuste pas.

Par exemple, pour faire simple:
- en A5 je tape =indirect(A$25&5)
En tirant ma formule, en A6 j'aimerais que la formule devienne
=indirect(A$25&6)
C'est à dire que le 5 devienne 6.
Comment faire ?

Merci
MichD
Le #23805521
Bonjour,

Je n'ai pas tout lu...

As-tu essayé quelque chose comme :

=INDIRECT("A"& LIGNE(A3))

A3 étant la première ligne et si tu recopies vers le bas, les références devraient suivre !



MichD
------------------------------------------
"Steph" a écrit dans le message de groupe de discussion :


On 28 sep, 15:19, "Jacky"
Re..
Il faut lire
=INDIRECT(A1&175165)
te donneras ce qu'il y a dans A175165
et non pas
=INDIRECT(A&175165
--
Salutations
JJ

"Jacky"
> Bonjour,

> As-tu essayé avec indirect
> En A1 >>> A
> En A2 >>> B
> Dans une cellule
> =INDIRECT(A&175165)
> te donneras ce qu'il y a dans A175165

> =Si(ET(INDIRECT(A1&175165)<A$160;INDIRECT(A2&165)<160);1;"")
> --
> Salutations
> JJ

> "Steph" >
> Bonjour,

> Difficile de trouver un titre pour ce que je veux faire, je vais
> essayer d'être claire !

> Dans excel, je dois saisir des formules si de ce genre:
> =SI(ET(A175165<A$160;B165<B$160);1;"")

> Mes lettres, ici A et B sont en fait des variables qui se trouvent
> dans les cellules du dessus.

> Par exemple si je tape ma formule en A3:
> - la lettre A est dans la cellule A1
> - la lettre B dans la cellule A2

> J'aimerais faire une macro (ou peut-être qu'il existe une formule) qui
> puisse aller chercher les valeurs en A1 et A2 pour les mettre dans mon
> si.

> Du genre:
> =SI(ET([celluleA1]175165<[celluleA1]$160;
> [celluleA2]165<[celluleA2]$160);1;"")

> Est-ce possible ?

> Merci



Merci, ça fonctionne :)
Mais quand je "glisse" ma formule vers les cases du dessous, la
formule ne s'ajuste pas.

Par exemple, pour faire simple:
- en A5 je tape =indirect(A$25&5)
En tirant ma formule, en A6 j'aimerais que la formule devienne
=indirect(A$25&6)
C'est à dire que le 5 devienne 6.
Comment faire ?

Merci
Jacky
Le #23805691
re..
C'est à dire que le 5 devienne 6.
Comment faire ?


Utilise indirect en combinaison avec ligne
Par exemple
=INDIRECT(A$25&LIGNE())

--
Salutations
JJ


_________________________________
Merci, ça fonctionne :)
Mais quand je "glisse" ma formule vers les cases du dessous, la
formule ne s'ajuste pas.

Par exemple, pour faire simple:
- en A5 je tape =indirect(A$25&5)
En tirant ma formule, en A6 j'aimerais que la formule devienne
=indirect(A$25&6)
C'est à dire que le 5 devienne 6.
Comment faire ?

Merci
Publicité
Poster une réponse
Anonyme