Magic SysRQ + Xen + screen + Putty

Le
Jean Baptiste Favre
Bonjour la liste,
J'ai un serveur de test qui me fait un kernel panic régulier au reboot.
Rien de bien méchant (c'est une machine de test après tout), mais j'ai
un soucis pour envoyer les Magic SysRQ.

Ce serveur est contrôlé par port série depuis une machine Debian. Sur
cette dernière, je lance "screen /dev/ttyUSB2 115200".

En local depuis la machine Debian, les Magic SysRQ marchent bien.

Lorsque j'accède à cette machine à distance depuis un windows par SSH
(Putty), ça ne passe pas.

J'ai pensé à un problème de mapping clavier entre Windows et Linux, mais
je ne trouve pas d'option particulière dans Putty.

Une idée ?

Cordialement,
JB

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4D2EC86B.7060200@jbfavre.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Eric Belhomme
Le #23017631
Le Thu, 13 Jan 2011 10:39:55 +0100, Jean Baptiste Favre a écrit :

Bonjour la liste,
J'ai un serveur de test qui me fait un kernel panic régulier au reboot.
Rien de bien méchant (c'est une machine de test après tout), mais j'ai
un soucis pour envoyer les Magic SysRQ.

Ce serveur est contrôlé par port série depuis une machine Debian. Sur
cette dernière, je lance "screen /dev/ttyUSB2 115200".

En local depuis la machine Debian, les Magic SysRQ marchent bien.

Lorsque j'accède à cette machine à distance depuis un windows par SSH
(Putty), ça ne passe pas.

J'ai pensé à un problème de mapping clavier entre Windows et Linux, mais
je ne trouve pas d'option particulière dans Putty.




Le problème vient plus probablement de screen qui n'envoie pas la bonne
séquence d'échappement.
Je ne sais pas comment régler le problème avec screen, en revanche
j'utilise console-server (et console-client) pour gérer mes serveurs via
les ports série, et la séquence "<CTRL>Ecl0<magic key>" fonctionne
parfaitement via ce biais.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/igmqj5$g85$
Jean Baptiste Favre
Le #23017811
Le 13/01/2011 13:18, Eric Belhomme a écrit :
Le Thu, 13 Jan 2011 10:39:55 +0100, Jean Baptiste Favre a écrit :

Bonjour la liste,
J'ai un serveur de test qui me fait un kernel panic régulier au reboot.
Rien de bien méchant (c'est une machine de test après tout), mais j'ai
un soucis pour envoyer les Magic SysRQ.

Ce serveur est contrôlé par port série depuis une machine Debian. Sur
cette dernière, je lance "screen /dev/ttyUSB2 115200".

En local depuis la machine Debian, les Magic SysRQ marchent bien.

Lorsque j'accède à cette machine à distance depuis un windows par SSH
(Putty), ça ne passe pas.

J'ai pensé à un problème de mapping clavier entre Windows et Linux, mais
je ne trouve pas d'option particulière dans Putty.




Le problème vient plus probablement de screen qui n'envoie pas la bonne
séquence d'échappement.
Je ne sais pas comment régler le problème avec screen, en revanche
j'utilise console-server (et console-client) pour gérer mes serveurs via
les ports série, et la séquence "<CTRL>Ecl0<magic key>" fonctionne
parfaitement via ce biais.



Bonjour,
Merci pour la réponse.
Je ne connaissais pas conserver-server et conserver-client et vais donc
les tester.

Juste une question à propos de "<CTRL>Ecl0". le CRTL, ok je vois. Mais
la suite ? Il s'agit de lettre ("e" majuscule, "c" minuscule, "l"
minuscule et 0) à taper les unes après les autres, ou d'une séquence
simultanée ? ET si j'ai bien suivi, ceci remplace le "Alt+Syst" des
Magic SysRQ "classiques" ?

Néanmoins, dans la mesure où en local sur ma machine les séquences SysRQ
fonctionnent correctement, je me dis que screen n'est pas concerné.

Cordialement,
JB

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme