Mailman avec https

Le
andre_debian
Excuses pour ma question rootkit "vi", pas lu tous les fils, désolé.
___________________________


J'ai créé un serveur Web Apache2 entièrement sous "https" (ssl) qui f=
onctionne bien,
sauf le gestionnaire "mailman".
En mode http (port 80), il n'a pas de problèmes.

Apache2 refuse de créer un 2ème virtualhost "mailman" sur le port 443.
/etc/init.d/./apache2 restart => fail

Mailman se lance malgré tout en https, s'affiche correctement, accepte le=
s login,
mais ne répond à aucune modification.

Si vous aviez une idée, grand merci !

andré

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/201307241548.06065.andre_debian@numericable.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sébastien NOBILI
Le #25561962
Le mercredi 24 juillet 2013 à 15:48, a écrit :
J'ai créé un serveur Web Apache2 entièrement sous "https" (ssl) qui fonctionne bien,
sauf le gestionnaire "mailman".
En mode http (port 80), il n'a pas de problèmes.

Apache2 refuse de créer un 2ème virtualhost "mailman" sur le port 443.
/etc/init.d/./apache2 restart => fail



Que disent les logs ?

Mailman se lance malgré tout en https, s'affiche correctement, accepte les login,
mais ne répond à aucune modification.



C'est contradictoire avec le paragraphe précédent, non ?
Qu'entends-tu par « ne répond à aucune modification » ?

Si vous aviez une idée, grand merci !



Pour l'instant, pas la moindre !

Seb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pierre Malard
Le #25562022
--Apple-Mail=_23C01D3E-D464-462C-BD25-5A6A1C0A7B45
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
charset=windows-1252

Bonjour,

Le 24 juil. 2013 à 15:48, a écrit :
J'ai créé un serveur Web Apache2 entièrement sous "https" (ssl) qui fonctionne bien,
sauf le gestionnaire "mailman".
En mode http (port 80), il n'a pas de problèmes.

Apache2 refuse de créer un 2ème virtualhost "mailman" sur le port 443.
/etc/init.d/./apache2 restart => fail

Mailman se lance malgré tout en https, s'affiche correctement, accepte les login,
mais ne répond à aucune modification.

Si vous aviez une idée, grand merci !



Et un peu plus d'explications que "fail", ce serait mieux pour pouvoir répondre...
Par exemple :
- Que renvoie exactement le "/etc/init.d/apache2 restart" ?
- Avez vous regardé les logs d'erreurs d'apache ?
- Que disent-ils ?
- Si pas assez d'information, avez-vous élevé le niveau de log ?
- Qu'est-ce que ça donne ?

Cordialement

--
Pierre Malard
«C'est bien plus beau lorsque c'est inutile»
Edmon Rostand - "Cyrano de Bergerac"
| _,,,---,,_
/,`.-'`' -. ;-;;,_
|,4- ) )-,_. , ( `'-'
'---''(_/--' `-'_)

perl -e '$_=q#: 3| 5-,3-3,2-: 3/,`.'"'"'`'"'"' 5-. ;-;;,-: |,A- ) )-,_. , ( `'"'"'-'"'"': '"'"'-3'"'"'2(-/--'"'"' `-'"'"'-): 22PLM::#;y#:#n#;s#(D)(d+)#$1x$2#ge;print'
- --> Ce message n’engage que son auteur <--


--Apple-Mail=_23C01D3E-D464-462C-BD25-5A6A1C0A7B45
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
filename=signature.asc
Content-Type: application/pgp-signature;
name=signature.asc
Content-Description: Message signed with OpenPGP using GPGMail

-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.19 (Darwin)

iQIcBAEBCgAGBQJR7+HpAAoJELzRDw+wKgIyEhkP/jR6cWkljfNFdCKdt8Nst6YA
o+ksNWZBtjCf4G3sPnEc42zGspNHIN02MBI1a1RcAuMxqzEPzABInjoOTx/XXMYY
sumv5lvJ8z1hldG5ptS4M8SeJV4IS+vPqG6qMHmu4N5GTQH3UQskmPjoKoHJDJBh
+ICQLuD1vGbP8Szy7tJN3hX04PiTL6sjeD8aO2CpBtlvP67ZK06NQuMoEOp+Oqh2
tSwrHUWYmEoKBuwWHNxi3AXrY6DTVm0fMYLT8+ELf8TjGsMIXSR6pWkXvyZUZ0/D
CpO9Kwvvkp5khJPh0P7L2ianHkWDNBIUv1KoYFdyHlS78ddCsG1BTs5Vj+cF7lm3
FQt6NwE5+uIu5xxZzf1auxF+/42JFKmlznfqazNyHzdAfykaa7IBd6iFpBSvkp6e
dUeTmDC+zqZiIh/l3f+ELEFy63k/P0eUaMqFtZlHLgTX4/ArbD03qjLRunPE2GRV
OgodzBptLFjUtUNMlepwfVWQZvCmZ28brAWRfxGXBAJIz6gAD1f89HWvs0o/JuwT
qzqjpFyza3Zheaby+1c31cb9hht9KInBok4iYxoTaBTjgJEzVnTEzLd8cuzIf2vG
Hu2p9oFqHUnWSVMgiz/dlkzTL0cSRxAxsgKvU41QCYuyX0/KkllhvUIduEA8P2HH
A/wEN5ABc+E4hgvzEG98
=DPtn
-----END PGP SIGNATURE-----

--Apple-Mail=_23C01D3E-D464-462C-BD25-5A6A1C0A7B45--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Grégoire COUTANT
Le #25562012
Logs ?

/var/log/apache2/xxxxx-error.log

Qques indications également avec :

$ apache2ctl -t

Greg

Le 24/07/2013 15:48, a écrit :
Excuses pour ma question rootkit "vi", pas lu tous les fils, désolé.
___________________________


J'ai créé un serveur Web Apache2 entièrement sous "https" (ssl) qui fonctionne bien,
sauf le gestionnaire "mailman".
En mode http (port 80), il n'a pas de problèmes.

Apache2 refuse de créer un 2ème virtualhost "mailman" sur le port 443.
/etc/init.d/./apache2 restart => fail

Mailman se lance malgré tout en https, s'affiche correctement, accepte les login,
mais ne répond à aucune modification.

Si vous aviez une idée, grand merci !

andré




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
andre_debian
Le #25564262
J'ai créé un serveur Web Apache2 entièrement sous "https" (ssl) qui
fonctionne bien, sauf le gestionnaire "mailman".
En mode http (port 80), il n'a pas de problèmes.
Apache2 refuse de créer un 2ème virtualhost "mailman" sur le port 443.
/etc/init.d/./apache2 restart => fail
Mailman se lance malgré tout en https, s'affiche correctement, accepte les
login, mais ne répond à aucune modification.
Si vous aviez une idée, grand merci ! andré

Logs

C'est contradictoire avec le paragraphe précédent, non ?
Qu'entends-tu par « ne répond à aucune modification » ?



Merci de vos réponses.

Ce n'est pas un problème lié à Apache2.

Mailman envoie un message pour sortir du mode https => http.
Et comme Apache2 est en mode exclusif https,
Mailman ne traite pas les opérations demandées.

La seule solution est de désactiver dans apache2 le mode exclusif https
et là Mailman fonctionne.

J'ai pourtant bien mis dans "/etc/mailman/mm_cfg.py" :
DEFAULT_URL_PATTERN = 'https://%s/cgi-bin/mailman/'

Le "/var/log/mailman/error.log", pourtant activé, reste vide.

Il faudrait que je trouve un fichier /etc/apache2/sites-enabled/mailman
configuré au mode https (ssl).

andré


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
andre_debian
Le #25564412
Trouvé :
Il faut taper cette commande pour chaque liste de Mailman :
/var/lib/mailman/bin/withlist -l -r fix_url <nom de la liste>

andré

On Thursday 25 July 2013 19:18:39 wrote:
> J'ai créé un serveur Web Apache2 entièrement sous "https" (ssl) q ui
> fonctionne bien, sauf le gestionnaire "mailman".
> En mode http (port 80), il n'a pas de problèmes.
> Apache2 refuse de créer un 2ème virtualhost "mailman" sur le port 4 43.
> /etc/init.d/./apache2 restart => fail
> Mailman se lance malgré tout en https, s'affiche correctement, accepte
> les login, mais ne répond à aucune modification.
> Si vous aviez une idée, grand merci ! andré
>
> Logs
>
> C'est contradictoire avec le paragraphe précédent, non ?
> Qu'entends-tu par « ne répond à aucune modification » ?

Merci de vos réponses.
Ce n'est pas un problème lié à Apache2.
Mailman envoie un message pour sortir du mode https => http.
Et comme Apache2 est en mode exclusif https,
Mailman ne traite pas les opérations demandées.
La seule solution est de désactiver dans apache2 le mode exclusif https
et là Mailman fonctionne.
J'ai pourtant bien mis dans "/etc/mailman/mm_cfg.py" :
DEFAULT_URL_PATTERN = 'https://%s/cgi-bin/mailman/'
Le "/var/log/mailman/error.log", pourtant activé, reste vide.
Il faudrait que je trouve un fichier /etc/apache2/sites-enabled/mailman
configuré au mode https (ssl).
andré



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme