mais ou est XrandR 1.2? Debutant]

Le
Hugues MORIN
=_Part_58784_1237877.1218655091010
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Bonjour a tous,

Je m'escrime depuis quelques jours a reconfigurer mon xorg.conf pour une
carte ATI Radeon 9250 en dualhead.

Dans toutes les explications que j'ai pu trouver on ne parle que de Xrandr
1.2.

D'apres xrandr -v, sur ma machine je n'ai que la version 1.1:

****:~# xrandr -v
Server reports RandR version 1.1

Je prefere utiliser aptitude pour installer/desinstaller quelquechose (la
peur debutant de faire une betise.:-), et j'y ai cherche partout Xrandr
1.2, mais je l'ai pas trouve.
J'ai aussi ete voir sur http://www.debian.org/distrib/packages mais rien non
plus.

Je pense que cela doit y etre mais comme je ne sais pas vraiment ce que je
cherche, je suis peut etre passe a cote, ou alors il n'existe pas en Etch.

voila mon source.list si ca peut etre utile:

#deb cdrom:[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 NETINST Binary-1
20070820-20:21]/ etch contrib main

deb http://ftp.fr.debian.org/debian/ etch main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ etch main contrib non-free

deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib

deb http://www.debian-multimedia.org etch main
deb-src http://www.debian-multimedia.org etch main


En resume, je voudrai installer XrandR 1.2 mais il faudrait que je sache ou
le trouver.


merci et Bonne soiree
Hugues

=_Part_58784_1237877.1218655091010
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

<div dir="ltr">Bonjour a tous,<br><br>Je m&#39;escrime depuis quelques jours a reconfigurer mon xorg.conf pour une carte ATI Radeon 9250 en dualhead.<br><br>Dans toutes les explications que j&#39;ai pu trouver on ne parle que de Xrandr 1.2.<br>

<br>D&#39;apres xrandr -v, sur ma machine je n&#39;ai que la version 1.1:<br><br>****:~# xrandr -v<br>Server reports RandR version 1.1<br><br>Je prefere utiliser aptitude pour installer/desinstaller quelquechose (la peur debutant de faire une betise.:-), et j&#39;y ai cherche partout Xrandr 1.2, mais je l&#39;ai pas trouve.<br>

J&#39;ai aussi ete voir sur <a href="http://www.debian.org/distrib/packages" target="_blank">http://www.debian.org/distrib/packages</a> mais rien non plus.<br><br>Je pense que cela doit y etre mais comme je ne sais pas vraiment ce que je cherche, je suis peut etre passe a cote, ou alors il n&#39;existe pas en Etch.<br>

<br>voila mon source.list si ca peut etre utile:<br><br>#deb cdrom:[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 NETINST Binary-1 20070820-20:21]/ etch contrib main<br><br>deb <a href="http://ftp.fr.debian.org/debian/" target="_blank">http://ftp.fr.debian.org/debian/</a> etch main contrib non-free<br>

deb-src <a href="http://ftp.fr.debian.org/debian/" target="_blank">http://ftp.fr.debian.org/debian/</a> etch main contrib non-free<br><br>deb <a href="http://security.debian.org/" target="_blank">http://security.debian.org/</a> etch/updates main contrib<br>

deb-src <a href="http://security.debian.org/" target="_blank">http://security.debian.org/</a> etch/updates main contrib<br><br>deb <a href="http://www.debian-multimedia.org" target="_blank">http://www.debian-multimedia.org</a> etch main<br>
deb-src <a href="http://www.debian-multimedia.org" target="_blank">http://www.debian-multimedia.org</a> etch main<br>
<br><br>En resume, je voudrai installer XrandR 1.2&nbsp; mais il faudrait que je sache ou le trouver.<br><br><br>merci et Bonne soiree<br>Hugues<br></div>

=_Part_58784_1237877.1218655091010--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Leopold BAILLY
Le #16541551
"Hugues MORIN"
Bonjour a tous,

Je m'escrime depuis quelques jours a reconfigurer mon xorg.conf pour une carte ATI Radeon 9250 en dualhead.

Dans toutes les explications que j'ai pu trouver on ne parle que de Xrandr 1.2.

D'apres xrandr -v, sur ma machine je n'ai que la version 1.1:

****:~# xrandr -v
Server reports RandR version 1.1

Je prefere utiliser aptitude pour installer/desinstaller quelquechose (la peur debutant de faire une betise....:-),
et j'y ai cherche partout Xrandr 1.2, mais je l'ai pas trouve.
J'ai aussi ete voir sur http://www.debian.org/distrib/packages mais rien non plus.



Eh bien en utilisant cette page de recherche, je peux voir que xrandr
fait partie du paquet :

xbase-clients en stable
x11-xserver-utils en testing

Je suis en testing est j'ai bien xrandr version 1.2.

Donc, si tu es à jour de xbase-clients (version 1:7.1.ds1-2) sur ta
stable et que xrandr est en version 1.1, tu n'as plus qu'à passer en
testing.

Pour éviter de basculer tout le système en testing, il y a la solution
du rétro-portage, mais ça me semble délicat sur des paquets d'aussi
bas niveau comme les paquets x11, et qui ont changé de nom de
surcroît.

--
Léo.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
François Boisson
Le #16541541
Le Wed, 13 Aug 2008 22:01:24 +0200
Leopold BAILLY
"Hugues MORIN"
> Bonjour a tous,
>
> Je m'escrime depuis quelques jours a reconfigurer mon xorg.conf pour une
> carte ATI Radeon 9250 en dualhead.
>
> Dans toutes les explications que j'ai pu trouver on ne parle que de Xrandr
> 1.2.
>
> D'apres xrandr -v, sur ma machine je n'ai que la version 1.1:
>
> ****:~# xrandr -v
> Server reports RandR version 1.1
>
> Je prefere utiliser aptitude pour installer/desinstaller quelquechose (la
> peur debutant de faire une betise....:-), et j'y ai cherche partout Xrandr
> 1.2, mais je l'ai pas trouve. J'ai aussi ete voir sur
> http://www.debian.org/distrib/packages mais rien non plus.

Eh bien en utilisant cette page de recherche, je peux voir que xrandr
fait partie du paquet :

xbase-clients en stable
x11-xserver-utils en testing

Je suis en testing est j'ai bien xrandr version 1.2.

Donc, si tu es à jour de xbase-clients (version 1:7.1.ds1-2) sur ta
stable et que xrandr est en version 1.1, tu n'as plus qu'à passer en
testing.

Pour éviter de basculer tout le système en testing, il y a la solution
du rétro-portage, mais ça me semble délicat sur des paquets d'aussi
bas niveau comme les paquets x11, et qui ont changé de nom de
surcroît.




:~$ apt-cache policy xbase-clients
xbase-clients:
Installé : 1:7.1.ds1-2
Candidat : 1:7.3+10
Table de version :
1:7.3+10 0
997 http://boisson.homeip.net etch/divers Packages
998 http://boisson.homeip.net etch/inspiron Packages
*** 1:7.1.ds1-2 0
500 http://ftp.fr.debian.org etch/main Packages
100 /var/lib/dpkg/status
:~$ xrandr -v
Server reports RandR version 1.2
:~$ dpkg -S xrandr
libxrandr2: /usr/share/doc/libxrandr2
libxrandr-dev: /usr/share/doc/libxrandr-dev/copyright
libxrandr-dev: /usr/share/doc/libxrandr-dev/changelog.Debian.gz
libxrandr-dev: /usr/share/doc/libxrandr-dev
libxrandr2: /usr/share/doc/libxrandr2/copyright
xbase-clients: /usr/share/man/man1/xrandr.1.gz
libxrandr-dev: /usr/lib/pkgconfig/xrandr.pc
xbase-clients: /usr/bin/xrandr
libxrandr2: /usr/share/doc/libxrandr2/changelog.Debian.gz
:~$

Le xrandr de etch est bien la version 1.2.

François Boisson

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Francois Bottin
Le #16542041
François Boisson wrote:
Le xrandr de etch est bien la version 1.2.



Ben justement, j'ai essayé de configurer mes deux cartes avec xrandr le
mois dernier, et j'étais arrivé au même point que l'OP : la version de
etch est la 1.1 !

Quelle est ta version de libxrandr2 ? Je vois que tu as tes propres
dépots, et tu n'as peut être pas la version de etch...

Chez moi (on voit bien le « 1.1 » dans la version du paquet) :
:~$ apt-cache policy libxrandr2
libxrandr2:
Installed: 2:1.1.0.2-5
Candidate: 2:1.1.0.2-5
Version table:
*** 2:1.1.0.2-5 0
500 http://ftp.fr.debian.org etch/main Packages
100 /var/lib/dpkg/status

Je ne peux pas revérifier avec un « xrandr -v » parce que je l'ai
désactivé de mon X et je ne peux pas le redémarrer pour le moment.

François.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
fra-duf-no-spam
Le #16542581
Le 14104ième jour après Epoch,
François Boisson écrivait:

J'ai remarqué que l'adresse de tes listes noires (que je refuse d'ut iliser)
est toujours la même 213.228.63.58, cette IP donne avec un



Bien vu, j'avais pas remarqué :)

Tu peux développer pourquoi tu refuses d'utiliser les black lists?

lynx 213.228.63.58

Attention !!!

Si vous arrivez sur cette page c'est que votre configuration DNS est
incorrecte. Merci de modifier les paramètres IP de votre ordinateur si
possible en DHCP pour obtenir automatiquement la bonne configuration. Pour
info les DNS de Free sont : 212.27.40.240 et 212.27.40.241

Donc à mon avis, tu as un gros souci de DNS. Vérifie encore de ce
coté.



C'est ça... Dans mon DNS, j'ai mis comme forwarder les DNS de free que
j'ai récupéré il y a un moment sur mon DHCP, mais ça a dû changer, et
comme je suis en IP fixe, j'ai pas fait attention...

Soit je vire les forwarders, soit je trouve un moyen de les récupà ©rer
de façon un peu plus dynamique.

Merci pour ton coup de main, et ton coup d'oeil ;)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
François Boisson
Le #16543591
Le Wed, 13 Aug 2008 23:13:48 +0200
Francois Bottin
François Boisson wrote:
> Le xrandr de etch est bien la version 1.2.

Ben justement, j'ai essayé de configurer mes deux cartes avec xrandr le
mois dernier, et j'étais arrivé au même point que l'OP : la version de
etch est la 1.1 !

Quelle est ta version de libxrandr2 ? Je vois que tu as tes propres
dépots, et tu n'as peut être pas la version de etch...



libxrandr2:
Installé : 2:1.1.0.2-5
Candidat : 2:1.1.0.2-5
Table de version :
*** 2:1.1.0.2-5 0
500 http://ftp.fr.debian.org etch/main Packages
100 /var/lib/dpkg/status
:~$

La seule chose est que j'ai effectivement fait un backport d'une partie de X
pour supporter l'accélération 3D sur la carte Intel, tu peux trouver les
paquets sur
deb http://boisson.homeip.net/debian etch inspiron

soit là: http://boisson.homeip.net/debian/pool/etch/inspiron64/

mais ce sont des 64 bits et les paquets concernant xrandr ne sont pas
concernés.
De plus si je passe dans le chroot 32bits:


bling:/home/francois# chroot /srv
bling:/# xrandr -v
Server reports RandR version 1.2
bling:/# dpkg -S xrandr
libxrandr2: /usr/share/doc/libxrandr2
libxrandr2: /usr/share/doc/libxrandr2/copyright
xbase-clients: /usr/share/man/man1/xrandr.1.gz
xbase-clients: /usr/bin/xrandr
libxrandr2: /usr/share/doc/libxrandr2/changelog.Debian.gz
bling:/# apt-cache policy xbase-clients libxrandr2
xbase-clients:
Installé : 1:7.1.ds1-2
Candidat : 1:7.1.ds1-2
Table de version :
1:7.3+14 0
97 http://ftp.fr.debian.org lenny/main Packages
95 http://ftp.fr.debian.org sid/main Packages
*** 1:7.1.ds1-2 0
986 http://ftp.fr.debian.org etch/main Packages
100 /var/lib/dpkg/status
libxrandr2:
Installé : 2:1.1.0.2-5
Candidat : 2:1.1.0.2-5
Table de version :
2:1.2.3-1 0
97 http://ftp.fr.debian.org lenny/main Packages
95 http://ftp.fr.debian.org sid/main Packages
*** 2:1.1.0.2-5 0
986 http://ftp.fr.debian.org etch/main Packages
100 /var/lib/dpkg/status
bling:/#

et sur 32 bits, je n'ai aucun backport de X. Peut être que la version rendu
par xrandr dépend de la version du X installé mais ce serait curieux...


François Boisson

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Hugues MORIN
Le #16548541
Bonsoir


Il semblerai donc que xrandr 1.2 n'existe par pour etch, je vais pas
aller chercher plus loin dans cette direction parce que j'ai vraiment
pas le niveau pour faire cohabiter du stable et du testing.
Pour votre curiosite voila ce que me donne les commandes qu'on
effectue Francois B. et Francois B.:

suntzu:~# xrandr -v
Server reports RandR version 1.1
suntzu:~# dpkg -S xrandr
libxrandr2: /usr/share/doc/libxrandr2
libxrandr2: /usr/share/doc/libxrandr2/copyright
xbase-clients: /usr/share/man/man1/xrandr.1.gz
xbase-clients: /usr/bin/xrandr
libxrandr2: /usr/share/doc/libxrandr2/changelog.Debian.gz
suntzu:~# apt-cache policy libxrandr2
libxrandr2:
Installé : 2:1.1.0.2-5
Candidat : 2:1.1.0.2-5
Table de version :
*** 2:1.1.0.2-5 0
500 http://ftp.fr.debian.org etch/main Packages
100 /var/lib/dpkg/status
suntzu:~# apt-cache policy xbase-clients libxrandr2
xbase-clients:
Installé : 1:7.1.ds1-2
Candidat : 1:7.1.ds1-2
Table de version :
*** 1:7.1.ds1-2 0
500 http://ftp.fr.debian.org etch/main Packages
100 /var/lib/dpkg/status
libxrandr2:
Installé : 2:1.1.0.2-5
Candidat : 2:1.1.0.2-5
Table de version :
*** 2:1.1.0.2-5 0
500 http://ftp.fr.debian.org etch/main Packages
100 /var/lib/dpkg/status

Cela semble etre similaire a l'exception de cette version 1:7.3+10 0
du xbase-client.

Merci pour votre aide et merci gregory pour le xorg.conf, je pense
qu'il va bien m'aider.

Je viens de relire le fil de discussion sur le Xinerama, dans le
dernier mail il y a cela:

"- la résolution verticale doit être la même sur les 2 écrans (le 2 iem est
limité à 1024x768), ça réduit fortement l'espace de travail (le com ble pour
du xinérama ;-) )
- glxinfo fige 'matériellement' mon pc (appui sur touche 'reset' nécess aire
pour repartir)

est-il possible d'avoir une résolution différente entre les 2 écrans en
mergefb ? (en etch)"

As tu trouve une solution pour des tailles differentes? sinon je ne
vais avoir du mal a faire cohabiter mais 2 ecrans (19" en 1280x1024 et
22" en 1680x1050)

Mon PC aussi ce figer parfois quand j'avais mon ancienne Matrox G450
est ce que ca pouvais venir de glxinfo? avec la carte actuelle Radeon
9250 ca ne m'est pas encore arrive mais je prefere demander au cas ou.



Bonne soiree et Bon Week end
Hugues

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
François Boisson
Le #16548741
Le Thu, 14 Aug 2008 22:16:24 +0200
"Hugues MORIN"
Cela semble etre similaire a l'exception de cette version 1:7.3+10 0
du xbase-client.


Sauf que ma version est 7.1.ds1-2, ce qui est étonnant est que dans le chroot
32 bits -où je n'ai effectué aucun backport et où c'est du etch pur jus et
xrandr renvoit la version 1.2. Je pense que xrandr est juste une interface
avec le serveur X et quye la version dépend du serveur X (en fait c'est la
seul explication que je vois à ce phénomène). En clair, comme j'ai

ii xserver-xorg 7.3+10 the X.Org X server

par un backport perso, je pense que xrandr est juste une interface de dialogue
avec le serveur X et que c'est lui qui répond. 5Sinon je ne comprend pas).

Ce que ça donne sur le 32 bits chroot etch pur jus:

bling:/# apt-cache policy xbase-clients libxrandr2 xbase-clients:
Installé : 1:7.1.ds1-2
Candidat : 1:7.1.ds1-2
Table de version :
1:7.3+14 0
97 http://ftp.fr.debian.org lenny/main Packages
95 http://ftp.fr.debian.org sid/main Packages
*** 1:7.1.ds1-2 0
986 http://ftp.fr.debian.org etch/main Packages
100 /var/lib/dpkg/status
libxrandr2:
Installé : 2:1.1.0.2-5
Candidat : 2:1.1.0.2-5
Table de version :
2:1.2.3-1 0
97 http://ftp.fr.debian.org lenny/main Packages
95 http://ftp.fr.debian.org sid/main Packages
*** 2:1.1.0.2-5 0
986 http://ftp.fr.debian.org etch/main Packages
100 /var/lib/dpkg/status
bling:/# xrandr -v
Server reports RandR version 1.2
bling:/#

François Boisson

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Grégory BULOT
Le #16549911
Hugues MORIN a écrit :
As tu trouve une solution pour des tailles differentes? sinon je ne
vais avoir du mal a faire cohabiter mais 2 ecrans (19" en 1280x1024 et
22" en 1680x1050)



le xorg.conf envoyé fonctionne en résolution différente (c'est merged fb
qui le permet, pas xinerama) dans ce cas

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Hugues MORIN
Le #16553221
Salut

Ca y est ca marche et bien en plus :-))

Seul hic, j'ai du faire une erreur quelques part, j'ai plus de
son.....Je suis arrive a le configurer une fois j'y arrivera bien de
nouveau.

Sinon voila le xorg.conf qui fonctionne pour moi:

Section "Device"
Identifier "MergedFBDevice"
Driver "radeon"
BusID "PCI:1:0:0"
Option "MergedFB" "true"
Option "CRT2Position" "leftOf"
Option "MetaModes" "1680x1050-1280x1024 1280x1024-1280x1024
1152x870-1024x768 1152x768-1024x768"
# Option "OverlayOnCRTC2" "true"
Option "MergedNonRectangular" "true"
Option "MergedXineramaCRT2IsScreen0" "false" #
determines which screen is going to be the primary screen; value can
be "true" or "false"
# Option "VideoOverlay" "on"
# Option "OpenGLOverlay" "off"
Option "MonitorLayout" "TDMS,TMDS"
Option "EnablePageFlip" "True"
Option "AGPMode" "4"
# Option "AGPFastWrite" "True"
EndSection


Section "Monitor"
Identifier "MergedFBMonitor"
# Option "VendorName" "Hyundai & Daewoo"
# Option "ModelName" "B91A & Sensy 22"
Option "DPMS"
EndSection


Section "Screen"
Identifier "MergedFBScreen"
Device "MergedFBDevice"
Monitor "MergedFBMonitor"
defaultDepth 24
SubSection "Display"
Depth 24
Modes "1680x1050" "1280x1024" "1152x864" "1152x870"
"1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
#ViewPort 0 0
virtual 2960 1050
EndSubSection
EndSection


Section "ServerLayout"
Identifier "Default Layout mergedfb"
Option "MergedFB" "true"
Screen "MergedFBScreen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection


Section "DRI"
Mode 0666
EndSection

Le DRI a l'air de fonctionner, et les seuls "warning" que j'ai dans le
xorg.0.log sont comme celui-ci:

(WW) AIGLX: 3D driver claims to not support visual 0x23

Je suppose que c'est du a la limitation de 2048x2048 pour la 3D.

Une derniere question, est-il possible de faire un xorg.conf en
fonction de l'utilisateur actif? Et si c'est possible de le faire,
auriez vous des liens qui traite de ce sujet?

Encore merci pour votre aide

Bonne journee

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme