majuscule

Le
Humanum
Bonjour,
Je souhaite simplifier la formule suivant, éviter le OU:

SI(OU(GAUCHE(B24;2)="HN";GAUCHE(B24;2)="hn");REMPLACER(B24;1;2;"");B24)

Le OU permet d'accepter la saisie en B24 soit en minuscule soit en
majuscule, n'y a t-il pas un autre moyen?
L'objectif de ma formule est d'extraire la valeur numérique qui fait
suite à "HN" et uniquement "HN". Cette valeur sera utilisé dans une
autre formule.

Merci d'avance,

Humanum
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #20708551
Bonsoir,
=SI(majuscule(GAUCHE(B24;2)="HN");REMPLACER(B24;1;2;"");B24)
devrait pouvoir convenir
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"Humanum" news:4b1be6b2$0$17506$
Bonjour,
Je souhaite simplifier la formule suivant, éviter le OU:

SI(OU(GAUCHE(B24;2)="HN";GAUCHE(B24;2)="hn");REMPLACER(B24;1;2;"");B24)

Le OU permet d'accepter la saisie en B24 soit en minuscule soit en
majuscule, n'y a t-il pas un autre moyen?
L'objectif de ma formule est d'extraire la valeur numérique qui fait suite
à "HN" et uniquement "HN". Cette valeur sera utilisé dans une autre
formule.

Merci d'avance,

Humanum


FS
Le #20708691
Bonsoir,

Par exemple :
=SI(MAJUSCULE(GAUCHE(B24;2))="HN";REMPLACER(B24;1;2;"");B24)

ou, à peine plus court :
=SI(GAUCHE(B24;2)={"HN";"hn"};DROITE(B24;NBCAR(B24)-2);B24)

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

Humanum a écrit :
Bonjour,
Je souhaite simplifier la formule suivant, éviter le OU:

SI(OU(GAUCHE(B24;2)="HN";GAUCHE(B24;2)="hn");REMPLACER(B24;1;2;"");B24)

Le OU permet d'accepter la saisie en B24 soit en minuscule soit en
majuscule, n'y a t-il pas un autre moyen?
L'objectif de ma formule est d'extraire la valeur numérique qui fait
suite à "HN" et uniquement "HN". Cette valeur sera utilisé dans une
autre formule.

Merci d'avance,

Humanum


Humanum
Le #20708681
Arf!

Comme bien souvent, une fois la réponse connue, c'est évident!

Grand merci,

Philippe.R a écrit :
Bonsoir,
=SI(majuscule(GAUCHE(B24;2)="HN");REMPLACER(B24;1;2;"");B24)
devrait pouvoir convenir


Humanum
Le #20708671
Merci Frédéric,

Dans la 2d solution, j'apprends que les {} agissent comme une fonction
OU, cela me parrait pratique à utiliser à l'avenir.

Peut on imaginer une multitude d'argument?
ex:{"AT";"HN";A$3$;2009;12;"TOTO"}

Cdt,
Jérôme

FS a écrit :
Bonsoir,

Par exemple :
=SI(MAJUSCULE(GAUCHE(B24;2))="HN";REMPLACER(B24;1;2;"");B24)

ou, à peine plus court :
=SI(GAUCHE(B24;2)={"HN";"hn"};DROITE(B24;NBCAR(B24)-2);B24)

FS


ChrisV
Le #20709591
Bonjour Humanum,

Sans doute un peu plus ésotérique que mes petits camarades...(que je salue
d'ailleurs bien sincèrement au passage :)
mais je n'ai pu résister au jeu du : "qui a la plus courte", qui a fait la
renommée du mpfe et surtout celle du président auto-proclamé du COIN. (que
je salue également bien amicalement :)

=STXT(B2;2*NB.SI(B2;"hn*")+1;9^9)


ChrisV
[...de passage]



"Humanum" 4b1be6b2$0$17506$
Bonjour,
Je souhaite simplifier la formule suivant, éviter le OU:

SI(OU(GAUCHE(B24;2)="HN";GAUCHE(B24;2)="hn");REMPLACER(B24;1;2;"");B24)

Le OU permet d'accepter la saisie en B24 soit en minuscule soit en
majuscule, n'y a t-il pas un autre moyen?
L'objectif de ma formule est d'extraire la valeur numérique qui fait suite
à "HN" et uniquement "HN". Cette valeur sera utilisé dans une autre
formule.

Merci d'avance,

Humanum


FS
Le #20709851
:)

Reviens quand tu veux !

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

ChrisV a écrit :
Bonjour Humanum,

Sans doute un peu plus ésotérique que mes petits camarades...(que je salue
d'ailleurs bien sincèrement au passage :)
mais je n'ai pu résister au jeu du : "qui a la plus courte", qui a fait la
renommée du mpfe et surtout celle du président auto-proclamé du COIN. (que
je salue également bien amicalement :)

=STXT(B2;2*NB.SI(B2;"hn*")+1;9^9)


ChrisV
[...de passage]



"Humanum" 4b1be6b2$0$17506$
Bonjour,
Je souhaite simplifier la formule suivant, éviter le OU:

SI(OU(GAUCHE(B24;2)="HN";GAUCHE(B24;2)="hn");REMPLACER(B24;1;2;"");B24)

Le OU permet d'accepter la saisie en B24 soit en minuscule soit en
majuscule, n'y a t-il pas un autre moyen?
L'objectif de ma formule est d'extraire la valeur numérique qui fait suite
à "HN" et uniquement "HN". Cette valeur sera utilisé dans une autre
formule.

Merci d'avance,

Humanum






Mgr.Abile
Le #20710261
Bénis sois tu pour cette fort belle obole !
Ce n'est pas Banni qui dira le contraire
--
News://news.microsoft.com/microsoft.public.fr.excel
Allez en paix
T.Abile
"ChrisV" news:%
Bonjour Humanum,

Sans doute un peu plus ésotérique que mes petits camarades...(que je salue
d'ailleurs bien sincèrement au passage :)
mais je n'ai pu résister au jeu du : "qui a la plus courte", qui a fait la
renommée du mpfe et surtout celle du président auto-proclamé du COIN. (que
je salue également bien amicalement :)

=STXT(B2;2*NB.SI(B2;"hn*")+1;9^9)


ChrisV
[...de passage]



"Humanum" 4b1be6b2$0$17506$
Bonjour,
Je souhaite simplifier la formule suivant, éviter le OU:

SI(OU(GAUCHE(B24;2)="HN";GAUCHE(B24;2)="hn");REMPLACER(B24;1;2;"");B24)

Le OU permet d'accepter la saisie en B24 soit en minuscule soit en
majuscule, n'y a t-il pas un autre moyen?
L'objectif de ma formule est d'extraire la valeur numérique qui fait
suite à "HN" et uniquement "HN". Cette valeur sera utilisé dans une autre
formule.

Merci d'avance,

Humanum






Humanum
Le #20710901
Bravo,
évidement ça marche, mais je suis incapable de faire une explication de
texte...de formule.

Jérôme

ChrisV a écrit :
Bonjour Humanum,

Sans doute un peu plus ésotérique que mes petits camarades...(que je salue
d'ailleurs bien sincèrement au passage :)
mais je n'ai pu résister au jeu du : "qui a la plus courte", qui a fait la
renommée du mpfe et surtout celle du président auto-proclamé du COIN. (que
je salue également bien amicalement :)

=STXT(B2;2*NB.SI(B2;"hn*")+1;9^9)


ChrisV
[...de passage]



"Humanum" 4b1be6b2$0$17506$

Bonjour,
Je souhaite simplifier la formule suivant, éviter le OU:

SI(OU(GAUCHE(B24;2)="HN";GAUCHE(B24;2)="hn");REMPLACER(B24;1;2;"");B24)

Le OU permet d'accepter la saisie en B24 soit en minuscule soit en
majuscule, n'y a t-il pas un autre moyen?
L'objectif de ma formule est d'extraire la valeur numérique qui fait suite
à "HN" et uniquement "HN". Cette valeur sera utilisé dans une autre
formule.

Merci d'avance,

Humanum







Humanum
Le #20711011
Re Re bonjour,

Apres plusieurs échecs pour imbriquer l'une ou l'autre des formules que
vous m'avez créer, j'ai fini par comprendre que la valeur retournée
était du texte!

du coup la parade est CNUM() mais cela ne marche que si des nombres sont
extraits... du coup j'en suis à cette formule ou le ESTNUM() n'est pas
le bon choix puisqu'il retournera toujours FAUX, mais je sèche:

=SI(ESTNUM(STXT(B25;2*NB.SI(B25;"hn*")+1;99));CNUM(STXT(B25;2*NB.SI(B25;"hn*")+1;99));B25)

Cela dit je suis sans doute sur la mauvaise voie, je souhaite faire la
somme des nombres succedants "hn" dans sur une plage données, exemple:
A1=hn2;A2=toto;A3=hn3;A4=5
résultat = 5 (format numérique)

Bonne nuit,
Jérôme

PS: ne m'en veuillez pas si je ne réponds pas dans la journée, je ne me
connecte que le soir.


Humanum a écrit :
Bonjour,
Je souhaite simplifier la formule suivant, éviter le OU:

SI(OU(GAUCHE(B24;2)="HN";GAUCHE(B24;2)="hn");REMPLACER(B24;1;2;"");B24)

Le OU permet d'accepter la saisie en B24 soit en minuscule soit en
majuscule, n'y a t-il pas un autre moyen?
L'objectif de ma formule est d'extraire la valeur numérique qui fait
suite à "HN" et uniquement "HN". Cette valeur sera utilisé dans une
autre formule.

Merci d'avance,

Humanum


FS
Le #20711261
Re,

Les formules proposées peuvent renvoyer un nombre en leur appliquant une
opération neutre.
Par exemple en colonne B (si tes données sont en colonne A) :

=SI(GAUCHE(A1;2)={"HN";"hn"};DROITE(A1;NBCAR(A1)-2);0)*1

ou

=STXT(A1;2*NB.SI(A1;"hn*")+1;99)*1

ou encore

=SI(MAJUSCULE(GAUCHE(A1;2)="HN");REMPLACER(A1;1;2;"");0)*1

Tu peux ensuite faire la somme de la colonne B.
Un peu plus compliqué avec la formule de ChrisV, qui doit tester d'abord
le résultat afin d'éviter une erreur et peut devenir qqchose comme (la
plus longue :) :

=SI(ESTNUM(STXT(A1;2*NB.SI(A1;"hn*")+1;99)*1);STXT(A1;2*NB.SI(A1;"hn*")+1;99)*1;0)

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

Humanum a écrit :
Re Re bonjour,

Apres plusieurs échecs pour imbriquer l'une ou l'autre des formules que
vous m'avez créer, j'ai fini par comprendre que la valeur retournée
était du texte!

du coup la parade est CNUM() mais cela ne marche que si des nombres sont
extraits... du coup j'en suis à cette formule ou le ESTNUM() n'est pas
le bon choix puisqu'il retournera toujours FAUX, mais je sèche:

=SI(ESTNUM(STXT(B25;2*NB.SI(B25;"hn*")+1;99));CNUM(STXT(B25;2*NB.SI(B25;"hn*")+1;99));B25)


Cela dit je suis sans doute sur la mauvaise voie, je souhaite faire la
somme des nombres succedants "hn" dans sur une plage données, exemple:
A1=hn2;A2=toto;A3=hn3;A4=5
résultat = 5 (format numérique)

Bonne nuit,
Jérôme

PS: ne m'en veuillez pas si je ne réponds pas dans la journée, je ne me
connecte que le soir.


Humanum a écrit :
Bonjour,
Je souhaite simplifier la formule suivant, éviter le OU:

SI(OU(GAUCHE(B24;2)="HN";GAUCHE(B24;2)="hn");REMPLACER(B24;1;2;"");B24)

Le OU permet d'accepter la saisie en B24 soit en minuscule soit en
majuscule, n'y a t-il pas un autre moyen?
L'objectif de ma formule est d'extraire la valeur numérique qui fait
suite à "HN" et uniquement "HN". Cette valeur sera utilisé dans une
autre formule.

Merci d'avance,

Humanum




Publicité
Poster une réponse
Anonyme