Mauvais aiguillage de piste audio d'un video-DVD

Le
geo cherchetout
Bonjour,

Avec Devede, je crée un image iso de vidéo-DVD à partir d'une vidéo MPEG qui
ne possède qu'une piste audio. Devede nomme « 0 » cette piste audio et ne me
donne évidemment pas d'autre choix ni ne me demande dans quelle piste du DVD
résultant mettre le son. VLC lit parfaitement l'image iso obtenue mais le
son n'est audible que si je lui demande de lire la piste 2 (parmi 4), ce qui
n'est pas le choix par défaut. Mplayer est également muet par défaut.
Avant de graver mon DVD, j'aimerais savoir :

Un lecteur de DVD de salon lirait-il automatiquement le son de la piste 2 ?

Serait-il possible de recopier dans la piste 1 le contenu de la 2, de
préférence sans déconstruire l'image iso ? Ou de rebaptiser 1 la piste 2 ?

Si vous avez d'autres idées plus pertinentes, ne vous gênez pas
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #22647651
geo cherchetout , dans le message
Avec Devede, je crée un image iso de vidéo-DVD à partir d'une vidéo MPEG qui
ne possède qu'une piste audio. Devede nomme « 0 » cette piste audio et ne me
donne évidemment pas d'autre choix ni ne me demande dans quelle piste du DVD
résultant mettre le son. VLC lit parfaitement l'image iso obtenue mais le
son n'est audible que si je lui demande de lire la piste 2 (parmi 4), ce qui
n'est pas le choix par défaut. Mplayer est également muet par défaut.
Avant de graver mon DVD, j'aimerais savoir :

Un lecteur de DVD de salon lirait-il automatiquement le son de la piste 2 ?



Il n'y a pas de piste 2 d'un DVD, ni de piste 0. Les pistes audio d'un DVD
commencent à 128.

Donc déjà, tu as un problème dans ton diagnostic. Peux-tu nous montrer la
ligne de commande et la sortie de mplayer quand ça ne marche pas, et quand
ça marche ?
geo cherchetout
Le #22648321
Le 05/10/2010 18:56, *Nicolas George* a écrit fort à propos :

Il n'y a pas de piste 2 d'un DVD, ni de piste 0. Les pistes audio d'un
DVD commencent à 128.



Je l'ignorais, comme tant d'autres choses.

Donc déjà, tu as un problème dans ton diagnostic.



J'évoquais surtout les symptômes observés avec VLC, qui semblaient plus
faciles à interpréter, mais je reconnais avoir mal retenu le comportement de
mplayer. Fragilité du témoignage humain...

Peux-tu nous montrer la ligne de commande et la sortie de mplayer quand
ça ne marche pas,



$ mplayer Sensations.iso

J'ai alors droit à environ 8 secondes de son sans images pendant lesquelles
la sortie reste sobre puisque seules les valeurs de la dernière ligne
s'incrémentent :

$ mplayer Sensations.iso
MPlayer SVN-1.rc4.0.r30130.1plf2010.0-4.4.1 (C) 2000-2009 MPlayer Team
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not open config files /home/gerard/.lircrc and /etc/lirc/lircrc
mplayer: No such file or directory
Failed to read LIRC config file ~/.lircrc.

Playing Sensations.iso.
MPEG-PS file format detected.
VIDEO: MPEG2 720x576 (aspect 2) 25.000 fps 7501.2 kbps (937.6 kbyte/s)
========================================================================= Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat -1
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
========================================================================= ========================================================================= Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 224.0 kbit/14.58% (ratio: 28000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
========================================================================= AO: [pulse] Init failed: Connection refused
Failed to initialize audio driver 'pulse'
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 768x576 Planar YV12 [zoom]
A: 7.4 V: 7.4 A-V: 0.034 ct: 0.619 204/204 4% 0% 1.1% 0 0

Ensuite, les lignes de message défilent à toute vitesse dont voici le début :

Too many video packets in the buffer: (4096 in 8169549 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Broken frame at 0x36258
A: 7.4 V: 7.4 A-V: 0.048 ct: 0.623 205/205 4% 0% 1.1% 0 0
Too many video packets in the buffer: (4096 in 8169549 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Broken frame at 0x36A38
A: 7.5 V: 7.4 A-V: 0.096 ct: 0.627 206/206 4% 0% 1.1% 0 0
Too many video packets in the buffer: (4096 in 8169559 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

etc

Je précise que l'emploi de l'option -ni n'y change rien.

et quand ça marche ?



Mince, v'la que ça se met à marcher si je donne un petit coup sur la touche
flêche droite ! Mieux, si je le fais avant la fin des 8 secondes, la sortie
d'erreurs ne s'emballe plus et la lecture se poursuit sans encombre jusqu'à
la fin.

Puis-je graver mon image avec quelque chance de ne pas sacrifier une galette
vierge pour rien ?
geo cherchetout
Le #22648571
Le 05/10/2010 22:08, j'ai écrit :

J'évoquais surtout les symptômes observés avec VLC, qui semblaient plus
faciles à interpréter, mais je reconnais avoir mal retenu le comportement de
mplayer. Fragilité du témoignage humain...



Mille zexcuses, c'est peut-être pis que cela. Je ne suis plus très sûr que
mes différents essais de lecture aient été faits avec la même images iso,
car j'en avais fait deux avec des différences d'options dans Devede. Je
reviendrai demain quand j'aurai refait la première, présentement effacée.
Trop fatigué ce soir...
Nicolas George
Le #22648561
geo cherchetout , dans le message
$ mplayer Sensations.iso



mplayer -dvd-device Sensations.iso dvd://1

(jamais testé avec une image ISO ; si tu as le répertoire à partir duquel
elle a été construite c'est mieux ; sinon tu peux la monter en loopback)
geo cherchetout
Le #22650191
Le 05/10/2010 23:19, *Nicolas George* a écrit fort à propos :

mplayer -dvd-device Sensations.iso dvd://1



Mplayer se referme très vite avec un message se terminant par ces lignes :

Broken frame at 0xFC0
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 768x576 Planar YV12 [zoom]
[mpeg2video @ 0x8900d80]ac-tex damaged at 9 11
[mpeg2video @ 0x8900d80]Warning MVs not available
[mpeg2video @ 0x8900d80]concealing 1125 DC, 1125 AC, 1125 MV errors
A: 0.4 V: 1.1 A-V: -0.672 ct: -0.050 24/ 24 16% 4% 1.1% 0 0

Exiting... (End of file)

Par contre
mplayer -dvd-device Sensations.iso dvd://2
marche au poil. Même pas besoin de l'aider à démarrer avec la touche flêche
droite. :-)

Et cela marche aussi bien avec les deux types d'images fabriquées au cours
de mes différents essais. (Car Devede offre le choix de réencoder les flux
audio et vidéo où de les conserver tels quels et j'ignorais initialement que
cette dernière option conviendrait.)

(jamais testé avec une image ISO ; si tu as le répertoire à partir duquel
elle a été construite c'est mieux ;



Je ne demande pas à devede de garder les fichiers temporaires faute de place
dans la partition. Le fichier mpeg d'origine se lit sans problème.

sinon tu peux la monter en loopback

J'y pensais, mais puisque nos lecteurs habituels acceptent les images iso...
geo cherchetout
Le #22651021
Le 06/10/2010 14:23, *geo cherchetout* a écrit :

Par contre
mplayer -dvd-device Sensations.iso dvd://2
marche au poil.



Ayant à présent créé une image iso réunissant plusieurs séquences, j'observe
que le chiffre 2 donne accès directement à la première séquence, le chiffre
3 à la deuxième, etc.

VLC quand à lui est toujours muet tant que je ne lui demande pas de lire la
piste audio 2, quel que soit le titre visionné.

J'ai finalement gravé l'image. Dès que j'ai accès à un lecteur de salon, je
vous tiens au courant du résultat.
geo cherchetout
Le #22651801
Le 06/10/2010 17:58, *geo cherchetout* a écrit fort à propos :

J'ai finalement gravé l'image. Dès que j'ai accès à un lecteur de salon, je
vous tiens au courant du résultat.



Aux innocents les mains pleines. Le vieux lecteur de mon copain René a lu le
DVD sans la moindre hésitation. Navigation dans le menu, son et image, tout
marche à la perfection. :-)
Publicité
Poster une réponse
Anonyme